API Key not enabled

Hello,

I have a cluster with 3 nodes of elasticsearch. In the first node I've installed kibana.

Configured TLS/SSL in all cluster nodes. And use credential to communicate with kibana and logstash.

My problem is about create alerting in kibana.

I create the kibana keys with this tools /bin/kibana-encryption-keys generate.

Copy output inside kibana.yml and restart them. But it didn't work.

image

I saw in API KEYS the informtion: API Key not enabled.

And when make the get /_security/api_key received this information:

image

How I enable this api key feature ?

My elasticsearch.yml:

image

I can use elasticsearch, kibana and metricbeat 7.17 version.

Everything working well, only i can't generate alarms.

Hi @SilasMuniz1 Please don't post screen shots of text... please post formatted text.

Looks You have not secured the elasticsearch HTTP endpoint 9200 with TLS therefore you can not create API Keys / The service is not enabled.

See Here

The API keys are created by the Elasticsearch API key service, which is automatically enabled when you configure TLS on the HTTP interface. Alternatively, you can explicitly enable the xpack.security.authc.api_key.enabled setting.

@stephenb

Sorry, I inside the picture because my elastic stack where in na place with i don't copy and past. Only make a printscreen. Sorry again.

I've insert xpack.security.authc.api_key.enabled: true in the elasticsearch.yml and the problem is solved.

Thank you a lot.

1 Like