API keys not enabled in Elasticsearch Contact your system administrator and refer to the docs(opens in a new tab or window) to enable API keys

API keys not enabled in Elasticsearch

Contact your system administrator to enable API keys.

how to resolve this?

Have you secured your cluster ? You need a certain level of security enabled to use API keys.

https://www.elastic.co/guide/en/elasticsearch/reference/current/secure-cluster.html

No , we configure only password but not configure HTTP and SSl.

we tried to configure the HTTP and SSl but that time Elasticsearch service are not started.

Have you at least configured TLS ? Otherwise API keys won't be enabled. You can do this without needing the https and ssl configuration.

https://www.elastic.co/guide/en/elasticsearch/reference/current/security-basic-setup.html

hello ,

we enable the TLS , please guide me for the next step for API Key.

You create API keys in Stack Management. Where do you want to use the keys and in what configuration?

You must have enable a configuration key somewhere to generate that error

1 Like