Auto-logout in Elastic managed service Kibana

Hi,
I'm presenting a Kibana dashboard on television and after like 6 hours the session automatically logouts and requires to log in again with username and password.
I'd like to disable the session from disconnection or in the worse case, to extend the timeout to the longest as possible. How can I do that? I looked at the Advanced Settings in Kibana but didn't find related settings.

Thanks!

Can anyone help, please?

Yes, you can set the idleTimeout or lifespan documented here: https://www.elastic.co/guide/en/kibana/current/security-settings-kb.html

@wylie Hi, thanks. I added the following property to the kibana.yml:
xpack.security.session.idleTimeout: 365d

It worked for 1 week and really no log out has occurred. But after that, it started logging out again every couple of hours ... is there any explanation why this happens?

It sounds like you might be running multiple Kibana instances: take a look at this advice about how to solve logouts with multiple instances.

@wylie I've checked the referred advice, I think it is not relevant in my case. I'm using Elastic Cloud.
That's all I see in the console:

I have one configuration file for all Kibana nodes. I have no other configuration files.
It worked perfectly for 1 week and for some reason something happened and then it started logging out again..

  1. Can you gather some logs related to the forced logout, from both ES and Kibana? You may need to set logging.verbose: true in the kibana.yml settings to collect enough detail

  2. What type of authentication are you using?

  3. Are you using any type of reverse proxy in front of Kibana?

  1. I set the logging.verbose: true in the kibana.yml. Where can I find the logs, so I will to send you?
  2. Authentication is done by users that are configured to have access to kibana.
  3. No

@wylie do you have any suggestions, please?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.