Disable Kibana Session Timeout

I have a dashboard displayed on a TV in my office that shows auto-refreshed stats through a Kibana dashboard. I am trying to disable the Kibana Session Timeout so that it never logs out, but the Kibana documentation doesn't actually say how to disable it. Additionally, I set it to 1000d but the TV logged out after 17 days which also didn't make much sense to me because the max timeout says it's 30 days.


xpack.security.session.lifespan: "1000d"

ELK Setup: Elastic Cloud
Version: 8.7.1

How can I prevent the TV from ever logging out?

Anyone know how to do this?

Hey @pocketcolin ,

You probably need to change xpack.security.session.idleTimeout as well.

According to docs, setting to 0 sessions will never expire due to inactivity

Best, Dima

Thanks for the suggestion, Dima! I'll give that a try and see if it fixes it.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.