Bad request when refreshing index pattern fields

After trying to setup ILM on my elasticsearch index i was suddenly no longer able to refresh index patterns. I just get Error fetching fields for index pattern... and the error is always Bad request, but it refers to different js lines. The most recent one was: Error: Bad Request
at If I open the console I see something this:
GET*&meta_fields=_source 400 (Bad Request)
but I don't know how to get any useful information out of the console.

I've now tried deleting all my indexes and starting completely from scratch, but the error still persists.

I tried turning on verbouse logging, but I can't get anything useful out of that. All I see there is:
"get","headers":{"host":"","connection":"keep-alive","kbn-version":"7.6.0","user-agent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.116
Safari/537.36","content-type":"application/json","accept":"/","referer":"","accept-encoding":"gzip, deflate","accept-language":"en-US,en;q=0.9,nb;q=0.8,en-GB;q=0.7"},"re
moteAddress":"","userAgent":"","referer":""},"res":{"statusCode":400,"responseTime":51,"contentLength":9},"message":"GET /api/index_patterns/_fi
elds_for_wildcard?pattern=corvus*&meta_fields=_source 400 51ms - 9.0B"}

I have also tried creating a very basic index where I just manually inserted four documents with simple test messages and I was still unable to reload fields for an index pattern matching this test index

I have now tried reinstalling Kibana with sudo apt-get remove --purge kibana and then sudo apt-get install kibana. That did not make a difference either

Hi, are there any clues in the Elasticsearch logs? Sometimes an error in a response from a Kibana API is a pass-through of an Elasticsearch error.

From what I can remember, I didn't find any errors in the Elasticsearch logs (as far as I could tell). I ended up creating a new VM and setting up everything from scratch. Not having this problem in the new VM.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.