[7.5] There was an error retrieving the index pattern

I just updated to 7.4.0 -> 7.5.0 and in uptime I now see below the query bar the warning

There was an error retrieving the index pattern

But I can see all 100+ monitors and can filter on location. But the query bar is grey out and is disabled.
I have made sure that the 2 heartbeats are updated to 7.5 and rerun the setup just to make sure.
I also tried to delete all kibana indexes and restart kibana no such luck

Of note is that this is running in a air gaped environment and so I disabled newsfeed and telemetry

Is this error persisting? This is certainly an odd error that we haven't seen before. The air gapped nature of your environment shouldn't be causing issues here, so I'm a bit surprised.

Can you open the browser debug and add any detail that may be present in the browser console if possible? If possible a peek into the network debugger in your browser may also yield some interesting error messages.

Nothing in the console execpt when it tries to get the data
POST https:///kibana/api/uptime/logOverview 400
POST https:///kibana/api/uptime/index_pattern 400

Network log:
Both requests come back as
{statusCode: 400, error: "Bad Request", message: "Bad Request"}

Saw nothing strange in the server log

same here.

Nothing in the console execpt when it tries to get the data
POST https:///kibana/api/uptime/logOverview 400
POST https:///kibana/api/uptime/index_pattern 400

Network log:
Both requests come back as
{statusCode: 400, error: "Bad Request", message: "Bad Request"}

I've tried to replicate this, but have been unable to do so using version 7.5.0.

Is there any more detail in the kibana server debug logs? My hunch is that whatever is driving this issue is being logged there.

That aside, are there any unusual security settings you've applied? Those shouldn't come back as 400 errors, but I'm trying to cover all the bases here.

No security the only thing we had heartbeat index with 2 weeks of data
I could not see any errors in the log.

I tested a fresh copy of 7.5 on my local macheine with no data and had no problems looks like uptime correctly created the index pattern.

To resolve the above issue please follow the below steps:

vim /etc/kibana/kibana.yml

#xpack.security.enabled:

Save and restart the kibana service.

1 Like

thanks for the tip it works uptime does not give an error anymore. Merci

1 Like

To make sure I understand, disabling security worked here? I assume then that you had security enabled on Kibana, but not enabled on Elasticsearch and that was the source of the problem. Is that correct?

Yes, i changed
vim /etc/kibana/kibana.yml
xpack.security.enabled: false to #xpack.security.enabled:

that worked for me.

But i had both kibana.yml and elasticsearch.yml with:
xpack.security.enabled: false

Interesting, thanks for the report!