Beats dashboards for TopBeat not creating dashboard


#1

I'm following the instruction on this page on a Windows machine:
https://www.elastic.co/guide/en/beats/libbeat/1.3/load-kibana-dashboards.html

When I try to load the dashboards using Powershell command: .\load.ps1
All the Visualizations seem to load, Everything seems to execute well until it gets to the part where the dashboards are getting loaded, it seems TopBeat (the one I need) gives me the error below. So the Topbeat dashboard does not get created. Here is the error it displays:

Invoke-RestMethod : {"error":{"root_cause":[{"type":"mapper_parsing_exception","reason":"failed to parse [timeFrom]
parse [timeFrom]","caused_by":{"type":"illegal_argument_exception","reason":"Invalid format: "now-15m""}},"status
Au caractère C:\Users\406556\Downloads\beats-dashboards-1.3.1\beats-dashboards-1.3.1\load.ps1:109 : 3

  • &$CURL -Headers $headers -Uri "$ELASTICSEARCH/$KIBANA_INDEX/dashboard/$name" - ...
  •   + CategoryInfo          : InvalidOperation : (System.Net.HttpWebRequest:HttpWebRequest) [Invoke-RestMethod], We
      + FullyQualifiedErrorId : WebCmdletWebResponseException,Microsoft.PowerShell.Commands.InvokeRestMethodCommand

(Monica Sarbu) #2

What Elasticsearch version are you using?


#3

I'm using version 2.3.3.


(Joseph Dissmeyer) #4

@rayc999, You might want to get the latest release of the dashboard samples.
I was able to load the sample Kibana dashboards downloaded from here https://www.elastic.co/guide/en/beats/libbeat/current/dashboard-load-options.html using my Windows 10 Pro laptop. Here is exactly what I did:

  1. Downloaded the ZIP package - http://download.elastic.co/beats/dashboards/beats-dashboards-1.3.1.zip
  2. Extract to local folder.
  3. Open PS shell, nav to the folder.
  4. Execute the following:

./load.ps1 -url http://ES_SERVER_NAME:9200

*** I have Shield installed in my ES instance. So my syntax needs to include the username and password along with the URL. Also, make sure you are pointing to the Elasticsearch listening port (default port is 9200) and NOT the Kibana listening port (which is typically 5601)

.\load.ps1 -url http://server_name:9200 -u username:password

Give that a try. Hope this helps!


(Monica Sarbu) #5

@rayc999 I have tried to reproduce the issue without any success. Only the Topbeat dashboard fails as it's the only one that has a time interval associated. I have created a pull request to remove the timeFrom that raised the error. Please try the zip archive with the dashboards, available in the pull request, and let me know if this works for you.


#6

I downloaded the new version from the pull request. But do I run the entire script again? I'm not sure if this will create duplicates.


(Monica Sarbu) #7

Yes, you can run the script again from the provided zip archive, and it will overwrite the current dashboards with the same name.


(system) #8

This topic was automatically closed after 21 days. New replies are no longer allowed.