Can not run kibana by source code

Hi,
I try to run kibana by source code ,but it seem no work well

This my step:
Step1
Download the kibana source code
download from https://github.com/elastic/kibana/archive/v7.4.2.zip
and unzip to d:\elk\kibana
Step2
Install nodejs( same version in .node-version file) and yarn
Step3
Run yarn kbn bootstrap
command line "cd" to the d:\elk\kibana
and run " yarn kbn bootstrap "
It show "Bootstrapping completed" in the end

Step4
Config the kibana.yml
server.port: 5601
server.host: "192.168.32.22"
elasticsearch.hosts: ["http://192.168.32.33:9200"]
the elasticsearch work well ,version :7.4.2

Setp 5
Run "yarn start"
it no see any error info ,
and in the end of the consol print,
it show "Optimization success in xxx seconds"
But no see any info like "http server running at http://xxx:5601"

Setp5
And use google Chrome and ie to visit "http://192.168.32.22:5601" ,it no any response

if i miss something ?
thanks for your response;

Hi

Could you provide some details about the environment you're trying to run Kibana?

Also you could try to start with yarn start --verbose to get more details where it's stuck (there should be a message that the server is running)

Thx & Best,
Matthias

thank you for quickly response;
my os :win7 64 ,
I can run the kibana(7.4.2) well by the release bin(kibana-7.4.2-windows-x86_64.zip)
but run by source code fail,

I run " yarn start --verbose >> aaa.txt"
i can see some "message":"Checking Elasticsearch version" in the aaa.txt
but i cannot find any error info in this;

Unfortunately this forum cannot upload attachment(txt)

Please try to following

remove your kibana.yml or rename it to make in inactive.
run yarn es snapshot, it's downloading and starting ES, then run yarn start. This should work.

Best,
Matthias

Thank for reply
i run " yarn es snapshot" ,but show "ERROR Snapshots for 7.4.2/latest are not available"

Now i try to use version:7.8.0 source code (download from:https://codeload.github.com/elastic/kibana/zip/v7.8.0)
and run "yarn kbn bootstrap "
but show

"ERROR Error: Command failed with exit code 128: git log -n 1 --pretty=format:%H -- D:\ELK\Kibana5_780\kibana
fatal: your current branch 'master' does not have any commits yet"

In fact , i only want to write some plugin and no want to commit anything to github right now;
How to handle this ?ths.

I try V7.8.0 continue;

I run some git command "git init ","git add." "git commit -ms "xx" "
next run "yarn kbn bootstrap" ,this step OK

next i try to run "yarn start " and visit by browser ,but no andy response,
that result the same as v7.4.2;
i try to rename kinanba.yml file ,and run "yarn es snapshot"
but it seem can't connect to the "https://storage.googleapis.com/kibana-ci-es-snapshots-daily/7.8.0/manifest-latest-verified.json"

ERROR FetchError: request to https://storage.googleapis.com/kibana-ci-es-snapshots-daily/7.8.0/manifest-latest-verified.json failed, reason: connect ETIMEDOUT 34.64.4.16:443

but very strange ,i use browser to visit the https://storage.googleapis.com/kibana-ci-es-snapshots-daily/7.8.0/manifest-latest-verified.json , it can visit and can download the manifest-latest-verified.json

I think i know why;
Because when run "yarn start" ,it still download something,like "chromium-312d84c-darwin.zip"
and the download speed very very slow,maybe 30--60 minute
so the kibana still no ready for visit ,so kibana have no any reponse when visit by browser;
when download finished,the kibana can visit;

I think it's very unreasonable,maybe can print some info in the console when download something or download all file before run "yarn start"(maybe download when run "yarn kbn bootstrap")