Cannot create visulization on Kibana

Hi, I'm using elk v:7.5.0, i uploaded my indexes correctly, but when i want to create a visualization all the indexs are in the list but i can't select any of them.

I don't know what's the problem, i can see the hint on the console and on the discover menu also, but i can't select any one to create a visualization

Would it be possible to share screenshots of the behavior?

Is this happening in Lens, which was introduced in 7.5 or on any of the older aggregation based visualizations?

1 Like

No i'm not using lens, i choose visualize then create a new visualization , a list of index appears but i can't select from this list.


but i can't select this index

Thanks for the screenshots, do you mean you cannot click in the test_host index pattern? Do you see any errors in the browser console?

Have you tried to enable the Kibana sample data to check if the new index patterns are also unavailable?

1 Like

Yes i cannot click " test_host

Please be aware that 7.5 is nearly a year past EOL. You should really upgrade.

2 Likes

Hi @warkolm thanks for your reply, I have some questions:
-If I update the version, will the problem be solved.
-Is there a method to update without losing my indexes.

Besides EOL problem, it seems you did not create index pattern. You need to define index pattern to utilize index in visualization.

1 Like

Thanks for your reply @Tomo_M I have already created the index pattern and in that time I was not able to select it from the index tab on visualization.
The problem was only EOL, because when I upgrade the version, everthing is working fine.

1 Like