Cannot Edit the configuration of Logs Stream on Kibana UI

Does anyone know how to solve this?

It seems I can't change the settings of Logs Stream. The input field not clickable.
I just want to change the Log indices.

I tried to restart my elastic and kibana but it's still the same.

I just found this topic as I have the exact same issue since a while but could not find a solution so far.

On the Logs > Stream page, I get an error message saying that the data view "logs-*" does not exist:


My logs data view is named "logs". I already tried to rename it to "logs-*" but the same issue still exists.

Do you already have a solution for that issue or are you still looking for one just like me?

I found a solution for this error.
When you open this dialog, you get an error related to a data view with a specific ID that cannot be found.
The solution is to create a new data view specifying the ID your Kibana is missing:

I did this and could recover this page.

1 Like

But how to find out which ID is missing? In my case, the missing ID is not shown anywhere. The only hint is that it tries to locate a data view named logs-* which exists but probably with a different ID.

Ah! In my case the dialog was describing which data view ID was trying to open.
Did you try creating a data view named "logs-*" ?
I already had one data view with that name, but the ID was not the one the system was looking for.

Yes, I have a data view named logs-* but I don't know which ID the system is looking for. And I also could not find anything in the advanced settings or saved objects.

I am using version 8.11.2. Maybe there is a difference on the versions and mine does inform about the ID the system is looking for.
I cannot think about any other reason.

I had the same issue when I upgrade from 8.8.2 to 8.12.1 and this solution fixed the issue for me.