Cannot install x-pack to Kibana due to no valid URL


(Andreas Bernard) #1

Good morning,

I'm absolutely new to the whole Stack, so please be patient with my lack of knowledge. :wink:

Trying to install Elasticsearch, Kibana, Logstash and Winlogbeat to get a whiff of how to handle it all, I run into some early problems.

When trying to install the x-pack plugin to Kibana, it fails due to "No valid URL specified".

The url that is autmatically attempted to use is https://artifacts/elastic.co/downloads/kibana-plugins/x-pack/x-pack-5.0.0.zip which should work.

Sadly, this stops me cold in the tracks, as I can't authenticate at Kibana without x-pack.

Any suggestions?

EDIT: seems I got a similar problem with the elasticsearch-plugin as well: Connection refused.


(Lee Drengenberg) #2

Hi Andreas,

Can you paste the command you ran and the output here? And the OS you're on.

Thanks,
Lee


(Court Ewing) #3

The easiest way to install x-pack is to not use a URL at all:

bin/kibana-plugin install x-pack

I recommend following the installation instructions in the X-Pack docs: https://www.elastic.co/guide/en/x-pack/current/installing-xpack.html


(Andreas Bernard) #4

from inside the bin folder on a Win 7 Enterprise:

kibana-plugin install x-pack

So I didn't use an URL, it was supplied by the kibana-plugin.bat itself but still didn't work.


(Lee Drengenberg) #5

Sorry you're still having troubles. Can you paste the whole command and output here?

It should look like this;

D:\5.0.0\kibana>bin\kibana-plugin.bat install x-pack
Attempting to transfer from x-pack
Attempting to transfer from https://artifacts.elastic.co/downloads/kibana-plugins/x-pack/x-pack-5.0.0.zip
Transferring 56932561 bytes....................
Transfer complete
Retrieving metadata from plugin archive
Extracting plugin archive
Extraction complete
Optimizing and caching browser bundles...
Plugin installation complete

(Andreas Bernard) #6
my_kibana_Path\bin>kibana-plugin install x-pack
Attempting to transfer from x-pack
Attempting to transfer from https://artifacts.elastic.co/downloads/kibana-plugin
s/x-pack/x-pack-5.0.0.zip
Plugin installation was unsuccessful due to error "No valid url specified."

(Lee Drengenberg) #7

Hi Andreas,

The URL you have in your output is the same as mine. Are you behind a firewall or proxy? Can you try getting the x-pack-5.0.0.zip by using either wget or pasting that URL in your browser?

wget https://artifacts.elastic.co/downloads/kibana-plugins/x-pack/x-pack-5.0.0.zip

According to this page; https://www.elastic.co/guide/en/x-pack/current/installing-xpack.html
If you get that downloaded, you could install x-pack from the file like this;

kibana-plugin install file:///<the downloaded file with path>
But I tried it and never got this method to work. I'll file an issue on that.

But I think if you get it downloaded you can just unzip that x-pack-5.0.0.zip and put the x-pack folder from it into the plugins directory of Kibana and start or restart Kibana.

Thanks,
Lee


(Lee Drengenberg) #8

(Lee Drengenberg) #9

OK, so it turns out that the offline install of the Kibana x-pack does work on Ubuntu, but not Windows. I don't have a Mac to test on. So if you get the file downloaded you should be able to follow those offline install instructions for both Kibana and Elasticsearch.

The documentation implies that the same zip file includes both the Elasticsearch and Kibana x-pack plugins but that is not correct. The installers support that option but the 5.0 release has 2 separate zip files, one for each.


(Andreas Bernard) #10

Then I'll have to wait for this problem to be solved, or have some time for a more thorough look. Thank you.


(Lee Drengenberg) #11

Hi Andreas,

So I think the offline install should work fine assuming the wget worked for you. The only trick I figured out is that if you were on Windows you have to use a command like;

kibana-plugin.bat install file://c:/path/to/x-pack.zip (with only 2 slashes on the file://)

vs. Linux or Mac;
kibana-plugin.bat install file:///path/to/x-pack.zip (with normal 3 slashes on the file:///)

And a little more clarification on the zip files themselves.

This file does include both the Elasticsearch and Kibana plugins;
https://artifacts.elastic.co/downloads/packs/x-pack/x-pack-5.0.0.zip

This one only includes the Elasticsearch plugin;
https://artifacts.elastic.co/downloads/elasticsearch-plugins/x-pack/x-pack-5.0.0.zip

And this one only includes the Kibana plugin;
https://artifacts.elastic.co/downloads/kibana-plugins/x-pack/x-pack-5.0.0.zip

So if you were installing Elasticsearch and Kibana on 2 different machines it might make sense to get the 2 smaller zips. If you have both on 1 machine then just get the single zip file. Just be careful since the zip files are all named the same thing.

The Elasticsearch plugin zip is about 15MB
The Kibana plugin zip is about 55MB
The combined zip is about 70MB

Thanks,
Lee


(Murali) #12

Hi All,
I have install ELK Stack 5.2.0 working fine,

when i am trying to install X-pack to kibana
C:\ELK\kibana-5.2.0-windows-x86\kibana-5.2.0-windows-x86\bin >\kibana-plugin.bat install x-pack

after restarting my Kibana.bat file(C:\ELK\kibana-5.2.0-windows-x86\kibana-5.2.0-windows-x86\bin), facing below issue(please find attachment)

Unhandled rejection [illegal_arguments_exception] no endpoint or opeation is available at [_xpack]::{"path":/_xpack","statusCode":400


(Brandon Kobel) #13

@murali_choppa Did you install x-pack on elasticsearch as well? If this doesn't work, I'd suggest opening up a new discuss ticket for what you're seeing.


(system) #14