Cannot start Elasticsearch after upgrade to 2.0

I did a upgrade from 1.7.3 to 2.0 via apt-get and after this I cannot start it via init.d script.

[2015-10-30 11:37:36,442][INFO ][bootstrap ] es.default.config is no longer supported. elasticsearch.yml must be placed in the config directory and cannot be renamed.

When I check the init.d script it seems correct and the elasticsearch.yml is present in /etc/elasticsearch.

Could it be that you have the same issues like here:

I haven't installed Marvel.

I checked and found some difference between https://github.com/elastic/elasticsearch/blob/e95af69fb71d67c3fb2a2806da24214dc4805140/distribution/deb/src/main/packaging/init.d/elasticsearch and my local file, however if I replace mine with that one I get "Bad substitution" error

Yeah - the title of the issue is misleading. I meant the answer given here

might actually be related to your problem as well.

What exactly was the difference?

Isabel

I've tried to do a search for es.default.config in /etc/ but didn't find anything.

See https://www.diffnow.com/?report=0wh98.
Mine is to the left.

At least line 100 is what's giving you the parsing error.

On the one from repository?

Anyone else have any suggestions?

@tlrx gave a great answer there: https://github.com/elastic/elasticsearch/issues/14347#issuecomment-152946882

But I installed it via a packet manager, so as far as I understand I shouldn't start it that way?

Anyway, if I try I get errors about logging.

Anyone?

Bump.

Hi Did you run the migration check before running the upgrade of ES from 1.7 to 2.0