Elastisearch don't start with marvel plugin


(Xwilly Azel) #1

Hi,

I have installed the last version of elasticsearch on redhat5 with the
official rmp everything look fine (clean install).
After installation of the plugin marvel, my elasticsearch instance don't
start :

[2014-02-20 10:27:05,012][INFO ][node ] [sacchi]

version[1.0.0], pid[23465], build[a46900e/2014-02-12T16:18:34Z]
[2014-02-20 10:27:05,012][INFO ][node ] [sacchi]
initializing ...

[2014-02-20 10:27:05,015][ERROR][bootstrap ] {1.0.0}:
Initialization Failed ...**- NullPointerException[null]

When I disable the plugin (rename the directory plugin), everything work
fine.

[2014-02-20 10:32:18,910][INFO ][node ] [sacchi]

version[1.0.0], pid[24172], build[a46900e/2014-02-12T16:18:34Z]
[2014-02-20 10:32:18,910][INFO ][node ] [sacchi]
initializing ...
[2014-02-20 10:32:18,912][INFO ][plugins ] [sacchi]
loaded [], sites []
[2014-02-20 10:32:20,788][INFO ][node ] [sacchi]
initialized
[2014-02-20 10:32:20,788][INFO ][node ] [sacchi]
starting ...
[2014-02-20 10:32:20,863][INFO ][transport ] [sacchi]
bound_address {inet[/0.0.0.0:9300]}, publish_address {inet[/xxx:9300]}
[2014-02-20 10:32:23,893][INFO ][cluster.service ] [sacchi]
new_master
[sacchi][L3874aIMQYydHAKnoaKilw][eqds3uzsynlourvd001.equities.net.intra][inet[/10.30.194.71:9300]],
reason: zen-disco-join (elected_as_master)
[2014-02-20 10:32:23,914][INFO ][discovery ] [sacchi]
ges_search/L3874aIMQYydHAKnoaKilw
[2014-02-20 10:32:23,930][INFO ][http ] [sacchi]
bound_address {inet[/0.0.0.0:9200]}, publish_address {inet[/xxx:9200]}
[2014-02-20 10:32:23,936][INFO ][gateway ] [sacchi]
recovered [0] indices into cluster_state
[2014-02-20 10:32:23,937][INFO ][node ] [sacchi]
started

my version of java :

java version "1.6.0_45"

Java(TM) SE Runtime Environment (build 1.6.0_45-b06)

any idea, on the issue ?
Also it's possible to enable a mode debug for elasticsearh ?

regards,
will

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/7e3402da-bd7d-4be4-9887-62c2ca02c459%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Boaz Leskes) #2

Hi will,

Do you have any marvel specific settings in your elasticsearch.yml?

To enable debug logs in es (assuming you run it from the command line):

./bin/elasticsearch --logger.level=DEBUG

Let me know what you see.

Cheers,
Boaz

On Thursday, February 20, 2014 10:39:24 AM UTC+1, Xwilly Azel wrote:

Hi,

I have installed the last version of elasticsearch on redhat5 with the
official rmp everything look fine (clean install).
After installation of the plugin marvel, my elasticsearch instance don't
start :

[2014-02-20 10:27:05,012][INFO ][node ] [sacchi]

version[1.0.0], pid[23465], build[a46900e/2014-02-12T16:18:34Z]
[2014-02-20 10:27:05,012][INFO ][node ] [sacchi]
initializing ...

[2014-02-20 10:27:05,015][ERROR][bootstrap ] {1.0.0}:
Initialization Failed ...**- NullPointerException[null]

When I disable the plugin (rename the directory plugin), everything work
fine.

[2014-02-20 10:32:18,910][INFO ][node ] [sacchi]

version[1.0.0], pid[24172], build[a46900e/2014-02-12T16:18:34Z]
[2014-02-20 10:32:18,910][INFO ][node ] [sacchi]
initializing ...
[2014-02-20 10:32:18,912][INFO ][plugins ] [sacchi]
loaded [], sites []
[2014-02-20 10:32:20,788][INFO ][node ] [sacchi]
initialized
[2014-02-20 10:32:20,788][INFO ][node ] [sacchi]
starting ...
[2014-02-20 10:32:20,863][INFO ][transport ] [sacchi]
bound_address {inet[/0.0.0.0:9300]}, publish_address {inet[/xxx:9300]}
[2014-02-20 10:32:23,893][INFO ][cluster.service ] [sacchi]
new_master
[sacchi][L3874aIMQYydHAKnoaKilw][eqds3uzsynlourvd001.equities.net.intra][inet[/10.30.194.71:9300]],
reason: zen-disco-join (elected_as_master)
[2014-02-20 10:32:23,914][INFO ][discovery ] [sacchi]
ges_search/L3874aIMQYydHAKnoaKilw
[2014-02-20 10:32:23,930][INFO ][http ] [sacchi]
bound_address {inet[/0.0.0.0:9200]}, publish_address {inet[/xxx:9200]}
[2014-02-20 10:32:23,936][INFO ][gateway ] [sacchi]
recovered [0] indices into cluster_state
[2014-02-20 10:32:23,937][INFO ][node ] [sacchi]
started

my version of java :

java version "1.6.0_45"

Java(TM) SE Runtime Environment (build 1.6.0_45-b06)

any idea, on the issue ?
Also it's possible to enable a mode debug for elasticsearh ?

regards,
will

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/ae4c65f8-a448-47de-a72d-98e2a859efee%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Xwilly Azel) #3

Hi Boaz,

here the result :

[2014-02-20 13:40:20,827][INFO ][node ] [sacchi] version
[1.0.0], pid[18874], build[a46900e/2014-02-12T16:18:34Z]
[2014-02-20 13:40:20,828][INFO ][node ] [sacchi]initializing
...
[2014-02-20 13:40:20,828][DEBUG][node ] [sacchi] usinghome
[/usr/share/elasticsearch], config [/etc/elasticsearch], data [[/apps_output
/elastisearch/index]], logs [/apps_output/elastisearch/logs], work [
/apps_output/elastisearch/temp], plugins [/usr/share/elasticsearch/plugins]
[2014-02-20 13:40:20,831][ERROR][bootstrap ] {1.0.0}:
Initialization Failed ...

  • NullPointerException[null]
    [2014-02-20 13:40:20,831][DEBUG][bootstrap ] Exception
    java.lang.NullPointerException
    at org.elasticsearch.plugins.PluginsService.
    loadPluginsIntoClassLoader(PluginsService.java:347)
    at org.elasticsearch.plugins.PluginsService.(PluginsService.
    java:99)
    at org.elasticsearch.node.internal.InternalNode.(InternalNode.
    java:143)
    at org.elasticsearch.node.NodeBuilder.build(NodeBuilder.java:159)
    at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:68)
    at org.elasticsearch.bootstrap.Bootstrap.main(Bootstrap.java:201)
    at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java
    :32)

version of marvel is : marvel-1.0.2.jar

On Thursday, February 20, 2014 12:13:55 PM UTC+1, Boaz Leskes wrote:

Hi will,

Do you have any marvel specific settings in your elasticsearch.yml?

To enable debug logs in es (assuming you run it from the command line):

./bin/elasticsearch --logger.level=DEBUG

Let me know what you see.

Cheers,
Boaz

On Thursday, February 20, 2014 10:39:24 AM UTC+1, Xwilly Azel wrote:

Hi,

I have installed the last version of elasticsearch on redhat5 with the
official rmp everything look fine (clean install).
After installation of the plugin marvel, my elasticsearch instance don't
start :

[2014-02-20 10:27:05,012][INFO ][node ] [sacchi]

version[1.0.0], pid[23465], build[a46900e/2014-02-12T16:18:34Z]
[2014-02-20 10:27:05,012][INFO ][node ] [sacchi]
initializing ...

[2014-02-20 10:27:05,015][ERROR][bootstrap ] {1.0.0}:
Initialization Failed ...**- NullPointerException[null]

When I disable the plugin (rename the directory plugin), everything work
fine.

[2014-02-20 10:32:18,910][INFO ][node ] [sacchi]

version[1.0.0], pid[24172], build[a46900e/2014-02-12T16:18:34Z]
[2014-02-20 10:32:18,910][INFO ][node ] [sacchi]
initializing ...
[2014-02-20 10:32:18,912][INFO ][plugins ] [sacchi]
loaded [], sites []
[2014-02-20 10:32:20,788][INFO ][node ] [sacchi]
initialized
[2014-02-20 10:32:20,788][INFO ][node ] [sacchi]
starting ...
[2014-02-20 10:32:20,863][INFO ][transport ] [sacchi]
bound_address {inet[/0.0.0.0:9300]}, publish_address {inet[/xxx:9300]}
[2014-02-20 10:32:23,893][INFO ][cluster.service ] [sacchi]
new_master
[sacchi][L3874aIMQYydHAKnoaKilw][eqds3uzsynlourvd001.equities.net.intra][inet[/10.30.194.71:9300]],
reason: zen-disco-join (elected_as_master)
[2014-02-20 10:32:23,914][INFO ][discovery ] [sacchi]
ges_search/L3874aIMQYydHAKnoaKilw
[2014-02-20 10:32:23,930][INFO ][http ] [sacchi]
bound_address {inet[/0.0.0.0:9200]}, publish_address {inet[/xxx:9200]}
[2014-02-20 10:32:23,936][INFO ][gateway ] [sacchi]
recovered [0] indices into cluster_state
[2014-02-20 10:32:23,937][INFO ][node ] [sacchi]
started

my version of java :

java version "1.6.0_45"

Java(TM) SE Runtime Environment (build 1.6.0_45-b06)

any idea, on the issue ?
Also it's possible to enable a mode debug for elasticsearh ?

regards,
will

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/33738ffc-2a30-4eb1-89b3-2391b3e7ab64%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Xwilly Azel) #4

and here my elasticsearch lib

elasticsearch-1.0.0.jar
jna-3.3.0.jar
jts-1.12.jar
log4j-1.2.17.jar
lucene-analyzers-common-4.6.1.jar
lucene-codecs-4.6.1.jar
lucene-core-4.6.1.jar
lucene-grouping-4.6.1.jar
lucene-highlighter-4.6.1.jar
lucene-join-4.6.1.jar
lucene-memory-4.6.1.jar
lucene-misc-4.6.1.jar
lucene-queries-4.6.1.jar
lucene-queryparser-4.6.1.jar
lucene-sandbox-4.6.1.jar
lucene-spatial-4.6.1.jar
lucene-suggest-4.6.1.jar
sigar
spatial4j-0.3.jar

On Thursday, February 20, 2014 1:42:44 PM UTC+1, Xwilly Azel wrote:

Hi Boaz,

here the result :

[2014-02-20 13:40:20,827][INFO ][node ] [sacchi]version
[1.0.0], pid[18874], build[a46900e/2014-02-12T16:18:34Z]
[2014-02-20 13:40:20,828][INFO ][node ] [sacchi]initializing
...
[2014-02-20 13:40:20,828][DEBUG][node ] [sacchi] usinghome
[/usr/share/elasticsearch], config [/etc/elasticsearch], data [[/
apps_output/elastisearch/index]], logs [/apps_output/elastisearch/logs],work
[/apps_output/elastisearch/temp], plugins [/usr/share/elasticsearch/
plugins]
[2014-02-20 13:40:20,831][ERROR][bootstrap ] {1.0.0}:
Initialization Failed ...

  • NullPointerException[null]
    [2014-02-20 13:40:20,831][DEBUG][bootstrap ] Exception
    java.lang.NullPointerException
    at org.elasticsearch.plugins.PluginsService.
    loadPluginsIntoClassLoader(PluginsService.java:347)
    at org.elasticsearch.plugins.PluginsService.(PluginsService.
    java:99)
    at org.elasticsearch.node.internal.InternalNode.(
    InternalNode.java:143)
    at org.elasticsearch.node.NodeBuilder.build(NodeBuilder.java:159)
    at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:68)
    at org.elasticsearch.bootstrap.Bootstrap.main(Bootstrap.java:201)
    at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.
    java:32)

version of marvel is : marvel-1.0.2.jar

On Thursday, February 20, 2014 12:13:55 PM UTC+1, Boaz Leskes wrote:

Hi will,

Do you have any marvel specific settings in your elasticsearch.yml?

To enable debug logs in es (assuming you run it from the command line):

./bin/elasticsearch --logger.level=DEBUG

Let me know what you see.

Cheers,
Boaz

On Thursday, February 20, 2014 10:39:24 AM UTC+1, Xwilly Azel wrote:

Hi,

I have installed the last version of elasticsearch on redhat5 with the
official rmp everything look fine (clean install).
After installation of the plugin marvel, my elasticsearch instance don't
start :

[2014-02-20 10:27:05,012][INFO ][node ] [sacchi]

version[1.0.0], pid[23465], build[a46900e/2014-02-12T16:18:34Z]
[2014-02-20 10:27:05,012][INFO ][node ] [sacchi]
initializing ...

[2014-02-20 10:27:05,015][ERROR][bootstrap ] {1.0.0}:
Initialization Failed ...**- NullPointerException[null]

When I disable the plugin (rename the directory plugin), everything work
fine.

[2014-02-20 10:32:18,910][INFO ][node ] [sacchi]

version[1.0.0], pid[24172], build[a46900e/2014-02-12T16:18:34Z]
[2014-02-20 10:32:18,910][INFO ][node ] [sacchi]
initializing ...
[2014-02-20 10:32:18,912][INFO ][plugins ] [sacchi]
loaded [], sites []
[2014-02-20 10:32:20,788][INFO ][node ] [sacchi]
initialized
[2014-02-20 10:32:20,788][INFO ][node ] [sacchi]
starting ...
[2014-02-20 10:32:20,863][INFO ][transport ] [sacchi]
bound_address {inet[/0.0.0.0:9300]}, publish_address {inet[/xxx:9300]}
[2014-02-20 10:32:23,893][INFO ][cluster.service ] [sacchi]
new_master
[sacchi][L3874aIMQYydHAKnoaKilw][eqds3uzsynlourvd001.equities.net.intra][inet[/10.30.194.71:9300]],
reason: zen-disco-join (elected_as_master)
[2014-02-20 10:32:23,914][INFO ][discovery ] [sacchi]
ges_search/L3874aIMQYydHAKnoaKilw
[2014-02-20 10:32:23,930][INFO ][http ] [sacchi]
bound_address {inet[/0.0.0.0:9200]}, publish_address {inet[/xxx:9200]}
[2014-02-20 10:32:23,936][INFO ][gateway ] [sacchi]
recovered [0] indices into cluster_state
[2014-02-20 10:32:23,937][INFO ][node ] [sacchi]
started

my version of java :

java version "1.6.0_45"

Java(TM) SE Runtime Environment (build 1.6.0_45-b06)

any idea, on the issue ?
Also it's possible to enable a mode debug for elasticsearh ?

regards,
will

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/78492da0-4e6a-4b6c-b2a3-f798748a9abe%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #5

Sounds like you set path.plugins, right?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 20 février 2014 à 13:44:08, Xwilly Azel (xwilly@gmail.com) a écrit:

and here my elasticsearch lib

elasticsearch-1.0.0.jar
jna-3.3.0.jar
jts-1.12.jar
log4j-1.2.17.jar
lucene-analyzers-common-4.6.1.jar
lucene-codecs-4.6.1.jar
lucene-core-4.6.1.jar
lucene-grouping-4.6.1.jar
lucene-highlighter-4.6.1.jar
lucene-join-4.6.1.jar
lucene-memory-4.6.1.jar
lucene-misc-4.6.1.jar
lucene-queries-4.6.1.jar
lucene-queryparser-4.6.1.jar
lucene-sandbox-4.6.1.jar
lucene-spatial-4.6.1.jar
lucene-suggest-4.6.1.jar
sigar
spatial4j-0.3.jar

On Thursday, February 20, 2014 1:42:44 PM UTC+1, Xwilly Azel wrote:
Hi Boaz,

here the result :

[2014-02-20 13:40:20,827][INFO ][node ] [sacchi] version[1.0.0], pid[18874], build[a46900e/2014-02-12T16:18:34Z]
[2014-02-20 13:40:20,828][INFO ][node ] [sacchi] initializing ...
[2014-02-20 13:40:20,828][DEBUG][node ] [sacchi] using home [/usr/share/elasticsearch], config [/etc/elasticsearch], data [[/apps_output/elastisearch/index]], logs [/apps_output/elastisearch/logs], work [/apps_output/elastisearch/temp], plugins [/usr/share/elasticsearch/plugins]
[2014-02-20 13:40:20,831][ERROR][bootstrap ] {1.0.0}: Initialization Failed ...

  • NullPointerException[null]
    [2014-02-20 13:40:20,831][DEBUG][bootstrap ] Exception
    java.lang.NullPointerException
    at org.elasticsearch.plugins.PluginsService.loadPluginsIntoClassLoader(PluginsService.java:347)
    at org.elasticsearch.plugins.PluginsService.(PluginsService.java:99)
    at org.elasticsearch.node.internal.InternalNode.(InternalNode.java:143)
    at org.elasticsearch.node.NodeBuilder.build(NodeBuilder.java:159)
    at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:68)
    at org.elasticsearch.bootstrap.Bootstrap.main(Bootstrap.java:201)
    at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:32)

version of marvel is : marvel-1.0.2.jar

On Thursday, February 20, 2014 12:13:55 PM UTC+1, Boaz Leskes wrote:
Hi will,

Do you have any marvel specific settings in your elasticsearch.yml?

To enable debug logs in es (assuming you run it from the command line):

./bin/elasticsearch --logger.level=DEBUG

Let me know what you see.

Cheers,
Boaz

On Thursday, February 20, 2014 10:39:24 AM UTC+1, Xwilly Azel wrote:
Hi,

I have installed the last version of elasticsearch on redhat5 with the official rmp everything look fine (clean install).
After installation of the plugin marvel, my elasticsearch instance don't start :

[2014-02-20 10:27:05,012][INFO ][node ] [sacchi] version[1.0.0], pid[23465], build[a46900e/2014-02-12T16:18:34Z]
[2014-02-20 10:27:05,012][INFO ][node ] [sacchi] initializing ...
[2014-02-20 10:27:05,015][ERROR][bootstrap ] {1.0.0}: Initialization Failed ...

  • NullPointerException[null]

When I disable the plugin (rename the directory plugin), everything work fine.

[2014-02-20 10:32:18,910][INFO ][node ] [sacchi] version[1.0.0], pid[24172], build[a46900e/2014-02-12T16:18:34Z]
[2014-02-20 10:32:18,910][INFO ][node ] [sacchi] initializing ...
[2014-02-20 10:32:18,912][INFO ][plugins ] [sacchi] loaded [], sites []
[2014-02-20 10:32:20,788][INFO ][node ] [sacchi] initialized
[2014-02-20 10:32:20,788][INFO ][node ] [sacchi] starting ...
[2014-02-20 10:32:20,863][INFO ][transport ] [sacchi] bound_address {inet[/0.0.0.0:9300]}, publish_address {inet[/xxx:9300]}
[2014-02-20 10:32:23,893][INFO ][cluster.service ] [sacchi] new_master [sacchi][L3874aIMQYydHAKnoaKilw][eqds3uzsynlourvd001.equities.net.intra][inet[/10.30.194.71:9300]], reason: zen-disco-join (elected_as_master)
[2014-02-20 10:32:23,914][INFO ][discovery ] [sacchi] ges_search/L3874aIMQYydHAKnoaKilw
[2014-02-20 10:32:23,930][INFO ][http ] [sacchi] bound_address {inet[/0.0.0.0:9200]}, publish_address {inet[/xxx:9200]}
[2014-02-20 10:32:23,936][INFO ][gateway ] [sacchi] recovered [0] indices into cluster_state
[2014-02-20 10:32:23,937][INFO ][node ] [sacchi] started

my version of java :

java version "1.6.0_45"
Java(TM) SE Runtime Environment (build 1.6.0_45-b06)

any idea, on the issue ?
Also it's possible to enable a mode debug for elasticsearh ?

regards,
will

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/78492da0-4e6a-4b6c-b2a3-f798748a9abe%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.5305fb20.643c9869.3fd6%40MacBook-Air-de-David.local.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #6

BTW, I will fix this NPE. Thanks for reporting

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 20 février 2014 à 13:55:03, David Pilato (david@pilato.fr) a écrit:

Sounds like you set path.plugins, right?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 20 février 2014 à 13:44:08, Xwilly Azel (xwilly@gmail.com) a écrit:

and here my elasticsearch lib

elasticsearch-1.0.0.jar
jna-3.3.0.jar
jts-1.12.jar
log4j-1.2.17.jar
lucene-analyzers-common-4.6.1.jar
lucene-codecs-4.6.1.jar
lucene-core-4.6.1.jar
lucene-grouping-4.6.1.jar
lucene-highlighter-4.6.1.jar
lucene-join-4.6.1.jar
lucene-memory-4.6.1.jar
lucene-misc-4.6.1.jar
lucene-queries-4.6.1.jar
lucene-queryparser-4.6.1.jar
lucene-sandbox-4.6.1.jar
lucene-spatial-4.6.1.jar
lucene-suggest-4.6.1.jar
sigar
spatial4j-0.3.jar

On Thursday, February 20, 2014 1:42:44 PM UTC+1, Xwilly Azel wrote:
Hi Boaz,

here the result :

[2014-02-20 13:40:20,827][INFO ][node ] [sacchi] version[1.0.0], pid[18874], build[a46900e/2014-02-12T16:18:34Z]
[2014-02-20 13:40:20,828][INFO ][node ] [sacchi] initializing ...
[2014-02-20 13:40:20,828][DEBUG][node ] [sacchi] using home [/usr/share/elasticsearch], config [/etc/elasticsearch], data [[/apps_output/elastisearch/index]], logs [/apps_output/elastisearch/logs], work [/apps_output/elastisearch/temp], plugins [/usr/share/elasticsearch/plugins]
[2014-02-20 13:40:20,831][ERROR][bootstrap ] {1.0.0}: Initialization Failed ...

  • NullPointerException[null]
    [2014-02-20 13:40:20,831][DEBUG][bootstrap ] Exception
    java.lang.NullPointerException
    at org.elasticsearch.plugins.PluginsService.loadPluginsIntoClassLoader(PluginsService.java:347)
    at org.elasticsearch.plugins.PluginsService.(PluginsService.java:99)
    at org.elasticsearch.node.internal.InternalNode.(InternalNode.java:143)
    at org.elasticsearch.node.NodeBuilder.build(NodeBuilder.java:159)
    at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:68)
    at org.elasticsearch.bootstrap.Bootstrap.main(Bootstrap.java:201)
    at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:32)

version of marvel is : marvel-1.0.2.jar

On Thursday, February 20, 2014 12:13:55 PM UTC+1, Boaz Leskes wrote:
Hi will,

Do you have any marvel specific settings in your elasticsearch.yml?

To enable debug logs in es (assuming you run it from the command line):

./bin/elasticsearch --logger.level=DEBUG

Let me know what you see.

Cheers,
Boaz

On Thursday, February 20, 2014 10:39:24 AM UTC+1, Xwilly Azel wrote:
Hi,

I have installed the last version of elasticsearch on redhat5 with the official rmp everything look fine (clean install).
After installation of the plugin marvel, my elasticsearch instance don't start :

[2014-02-20 10:27:05,012][INFO ][node ] [sacchi] version[1.0.0], pid[23465], build[a46900e/2014-02-12T16:18:34Z]
[2014-02-20 10:27:05,012][INFO ][node ] [sacchi] initializing ...
[2014-02-20 10:27:05,015][ERROR][bootstrap ] {1.0.0}: Initialization Failed ...

  • NullPointerException[null]

When I disable the plugin (rename the directory plugin), everything work fine.

[2014-02-20 10:32:18,910][INFO ][node ] [sacchi] version[1.0.0], pid[24172], build[a46900e/2014-02-12T16:18:34Z]
[2014-02-20 10:32:18,910][INFO ][node ] [sacchi] initializing ...
[2014-02-20 10:32:18,912][INFO ][plugins ] [sacchi] loaded [], sites []
[2014-02-20 10:32:20,788][INFO ][node ] [sacchi] initialized
[2014-02-20 10:32:20,788][INFO ][node ] [sacchi] starting ...
[2014-02-20 10:32:20,863][INFO ][transport ] [sacchi] bound_address {inet[/0.0.0.0:9300]}, publish_address {inet[/xxx:9300]}
[2014-02-20 10:32:23,893][INFO ][cluster.service ] [sacchi] new_master [sacchi][L3874aIMQYydHAKnoaKilw][eqds3uzsynlourvd001.equities.net.intra][inet[/10.30.194.71:9300]], reason: zen-disco-join (elected_as_master)
[2014-02-20 10:32:23,914][INFO ][discovery ] [sacchi] ges_search/L3874aIMQYydHAKnoaKilw
[2014-02-20 10:32:23,930][INFO ][http ] [sacchi] bound_address {inet[/0.0.0.0:9200]}, publish_address {inet[/xxx:9200]}
[2014-02-20 10:32:23,936][INFO ][gateway ] [sacchi] recovered [0] indices into cluster_state
[2014-02-20 10:32:23,937][INFO ][node ] [sacchi] started

my version of java :

java version "1.6.0_45"
Java(TM) SE Runtime Environment (build 1.6.0_45-b06)

any idea, on the issue ?
Also it's possible to enable a mode debug for elasticsearh ?

regards,
will

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/78492da0-4e6a-4b6c-b2a3-f798748a9abe%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.5305fb85.2ae8944a.3fd6%40MacBook-Air-de-David.local.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #7

After some search, I think you are hitting this issue: https://github.com/elasticsearch/elasticsearch/pull/4187

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 20 février 2014 à 13:56:46, David Pilato (david@pilato.fr) a écrit:

BTW, I will fix this NPE. Thanks for reporting

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 20 février 2014 à 13:55:03, David Pilato (david@pilato.fr) a écrit:

Sounds like you set path.plugins, right?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 20 février 2014 à 13:44:08, Xwilly Azel (xwilly@gmail.com) a écrit:

and here my elasticsearch lib

elasticsearch-1.0.0.jar
jna-3.3.0.jar
jts-1.12.jar
log4j-1.2.17.jar
lucene-analyzers-common-4.6.1.jar
lucene-codecs-4.6.1.jar
lucene-core-4.6.1.jar
lucene-grouping-4.6.1.jar
lucene-highlighter-4.6.1.jar
lucene-join-4.6.1.jar
lucene-memory-4.6.1.jar
lucene-misc-4.6.1.jar
lucene-queries-4.6.1.jar
lucene-queryparser-4.6.1.jar
lucene-sandbox-4.6.1.jar
lucene-spatial-4.6.1.jar
lucene-suggest-4.6.1.jar
sigar
spatial4j-0.3.jar

On Thursday, February 20, 2014 1:42:44 PM UTC+1, Xwilly Azel wrote:
Hi Boaz,

here the result :

[2014-02-20 13:40:20,827][INFO ][node ] [sacchi] version[1.0.0], pid[18874], build[a46900e/2014-02-12T16:18:34Z]
[2014-02-20 13:40:20,828][INFO ][node ] [sacchi] initializing ...
[2014-02-20 13:40:20,828][DEBUG][node ] [sacchi] using home [/usr/share/elasticsearch], config [/etc/elasticsearch], data [[/apps_output/elastisearch/index]], logs [/apps_output/elastisearch/logs], work [/apps_output/elastisearch/temp], plugins [/usr/share/elasticsearch/plugins]
[2014-02-20 13:40:20,831][ERROR][bootstrap ] {1.0.0}: Initialization Failed ...

  • NullPointerException[null]
    [2014-02-20 13:40:20,831][DEBUG][bootstrap ] Exception
    java.lang.NullPointerException
    at org.elasticsearch.plugins.PluginsService.loadPluginsIntoClassLoader(PluginsService.java:347)
    at org.elasticsearch.plugins.PluginsService.(PluginsService.java:99)
    at org.elasticsearch.node.internal.InternalNode.(InternalNode.java:143)
    at org.elasticsearch.node.NodeBuilder.build(NodeBuilder.java:159)
    at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:68)
    at org.elasticsearch.bootstrap.Bootstrap.main(Bootstrap.java:201)
    at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:32)

version of marvel is : marvel-1.0.2.jar

On Thursday, February 20, 2014 12:13:55 PM UTC+1, Boaz Leskes wrote:
Hi will,

Do you have any marvel specific settings in your elasticsearch.yml?

To enable debug logs in es (assuming you run it from the command line):

./bin/elasticsearch --logger.level=DEBUG

Let me know what you see.

Cheers,
Boaz

On Thursday, February 20, 2014 10:39:24 AM UTC+1, Xwilly Azel wrote:
Hi,

I have installed the last version of elasticsearch on redhat5 with the official rmp everything look fine (clean install).
After installation of the plugin marvel, my elasticsearch instance don't start :

[2014-02-20 10:27:05,012][INFO ][node ] [sacchi] version[1.0.0], pid[23465], build[a46900e/2014-02-12T16:18:34Z]
[2014-02-20 10:27:05,012][INFO ][node ] [sacchi] initializing ...
[2014-02-20 10:27:05,015][ERROR][bootstrap ] {1.0.0}: Initialization Failed ...

  • NullPointerException[null]

When I disable the plugin (rename the directory plugin), everything work fine.

[2014-02-20 10:32:18,910][INFO ][node ] [sacchi] version[1.0.0], pid[24172], build[a46900e/2014-02-12T16:18:34Z]
[2014-02-20 10:32:18,910][INFO ][node ] [sacchi] initializing ...
[2014-02-20 10:32:18,912][INFO ][plugins ] [sacchi] loaded [], sites []
[2014-02-20 10:32:20,788][INFO ][node ] [sacchi] initialized
[2014-02-20 10:32:20,788][INFO ][node ] [sacchi] starting ...
[2014-02-20 10:32:20,863][INFO ][transport ] [sacchi] bound_address {inet[/0.0.0.0:9300]}, publish_address {inet[/xxx:9300]}
[2014-02-20 10:32:23,893][INFO ][cluster.service ] [sacchi] new_master [sacchi][L3874aIMQYydHAKnoaKilw][eqds3uzsynlourvd001.equities.net.intra][inet[/10.30.194.71:9300]], reason: zen-disco-join (elected_as_master)
[2014-02-20 10:32:23,914][INFO ][discovery ] [sacchi] ges_search/L3874aIMQYydHAKnoaKilw
[2014-02-20 10:32:23,930][INFO ][http ] [sacchi] bound_address {inet[/0.0.0.0:9200]}, publish_address {inet[/xxx:9200]}
[2014-02-20 10:32:23,936][INFO ][gateway ] [sacchi] recovered [0] indices into cluster_state
[2014-02-20 10:32:23,937][INFO ][node ] [sacchi] started

my version of java :

java version "1.6.0_45"
Java(TM) SE Runtime Environment (build 1.6.0_45-b06)

any idea, on the issue ?
Also it's possible to enable a mode debug for elasticsearh ?

regards,
will

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/78492da0-4e6a-4b6c-b2a3-f798748a9abe%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.5305fb85.2ae8944a.3fd6%40MacBook-Air-de-David.local.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.5305fd1e.3d1b58ba.3fd6%40MacBook-Air-de-David.local.
For more options, visit https://groups.google.com/groups/opt_out.


(Xwilly Azel) #8

same with path for plugin

[2014-02-20 13:59:23,388][INFO ][node ] [sacchi]
version[1.0.0], pid[21718], build[a46900e/2014-02-12T16:18:34Z]
[2014-02-20 13:59:23,389][INFO ][node ] [sacchi]
initializing ...
[2014-02-20 13:59:23,389][DEBUG][node ] [sacchi] using
home [/usr/share/elasticsearch], config [/etc/elasticsearch], data
[[/apps_output/elastisearch/index]], logs [/apps_output/elastisearch/logs],
work [/apps_output/elastisearch/temp],* plugins
[/usr/share/elasticsearch/plugins]*
[2014-02-20 13:59:23,392][ERROR][bootstrap ] {1.0.0}:
Initialization Failed ...

  • NullPointerException[null]
    [2014-02-20 13:59:23,393][DEBUG][bootstrap ] Exception
    java.lang.NullPointerException
    at
    org.elasticsearch.plugins.PluginsService.loadPluginsIntoClassLoader(PluginsService.java:347)
    at
    org.elasticsearch.plugins.PluginsService.(PluginsService.java:99)
    at
    org.elasticsearch.node.internal.InternalNode.(InternalNode.java:143)
    at org.elasticsearch.node.NodeBuilder.build(NodeBuilder.java:159)
    at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:68)
    at org.elasticsearch.bootstrap.Bootstrap.main(Bootstrap.java:201)
    at
    org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:32)

[root@eqds3uzsynlourvd001 elasticsearch]# lrt
/usr/share/elasticsearch/plugins/

total 4
drwxr-x--- 3 root root 4096 Feb 20 10:13 marvel

On Thursday, February 20, 2014 1:54:56 PM UTC+1, David Pilato wrote:

Sounds like you set path.plugins, right?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 20 février 2014 à 13:44:08, Xwilly Azel (xwi...@gmail.com <javascript:>)
a écrit:

and here my elasticsearch lib

elasticsearch-1.0.0.jar
jna-3.3.0.jar
jts-1.12.jar
log4j-1.2.17.jar
lucene-analyzers-common-4.6.1.jar
lucene-codecs-4.6.1.jar
lucene-core-4.6.1.jar
lucene-grouping-4.6.1.jar
lucene-highlighter-4.6.1.jar
lucene-join-4.6.1.jar
lucene-memory-4.6.1.jar
lucene-misc-4.6.1.jar
lucene-queries-4.6.1.jar
lucene-queryparser-4.6.1.jar
lucene-sandbox-4.6.1.jar
lucene-spatial-4.6.1.jar
lucene-suggest-4.6.1.jar
sigar
spatial4j-0.3.jar

On Thursday, February 20, 2014 1:42:44 PM UTC+1, Xwilly Azel wrote:

Hi Boaz,

here the result :

[2014-02-20 13:40:20,827][INFO ][node ] [sacchi]
version[1.0.0], pid[18874], build[a46900e/2014-02-12T16:18:34Z]
[2014-02-20 13:40:20,828][INFO ][node ] [sacchi]
initializing ...
[2014-02-20 13:40:20,828][DEBUG][node ] [sacchi]
using home [/usr/share/elasticsearch], config [/etc/elasticsearch], data
[[/apps_output/elastisearch/index]], logs [/apps_output/elastisearch/logs
], work [/apps_output/elastisearch/temp], plugins [/usr/share/
elasticsearch/plugins]
[2014-02-20 13:40:20,831][ERROR][bootstrap ] {1.0.0}:
Initialization Failed ...

  • NullPointerException[null]
    [2014-02-20 13:40:20,831][DEBUG][bootstrap ] Exception
    java.lang.NullPointerException
    at org.elasticsearch.plugins.PluginsService.
    loadPluginsIntoClassLoader(PluginsService.java:347)
    at org.elasticsearch.plugins.PluginsService.(PluginsService
    .java:99)
    at org.elasticsearch.node.internal.InternalNode.(
    InternalNode.java:143)
    at org.elasticsearch.node.NodeBuilder.build(NodeBuilder.java:159)
    at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:68)
    at org.elasticsearch.bootstrap.Bootstrap.main(Bootstrap.java:201)
    at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.
    java:32)

version of marvel is : marvel-1.0.2.jar

On Thursday, February 20, 2014 12:13:55 PM UTC+1, Boaz Leskes wrote:

Hi will,

Do you have any marvel specific settings in your elasticsearch.yml?

To enable debug logs in es (assuming you run it from the command line):

./bin/elasticsearch --logger.level=DEBUG

Let me know what you see.

Cheers,
Boaz

On Thursday, February 20, 2014 10:39:24 AM UTC+1, Xwilly Azel wrote:

Hi,

I have installed the last version of elasticsearch on redhat5 with the
official rmp everything look fine (clean install).
After installation of the plugin marvel, my elasticsearch instance
don't start :

[2014-02-20 10:27:05,012][INFO ][node ] [sacchi]

version[1.0.0], pid[23465], build[a46900e/2014-02-12T16:18:34Z]
[2014-02-20 10:27:05,012][INFO ][node ] [sacchi]
initializing ...

[2014-02-20 10:27:05,015][ERROR][bootstrap ] {1.0.0}:
Initialization Failed ...**- NullPointerException[null]

When I disable the plugin (rename the directory plugin), everything
work fine.

[2014-02-20 10:32:18,910][INFO ][node ] [sacchi]

version[1.0.0], pid[24172], build[a46900e/2014-02-12T16:18:34Z]
[2014-02-20 10:32:18,910][INFO ][node ] [sacchi]
initializing ...
[2014-02-20 10:32:18,912][INFO ][plugins ] [sacchi]
loaded [], sites []
[2014-02-20 10:32:20,788][INFO ][node ] [sacchi]
initialized
[2014-02-20 10:32:20,788][INFO ][node ] [sacchi]
starting ...
[2014-02-20 10:32:20,863][INFO ][transport ] [sacchi]
bound_address {inet[/0.0.0.0:9300]}, publish_address {inet[/xxx:9300]}
[2014-02-20 10:32:23,893][INFO ][cluster.service ] [sacchi]
new_master
[sacchi][L3874aIMQYydHAKnoaKilw][eqds3uzsynlourvd001.equities.net.intra][inet[/10.30.194.71:9300]],
reason: zen-disco-join (elected_as_master)
[2014-02-20 10:32:23,914][INFO ][discovery ] [sacchi]
ges_search/L3874aIMQYydHAKnoaKilw
[2014-02-20 10:32:23,930][INFO ][http ] [sacchi]
bound_address {inet[/0.0.0.0:9200]}, publish_address {inet[/xxx:9200]}
[2014-02-20 10:32:23,936][INFO ][gateway ] [sacchi]
recovered [0] indices into cluster_state
[2014-02-20 10:32:23,937][INFO ][node ] [sacchi]
started

my version of java :

java version "1.6.0_45"

Java(TM) SE Runtime Environment (build 1.6.0_45-b06)

any idea, on the issue ?
Also it's possible to enable a mode debug for elasticsearh ?

regards,
will

--

You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/78492da0-4e6a-4b6c-b2a3-f798748a9abe%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/70e93eaa-10ff-4c27-b833-919a9c226a1c%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Xwilly Azel) #9

path is set

2014-02-20 13:59:23,388][INFO ][node ] [sacchi]
version[1.0.0], pid[21718], build[a46900e/2014-02-12T16:18:34Z]
[2014-02-20 13:59:23,389][INFO ][node ] [sacchi]
initializing ...
[2014-02-20 13:59:23,389][DEBUG][node ] [sacchi] using
home [/usr/share/elasticsearch], config [/etc/elasticsearch], data
[[/apps_output/elastisearch/index]], logs [/apps_output/elastisearch/logs],
work [/apps_output/elastisearch/temp], plugins
[/usr/share/elasticsearch/plugins]

[2014-02-20 13:59:23,392][ERROR][bootstrap ] {1.0.0}:
Initialization Failed ...

  • NullPointerException[null]
    [2014-02-20 13:59:23,393][DEBUG][bootstrap ] Exception
    java.lang.NullPointerException
    at
    org.elasticsearch.plugins.PluginsService.loadPluginsIntoClassLoader(PluginsService.java:347)
    at
    org.elasticsearch.plugins.PluginsService.(PluginsService.java:99)
    at
    org.elasticsearch.node.internal.InternalNode.(InternalNode.java:143)
    at org.elasticsearch.node.NodeBuilder.build(NodeBuilder.java:159)
    at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:68)
    at org.elasticsearch.bootstrap.Bootstrap.main(Bootstrap.java:201)
    at
    org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:32)

lrt* /usr/share/elasticsearch/plugins/*
total 4
drwxr-x--- 3 root root 4096 Feb 20 10:13 marvel

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/4dd58dd8-a3d3-4971-a977-e38a73be156a%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #10

Issue happens when you don't have read rights to the plugin path. I thought I fixed it some months ago but there still an issue.
I guess you run elasticsearch under another unix account than root.

That's the cause here.

You should change owner of plugins dir.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 20 février 2014 à 14:09:18, Xwilly Azel (xwilly@gmail.com) a écrit:

path is set

2014-02-20 13:59:23,388][INFO ][node ] [sacchi] version[1.0.0], pid[21718], build[a46900e/2014-02-12T16:18:34Z]
[2014-02-20 13:59:23,389][INFO ][node ] [sacchi] initializing ...
[2014-02-20 13:59:23,389][DEBUG][node ] [sacchi] using home [/usr/share/elasticsearch], config [/etc/elasticsearch], data [[/apps_output/elastisearch/index]], logs [/apps_output/elastisearch/logs], work [/apps_output/elastisearch/temp], plugins [/usr/share/elasticsearch/plugins]
[2014-02-20 13:59:23,392][ERROR][bootstrap ] {1.0.0}: Initialization Failed ...

  • NullPointerException[null]
    [2014-02-20 13:59:23,393][DEBUG][bootstrap ] Exception
    java.lang.NullPointerException
    at org.elasticsearch.plugins.PluginsService.loadPluginsIntoClassLoader(PluginsService.java:347)
    at org.elasticsearch.plugins.PluginsService.(PluginsService.java:99)
    at org.elasticsearch.node.internal.InternalNode.(InternalNode.java:143)
    at org.elasticsearch.node.NodeBuilder.build(NodeBuilder.java:159)
    at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:68)
    at org.elasticsearch.bootstrap.Bootstrap.main(Bootstrap.java:201)
    at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:32)

lrt /usr/share/elasticsearch/plugins/
total 4
drwxr-x--- 3 root root 4096 Feb 20 10:13 marvel

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/4dd58dd8-a3d3-4971-a977-e38a73be156a%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.5305ff56.79e2a9e3.3fd6%40MacBook-Air-de-David.local.
For more options, visit https://groups.google.com/groups/opt_out.


(Xwilly Azel) #11

done.

./bin/plugin

should create the directory plugins with the same right than the directory
lib and we should have an explicit error log in this case.

i've done the installation with official rpm :).

On Thursday, February 20, 2014 2:12:54 PM UTC+1, David Pilato wrote:

Issue happens when you don't have read rights to the plugin path. I
thought I fixed it some months ago but there still an issue.
I guess you run elasticsearch under another unix account than root.

That's the cause here.

You should change owner of plugins dir.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 20 février 2014 à 14:09:18, Xwilly Azel (xwi...@gmail.com <javascript:>)
a écrit:

path is set

2014-02-20 13:59:23,388][INFO ][node ] [sacchi]
version[1.0.0], pid[21718], build[a46900e/2014-02-12T16:18:34Z]
[2014-02-20 13:59:23,389][INFO ][node ] [sacchi]
initializing ...
[2014-02-20 13:59:23,389][DEBUG][node ] [sacchi] using
home [/usr/share/elasticsearch], config [/etc/elasticsearch], data
[[/apps_output/elastisearch/index]], logs [/apps_output/elastisearch/logs],
work [/apps_output/elastisearch/temp], plugins
[/usr/share/elasticsearch/plugins]

[2014-02-20 13:59:23,392][ERROR][bootstrap ] {1.0.0}:
Initialization Failed ...

  • NullPointerException[null]
    [2014-02-20 13:59:23,393][DEBUG][bootstrap ] Exception
    java.lang.NullPointerException
    at
    org.elasticsearch.plugins.PluginsService.loadPluginsIntoClassLoader(PluginsService.java:347)
    at
    org.elasticsearch.plugins.PluginsService.(PluginsService.java:99)
    at
    org.elasticsearch.node.internal.InternalNode.(InternalNode.java:143)
    at org.elasticsearch.node.NodeBuilder.build(NodeBuilder.java:159)
    at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:68)
    at org.elasticsearch.bootstrap.Bootstrap.main(Bootstrap.java:201)
    at
    org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:32)

    lrt /usr/share/elasticsearch/plugins/
    total 4
    drwxr-x--- 3 root root 4096 Feb 20 10:13 marvel

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/4dd58dd8-a3d3-4971-a977-e38a73be156a%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/11e9e378-606f-43a6-9dd6-a0762faf6567%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Xwilly Azel) #12

and Thanks for your help David :).

On Thursday, February 20, 2014 2:21:15 PM UTC+1, Xwilly Azel wrote:

done.

./bin/plugin

should create the directory plugins with the same right than the directory
lib and we should have an explicit error log in this case.

i've done the installation with official rpm :).

On Thursday, February 20, 2014 2:12:54 PM UTC+1, David Pilato wrote:

Issue happens when you don't have read rights to the plugin path. I
thought I fixed it some months ago but there still an issue.
I guess you run elasticsearch under another unix account than root.

That's the cause here.

You should change owner of plugins dir.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 20 février 2014 à 14:09:18, Xwilly Azel (xwi...@gmail.com) a écrit:

path is set

2014-02-20 13:59:23,388][INFO ][node ] [sacchi]
version[1.0.0], pid[21718], build[a46900e/2014-02-12T16:18:34Z]
[2014-02-20 13:59:23,389][INFO ][node ] [sacchi]
initializing ...
[2014-02-20 13:59:23,389][DEBUG][node ] [sacchi]
using home [/usr/share/elasticsearch], config [/etc/elasticsearch], data
[[/apps_output/elastisearch/index]], logs [/apps_output/elastisearch/logs],
work [/apps_output/elastisearch/temp], plugins
[/usr/share/elasticsearch/plugins]

[2014-02-20 13:59:23,392][ERROR][bootstrap ] {1.0.0}:
Initialization Failed ...

  • NullPointerException[null]
    [2014-02-20 13:59:23,393][DEBUG][bootstrap ] Exception
    java.lang.NullPointerException
    at
    org.elasticsearch.plugins.PluginsService.loadPluginsIntoClassLoader(PluginsService.java:347)
    at
    org.elasticsearch.plugins.PluginsService.(PluginsService.java:99)
    at
    org.elasticsearch.node.internal.InternalNode.(InternalNode.java:143)
    at org.elasticsearch.node.NodeBuilder.build(NodeBuilder.java:159)
    at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:68)
    at org.elasticsearch.bootstrap.Bootstrap.main(Bootstrap.java:201)
    at
    org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:32)

    lrt /usr/share/elasticsearch/plugins/
    total 4
    drwxr-x--- 3 root root 4096 Feb 20 10:13 marvel

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/4dd58dd8-a3d3-4971-a977-e38a73be156a%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/807f2f30-da1d-4fec-a16e-92f174667f44%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #13

I sent a PR for the log issue: https://github.com/elasticsearch/elasticsearch/pull/5196

Interesting. How do you run bin/plugin? Do you run it as root?
Something like sudo bin/plugin …. ?

If so I guess it comes from here.

You should run it as elasticsearch user but I'm wondering if it will work.

@Alex (spinscale): should we by default create the plugins dir in our RPM packages and set them to default elasticsearch user?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 20 février 2014 à 14:21:19, Xwilly Azel (xwilly@gmail.com) a écrit:

done.

./bin/plugin

should create the directory plugins with the same right than the directory lib and we should have an explicit error log in this case.

i've done the installation with official rpm :).

On Thursday, February 20, 2014 2:12:54 PM UTC+1, David Pilato wrote:
Issue happens when you don't have read rights to the plugin path. I thought I fixed it some months ago but there still an issue.
I guess you run elasticsearch under another unix account than root.

That's the cause here.

You should change owner of plugins dir.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 20 février 2014 à 14:09:18, Xwilly Azel (xwi...@gmail.com) a écrit:

path is set

2014-02-20 13:59:23,388][INFO ][node ] [sacchi] version[1.0.0], pid[21718], build[a46900e/2014-02-12T16:18:34Z]
[2014-02-20 13:59:23,389][INFO ][node ] [sacchi] initializing ...
[2014-02-20 13:59:23,389][DEBUG][node ] [sacchi] using home [/usr/share/elasticsearch], config [/etc/elasticsearch], data [[/apps_output/elastisearch/index]], logs [/apps_output/elastisearch/logs], work [/apps_output/elastisearch/temp], plugins [/usr/share/elasticsearch/plugins]
[2014-02-20 13:59:23,392][ERROR][bootstrap ] {1.0.0}: Initialization Failed ...

  • NullPointerException[null]
    [2014-02-20 13:59:23,393][DEBUG][bootstrap ] Exception
    java.lang.NullPointerException
    at org.elasticsearch.plugins.PluginsService.loadPluginsIntoClassLoader(PluginsService.java:347)
    at org.elasticsearch.plugins.PluginsService.(PluginsService.java:99)
    at org.elasticsearch.node.internal.InternalNode.(InternalNode.java:143)
    at org.elasticsearch.node.NodeBuilder.build(NodeBuilder.java:159)
    at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:68)
    at org.elasticsearch.bootstrap.Bootstrap.main(Bootstrap.java:201)
    at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:32)

lrt /usr/share/elasticsearch/plugins/
total 4
drwxr-x--- 3 root root 4096 Feb 20 10:13 marvel

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/4dd58dd8-a3d3-4971-a977-e38a73be156a%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/11e9e378-606f-43a6-9dd6-a0762faf6567%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.53060239.12200854.3fd6%40MacBook-Air-de-David.local.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #14