Marvel page is empty


(Prakash B) #1
  • I am on ES version 1.0.1
  • Installed the 'head' plugin and it works. But marvel does not. Did a
    reinstall and it did not help
  • Also went through the discussion of a previous similar post ...

Screenshot:
[@mil-ora2 elasticsearch-1.0.1]$ ls -l plugins/
total 4
drwxr-xr-x 4 oracle dba 4096 Apr 17 18:48 marvel
[@mil-ora2 elasticsearch-1.0.1]$ tail logs/elasticsearch.log
[2014-04-17 18:57:28,882][INFO ][node ] [Richard
Parker] initializing ...
[2014-04-17 18:57:28,899][INFO ][plugins ] [Richard
Parker] loaded [], sites []
[2014-04-17 18:57:31,249][INFO ][node ] [Richard
Parker] initialized
[2014-04-17 18:57:31,249][INFO ][node ] [Richard
Parker] starting ...
[2014-04-17 18:57:31,374][INFO ][transport ] [Richard
Parker] bound_address {inet[/0:0:0:0:0:0:0:0:9300]}, publish_address
{inet[/172.16.140.14:9300]}
[2014-04-17 18:57:34,421][INFO ][cluster.service ] [Richard
Parker] new_master [Richard
Parker][iIQsbh7US3qbO5ik93Li9g][mil-ora2][inet[/172.16.140.14:9300]],
reason: zen-disco-join (elected_as_master)
[2014-04-17 18:57:34,452][INFO ][discovery ] [Richard
Parker] elasticsearch/iIQsbh7US3qbO5ik93Li9g
[2014-04-17 18:57:34,468][INFO ][http ] [Richard
Parker] bound_address {inet[/0:0:0:0:0:0:0:0:9200]}, publish_address
{inet[/172.16.140.14:9200]}
[2014-04-17 18:57:34,485][INFO ][gateway ] [Richard
Parker] recovered [0] indices into cluster_state
[2014-04-17 18:57:34,486][INFO ][node ] [Richard
Parker] started
[@mil-ora2 elasticsearch-1.0.1]$

TIA

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/22465a3f-78f5-4b01-8bee-12cf76433a08%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Boaz Leskes) #2

Hi Tia,

Can you share how you installed ES and how you installed Marvel? also is
the user which ES runs under allowed to access the plugin folder (created
by the user who installed marvel).

Cheers,
Boaz

On Thursday, April 17, 2014 9:34:27 PM UTC+2, Prakash B wrote:

  • I am on ES version 1.0.1
  • Installed the 'head' plugin and it works. But marvel does not. Did a
    reinstall and it did not help
  • Also went through the discussion of a previous similar post ...

Screenshot:
[@mil-ora2 elasticsearch-1.0.1]$ ls -l plugins/
total 4
drwxr-xr-x 4 oracle dba 4096 Apr 17 18:48 marvel
[@mil-ora2 elasticsearch-1.0.1]$ tail logs/elasticsearch.log
[2014-04-17 18:57:28,882][INFO ][node ] [Richard
Parker] initializing ...
[2014-04-17 18:57:28,899][INFO ][plugins ] [Richard
Parker] loaded [], sites []
[2014-04-17 18:57:31,249][INFO ][node ] [Richard
Parker] initialized
[2014-04-17 18:57:31,249][INFO ][node ] [Richard
Parker] starting ...
[2014-04-17 18:57:31,374][INFO ][transport ] [Richard
Parker] bound_address {inet[/0:0:0:0:0:0:0:0:9300]}, publish_address {inet[/
172.16.140.14:9300]}
[2014-04-17 18:57:34,421][INFO ][cluster.service ] [Richard
Parker] new_master [Richard
Parker][iIQsbh7US3qbO5ik93Li9g][mil-ora2][inet[/172.16.140.14:9300]],
reason: zen-disco-join (elected_as_master)
[2014-04-17 18:57:34,452][INFO ][discovery ] [Richard
Parker] elasticsearch/iIQsbh7US3qbO5ik93Li9g
[2014-04-17 18:57:34,468][INFO ][http ] [Richard
Parker] bound_address {inet[/0:0:0:0:0:0:0:0:9200]}, publish_address {inet[/
172.16.140.14:9200]}
[2014-04-17 18:57:34,485][INFO ][gateway ] [Richard
Parker] recovered [0] indices into cluster_state
[2014-04-17 18:57:34,486][INFO ][node ] [Richard
Parker] started
[@mil-ora2 elasticsearch-1.0.1]$

TIA

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/aff2c4c8-5751-455c-b56e-c0850a33878c%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Prakash B) #3

Boaz,

To install ES, all I did was to unzip the file that I downloaded.

Here is the command I used to install Marvel: bin/plugin -u
file:///tmp/elasticsearch-1.0.1.zip -i elasticsearch/marvel/latest

The user:group that I have used is oracle:dba. And this account has full
access. I installed Elasticsearch head using the same method and it worked.

Thanks
Prakash

On Saturday, April 19, 2014 1:07:25 AM UTC-7, Boaz Leskes wrote:

Hi Tia,

Can you share how you installed ES and how you installed Marvel? also is
the user which ES runs under allowed to access the plugin folder (created
by the user who installed marvel).

Cheers,
Boaz

On Thursday, April 17, 2014 9:34:27 PM UTC+2, Prakash B wrote:

  • I am on ES version 1.0.1
  • Installed the 'head' plugin and it works. But marvel does not. Did
    a reinstall and it did not help
  • Also went through the discussion of a previous similar post ...

Screenshot:
[@mil-ora2 elasticsearch-1.0.1]$ ls -l plugins/
total 4
drwxr-xr-x 4 oracle dba 4096 Apr 17 18:48 marvel
[@mil-ora2 elasticsearch-1.0.1]$ tail logs/elasticsearch.log
[2014-04-17 18:57:28,882][INFO ][node ] [Richard
Parker] initializing ...
[2014-04-17 18:57:28,899][INFO ][plugins ] [Richard
Parker] loaded [], sites []
[2014-04-17 18:57:31,249][INFO ][node ] [Richard
Parker] initialized
[2014-04-17 18:57:31,249][INFO ][node ] [Richard
Parker] starting ...
[2014-04-17 18:57:31,374][INFO ][transport ] [Richard
Parker] bound_address {inet[/0:0:0:0:0:0:0:0:9300]}, publish_address {inet[/
172.16.140.14:9300]}
[2014-04-17 18:57:34,421][INFO ][cluster.service ] [Richard
Parker] new_master [Richard
Parker][iIQsbh7US3qbO5ik93Li9g][mil-ora2][inet[/172.16.140.14:9300]],
reason: zen-disco-join (elected_as_master)
[2014-04-17 18:57:34,452][INFO ][discovery ] [Richard
Parker] elasticsearch/iIQsbh7US3qbO5ik93Li9g
[2014-04-17 18:57:34,468][INFO ][http ] [Richard
Parker] bound_address {inet[/0:0:0:0:0:0:0:0:9200]}, publish_address {inet[/
172.16.140.14:9200]}
[2014-04-17 18:57:34,485][INFO ][gateway ] [Richard
Parker] recovered [0] indices into cluster_state
[2014-04-17 18:57:34,486][INFO ][node ] [Richard
Parker] started
[@mil-ora2 elasticsearch-1.0.1]$

TIA

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/d50392b9-4955-42b9-b0a5-9be1055ba976%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(eunever32) #4

After installing you need to restart elasticsearch.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/f3cb5bb3-31f0-49ec-987a-0e6bb2b2e3f4%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Prakash B) #5

I did restart.

On Monday, April 21, 2014 10:13:30 AM UTC-7, eune...@gmail.com wrote:

After installing you need to restart elasticsearch.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/a780f991-a3f6-4a2a-9845-d3c524ec2932%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Boaz Leskes) #6

Somehow Elasticsearch can't find/access the marvel jars & _site. This is
indicated by this log:

[2014-04-17 18:57:28,899][INFO ][plugins ] [Richard
Parker] loaded [], sites []

Is ES running under the same oracle:dba user? Can you double check that
the marvel folder under plugins is not empty?

On Monday, April 21, 2014 8:35:14 PM UTC+2, Prakash B wrote:

I did restart.

On Monday, April 21, 2014 10:13:30 AM UTC-7, eune...@gmail.com wrote:

After installing you need to restart elasticsearch.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/ca0e0450-7d68-4c4e-92ba-8703c2f8fde9%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #7