Marvel does not display any contents with ES1.2.1


(ajay.bh111) #1

Hi

I have new test setup for ES and added latest marvel from internet and
tried ipv6 workaround to mentioned in other thread too but display does not
show any contents from the marvel URL. Marvel plugin installed from
internet .

Here is the status (only one node up for debugging for 3 node cluster)

curl -XGET 'http://127.0.0.1:9200/_cluster/health?pretty=true'
{
"cluster_name" : "elastic_alpha",
"status" : "yellow",
"timed_out" : false,
"number_of_nodes" : 1,
"number_of_data_nodes" : 1,
"active_primary_shards" : 5,
"active_shards" : 5,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 5
}

root@elk01:/usr/local/elasticsearch# bin/plugin --list
Installed plugins:
- marvel
cluster.name: elastic_alpha

elasticsearch.yml file:

node.name: elk01
node.max_local_storage_nodes: 1
index.mapper.dynamic: true
action.auto_create_index: true
action.disable_delete_all_indices: true
path.conf: /iscsi_disk1/etc/elasticsearch
path.data: /iscsi_disk1/data/elasticsearch
path.work: /tmp/work/elasticsearch
path.logs: /iscsi_disk1/logs/elasticsearch
path.plugins: /usr/local/elasticsearch/bin/plugin
bootstrap.mlockall: true
http.port: 9200
gateway.expected_nodes: 1
discovery.zen.minimum_master_nodes: 1
discovery.zen.ping.multicast.enabled: false
cloud.node.auto_attributes: true
discovery.zen.ping.unicast.hosts: [ "elk01:9300","elk02:9300","elk03:9300" ]
indices.memory.index_buffer_size: 50%
marvel.agent.exporter.es.hosts: ["[::1]:9200"]
marvel.agent.enabled: false

Any thing wrong with the config ?

Thanks
Ajay

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/809a2457-b189-44b4-a185-bce46f06ca02%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Boaz Leskes) #2

Hi Ajay,

I'm not sure exactly what problem you have, but note that you have disabled
data shipping by setting "marvel.agent.enabled: false" . Was this your
intention? If not this why you don't have any data in marvel.

Cheers,
Boaz

PS you probably want to also remove "indices.memory.index_buffer_size:
50%", unless you plan on doing very heavy indexing and even then I'd wait
until I see problems

On Thursday, July 10, 2014 9:59:52 PM UTC+2, ajay....@gmail.com wrote:

Hi

I have new test setup for ES and added latest marvel from internet and
tried ipv6 workaround to mentioned in other thread too but display does not
show any contents from the marvel URL. Marvel plugin installed from
internet .

Here is the status (only one node up for debugging for 3 node cluster)

curl -XGET 'http://127.0.0.1:9200/_cluster/health?pretty=true'
{
"cluster_name" : "elastic_alpha",
"status" : "yellow",
"timed_out" : false,
"number_of_nodes" : 1,
"number_of_data_nodes" : 1,
"active_primary_shards" : 5,
"active_shards" : 5,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 5
}

root@elk01:/usr/local/elasticsearch# bin/plugin --list
Installed plugins:
- marvel
cluster.name: elastic_alpha

elasticsearch.yml file:

node.name: elk01
node.max_local_storage_nodes: 1
index.mapper.dynamic: true
action.auto_create_index: true
action.disable_delete_all_indices: true
path.conf: /iscsi_disk1/etc/elasticsearch
path.data: /iscsi_disk1/data/elasticsearch
path.work: /tmp/work/elasticsearch
path.logs: /iscsi_disk1/logs/elasticsearch
path.plugins: /usr/local/elasticsearch/bin/plugin
bootstrap.mlockall: true
http.port: 9200
gateway.expected_nodes: 1
discovery.zen.minimum_master_nodes: 1
discovery.zen.ping.multicast.enabled: false
cloud.node.auto_attributes: true
discovery.zen.ping.unicast.hosts: [ "elk01:9300","elk02:9300","elk03:9300"
]
indices.memory.index_buffer_size: 50%
marvel.agent.exporter.es.hosts: ["[::1]:9200"]
marvel.agent.enabled: false

Any thing wrong with the config ?

Thanks
Ajay

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/3f66fd8d-211b-49df-bb68-96ee918c53fb%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(ajay.bh111) #3

Tried multiple times with setting it to true or false both but result is same.ThanksAjay

Sent from my BlackBerry 10 smartphone on the Rogers network.From: Boaz LeskesSent: Sunday, July 13, 2014 02:09To: elasticsearch@googlegroups.comReply To: elasticsearch@googlegroups.comSubject: Re: Marvel does not display any contents with ES1.2.1.

Hi Ajay,

I'm not sure exactly what problem you have, but note that you have disabled data shipping by setting "marvel.agent.enabled: false" . Was this your intention? If not this why you don't have any data in marvel.

Cheers,Boaz

PS you probably want to also remove "indices.memory.index_buffer_size: 50%", unless you plan on doing very heavy indexing and even then I'd wait until I see problems

On Thursday, July 10, 2014 9:59:52 PM UTC+2, ajay....@gmail.com wrote:

Hi

I have new test setup for ES and added latest marvel from internet and tried ipv6 workaround to mentioned in other thread too but display does not show any contents from the marvel URL. Marvel plugin installed from internet .

Here is the status (only one node up for debugging for 3 node cluster)

curl -XGET 'http://127.0.0.1:9200/_cluster/health?pretty=true'

{

"cluster_name" : "elastic_alpha",

"status" : "yellow",

"timed_out" : false,

"number_of_nodes" : 1,

"number_of_data_nodes" : 1,

"active_primary_shards" : 5,

"active_shards" : 5,

"relocating_shards" : 0,

"initializing_shards" : 0,

"unassigned_shards" : 5

}

root@elk01:/usr/local/elasticsearch# bin/plugin --list

Installed plugins:

- marvel

cluster.name: elastic_alpha

elasticsearch.yml file:

node.name: elk01

node.max_local_storage_nodes: 1

index.mapper.dynamic: true

action.auto_create_index: true

action.disable_delete_all_indices: true

path.conf: /iscsi_disk1/etc/elasticsearch

path.data: /iscsi_disk1/data/elasticsearch

path.work: /tmp/work/elasticsearch

path.logs: /iscsi_disk1/logs/elasticsearch

path.plugins: /usr/local/elasticsearch/bin/plugin

bootstrap.mlockall: true

http.port: 9200

gateway.expected_nodes: 1

discovery.zen.minimum_master_nodes: 1

discovery.zen.ping.multicast.enabled: false

cloud.node.auto_attributes: true

discovery.zen.ping.unicast.hosts: [ "elk01:9300","elk02:9300","elk03:9300" ]

indices.memory.index_buffer_size: 50%

marvel.agent.exporter.es.hosts: ["[::1]:9200"]

marvel.agent.enabled: false

Any thing wrong with the config ?

Thanks

Ajay

--

You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.

To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/rdopCoFhrw8/unsubscribe.

To unsubscribe from this group and all its topics, send an email to elasticsearch+unsubscribe@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/3f66fd8d-211b-49df-bb68-96ee918c53fb%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.


(Boaz Leskes) #4

Can you share a screen shot of what you see and also the logs of the node? I'm looking for the adress Es bound it self to and any error from marvel

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/1405334322396.4de81dad%40Nodemailer.
For more options, visit https://groups.google.com/d/optout.


(ajay.bh111) #5

Hi Boaz

Attached are the logs, and screenshot. new config (vm recreated) with fresh
install config with marvel agent enabled . Using a single node setup to
find the issue with marvel.

Thanks
Ajay

Config:

cluster.name: elastic_test1
node.name: elk01
node.max_local_storage_nodes: 1
index.mapper.dynamic: true
action.auto_create_index: true
action.disable_delete_all_indices: true
path.conf: /iscsi_disk1/etc/elasticsearch
path.data: /iscsi_disk1/data/elasticsearch
path.work: /iscsi_disk1/work/elasticsearch
path.logs: /iscsi_disk1/logs/elasticsearch
path.plugins: /usr/local/elasticsearch/bin/plugin
bootstrap.mlockall: true
http.port: 9200
gateway.expected_nodes: 1
discovery.zen.minimum_master_nodes: 1
discovery.zen.ping.multicast.enabled: false
cloud.node.auto_attributes: true
discovery.zen.ping.unicast.hosts: [ "elk001:9300" ]
indices.memory.index_buffer_size: 50%
marvel.agent.enabled: enabled

ES status :
root@elk01:/iscsi_disk1/etc/elasticsearch# curl -XGET '
http://localhost:9200/_cluster/health?pretty=true'
{
"cluster_name" : "elastic_test1",
"status" : "yellow",
"timed_out" : false,
"number_of_nodes" : 1,
"number_of_data_nodes" : 1,
"active_primary_shards" : 5,
"active_shards" : 5,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 5
}

On Mon, Jul 14, 2014 at 6:38 AM, Boaz Leskes b.leskes@gmail.com wrote:

Can you share a screen shot of what you see and also the logs of the node?
I'm looking for the adress Es bound it self to and any error from marvel

On Mon, Jul 14, 2014 at 2:26 AM, ajay.bh111@gmail.com <
ajay.bh111@gmail.com> wrote:

Tried multiple times with setting it to true or false both but result is
same.
Thanks
Ajay

Sent from my BlackBerry 10 smartphone on the Rogers network.
*From: *Boaz Leskes
*Sent: *Sunday, July 13, 2014 02:09
*To: *elasticsearch@googlegroups.com
*Reply To: *elasticsearch@googlegroups.com
*Subject: *Re: Marvel does not display any contents with ES1.2.1.

Hi Ajay,

I'm not sure exactly what problem you have, but note that you have
disabled data shipping by setting "marvel.agent.enabled: false" . Was this
your intention? If not this why you don't have any data in marvel.

Cheers,
Boaz

PS you probably want to also remove "indices.memory.index_buffer_size:
50%", unless you plan on doing very heavy indexing and even then I'd wait
until I see problems

On Thursday, July 10, 2014 9:59:52 PM UTC+2, ajay....@gmail.com wrote:

Hi

I have new test setup for ES and added latest marvel from internet and
tried ipv6 workaround to mentioned in other thread too but display does not
show any contents from the marvel URL. Marvel plugin installed from
internet .

Here is the status (only one node up for debugging for 3 node cluster)

curl -XGET 'http://127.0.0.1:9200/_cluster/health?pretty=true'
{
"cluster_name" : "elastic_alpha",
"status" : "yellow",
"timed_out" : false,
"number_of_nodes" : 1,
"number_of_data_nodes" : 1,
"active_primary_shards" : 5,
"active_shards" : 5,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 5
}

root@elk01:/usr/local/elasticsearch# bin/plugin --list
Installed plugins:
- marvel
cluster.name: elastic_alpha

elasticsearch.yml file:

node.name: elk01
node.max_local_storage_nodes: 1
index.mapper.dynamic: true
action.auto_create_index: true
action.disable_delete_all_indices: true
path.conf: /iscsi_disk1/etc/elasticsearch
path.data: /iscsi_disk1/data/elasticsearch
path.work: /tmp/work/elasticsearch
path.logs: /iscsi_disk1/logs/elasticsearch
path.plugins: /usr/local/elasticsearch/bin/plugin
bootstrap.mlockall: true
http.port: 9200
gateway.expected_nodes: 1
discovery.zen.minimum_master_nodes: 1
discovery.zen.ping.multicast.enabled: false
cloud.node.auto_attributes: true
discovery.zen.ping.unicast.hosts: [
"elk01:9300","elk02:9300","elk03:9300" ]
indices.memory.index_buffer_size: 50%
marvel.agent.exporter.es.hosts: ["[::1]:9200"]
marvel.agent.enabled: false

Any thing wrong with the config ?

Thanks
Ajay

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/rdopCoFhrw8/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/3f66fd8d-211b-49df-bb68-96ee918c53fb%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/3f66fd8d-211b-49df-bb68-96ee918c53fb%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/rdopCoFhrw8/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/20140714002629.26468518.62786.275%40gmail.com
https://groups.google.com/d/msgid/elasticsearch/20140714002629.26468518.62786.275%40gmail.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/rdopCoFhrw8/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/1405334322396.4de81dad%40Nodemailer
https://groups.google.com/d/msgid/elasticsearch/1405334322396.4de81dad%40Nodemailer?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAJrOVw3WU_MYjmuYUAM-pdwgZPX0NL26sws%2BbOOw9Hbtg0jK4g%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(ajay.bh111) #6

Attached are logs with one config error on hostname fixed (elk001 ->
elk01) and logs in DEBUG. Still no marvel display.
Thanks
Ajay

On Mon, Jul 14, 2014 at 2:12 PM, ajay b ajay.bh111@gmail.com wrote:

Hi Boaz

Attached are the logs, and screenshot. new config (vm recreated) with
fresh install config with marvel agent enabled . Using a single node setup
to find the issue with marvel.

Thanks
Ajay

Config:

cluster.name: elastic_test1
node.name: elk01
node.max_local_storage_nodes: 1
index.mapper.dynamic: true
action.auto_create_index: true
action.disable_delete_all_indices: true
path.conf: /iscsi_disk1/etc/elasticsearch
path.data: /iscsi_disk1/data/elasticsearch
path.work: /iscsi_disk1/work/elasticsearch
path.logs: /iscsi_disk1/logs/elasticsearch
path.plugins: /usr/local/elasticsearch/bin/plugin
bootstrap.mlockall: true
http.port: 9200
gateway.expected_nodes: 1
discovery.zen.minimum_master_nodes: 1
discovery.zen.ping.multicast.enabled: false
cloud.node.auto_attributes: true
discovery.zen.ping.unicast.hosts: [ "elk001:9300" ]
indices.memory.index_buffer_size: 50%
marvel.agent.enabled: enabled

ES status :
root@elk01:/iscsi_disk1/etc/elasticsearch# curl -XGET '
http://localhost:9200/_cluster/health?pretty=true'
{
"cluster_name" : "elastic_test1",
"status" : "yellow",
"timed_out" : false,
"number_of_nodes" : 1,
"number_of_data_nodes" : 1,
"active_primary_shards" : 5,
"active_shards" : 5,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 5
}

On Mon, Jul 14, 2014 at 6:38 AM, Boaz Leskes b.leskes@gmail.com wrote:

Can you share a screen shot of what you see and also the logs of the
node? I'm looking for the adress Es bound it self to and any error from
marvel

On Mon, Jul 14, 2014 at 2:26 AM, ajay.bh111@gmail.com <
ajay.bh111@gmail.com> wrote:

Tried multiple times with setting it to true or false both but result is
same.
Thanks
Ajay

Sent from my BlackBerry 10 smartphone on the Rogers network.
*From: *Boaz Leskes
*Sent: *Sunday, July 13, 2014 02:09
*To: *elasticsearch@googlegroups.com
*Reply To: *elasticsearch@googlegroups.com
*Subject: *Re: Marvel does not display any contents with ES1.2.1.

Hi Ajay,

I'm not sure exactly what problem you have, but note that you have
disabled data shipping by setting "marvel.agent.enabled: false" . Was this
your intention? If not this why you don't have any data in marvel.

Cheers,
Boaz

PS you probably want to also remove "indices.memory.index_buffer_size:
50%", unless you plan on doing very heavy indexing and even then I'd wait
until I see problems

On Thursday, July 10, 2014 9:59:52 PM UTC+2, ajay....@gmail.com wrote:

Hi

I have new test setup for ES and added latest marvel from internet and
tried ipv6 workaround to mentioned in other thread too but display does not
show any contents from the marvel URL. Marvel plugin installed from
internet .

Here is the status (only one node up for debugging for 3 node cluster)

curl -XGET 'http://127.0.0.1:9200/_cluster/health?pretty=true'
{
"cluster_name" : "elastic_alpha",
"status" : "yellow",
"timed_out" : false,
"number_of_nodes" : 1,
"number_of_data_nodes" : 1,
"active_primary_shards" : 5,
"active_shards" : 5,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 5
}

root@elk01:/usr/local/elasticsearch# bin/plugin --list
Installed plugins:
- marvel
cluster.name: elastic_alpha

elasticsearch.yml file:

node.name: elk01
node.max_local_storage_nodes: 1
index.mapper.dynamic: true
action.auto_create_index: true
action.disable_delete_all_indices: true
path.conf: /iscsi_disk1/etc/elasticsearch
path.data: /iscsi_disk1/data/elasticsearch
path.work: /tmp/work/elasticsearch
path.logs: /iscsi_disk1/logs/elasticsearch
path.plugins: /usr/local/elasticsearch/bin/plugin
bootstrap.mlockall: true
http.port: 9200
gateway.expected_nodes: 1
discovery.zen.minimum_master_nodes: 1
discovery.zen.ping.multicast.enabled: false
cloud.node.auto_attributes: true
discovery.zen.ping.unicast.hosts: [
"elk01:9300","elk02:9300","elk03:9300" ]
indices.memory.index_buffer_size: 50%
marvel.agent.exporter.es.hosts: ["[::1]:9200"]
marvel.agent.enabled: false

Any thing wrong with the config ?

Thanks
Ajay

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/rdopCoFhrw8/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/3f66fd8d-211b-49df-bb68-96ee918c53fb%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/3f66fd8d-211b-49df-bb68-96ee918c53fb%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/rdopCoFhrw8/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/20140714002629.26468518.62786.275%40gmail.com
https://groups.google.com/d/msgid/elasticsearch/20140714002629.26468518.62786.275%40gmail.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/rdopCoFhrw8/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/1405334322396.4de81dad%40Nodemailer
https://groups.google.com/d/msgid/elasticsearch/1405334322396.4de81dad%40Nodemailer?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAJrOVw17Bw%2BoqTeLraxSkVcW1M2a7PQjRpmUte%3DSJPy15sg-HA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Boaz Leskes) #7

Hi Ajay,

If look at the following line:

[2014-07-14 19:44:23,188][INFO ][plugins ] [elk01] loaded
[], sites []

You can see that the node doesn't find the marvel plugin. How did you
install ES? Did you install marvel with the same user? It may be that the
user running ES has no access to the files? Do you see the marvel files
at /usr/local/elasticsearch/bin/plugin ?

PS I'm not sure which version of internet explorer you are using, but
marvel is compatible with IE9 and up.

On Mon, Jul 14, 2014 at 10:46 PM, ajay b ajay.bh111@gmail.com wrote:

Attached are logs with one config error on hostname fixed (elk001 ->
elk01) and logs in DEBUG. Still no marvel display.
Thanks
Ajay

On Mon, Jul 14, 2014 at 2:12 PM, ajay b ajay.bh111@gmail.com wrote:

Hi Boaz

Attached are the logs, and screenshot. new config (vm recreated) with
fresh install config with marvel agent enabled . Using a single node setup
to find the issue with marvel.

Thanks
Ajay

Config:

cluster.name: elastic_test1
node.name: elk01
node.max_local_storage_nodes: 1
index.mapper.dynamic: true
action.auto_create_index: true
action.disable_delete_all_indices: true
path.conf: /iscsi_disk1/etc/elasticsearch
path.data: /iscsi_disk1/data/elasticsearch
path.work: /iscsi_disk1/work/elasticsearch
path.logs: /iscsi_disk1/logs/elasticsearch
path.plugins: /usr/local/elasticsearch/bin/plugin
bootstrap.mlockall: true
http.port: 9200
gateway.expected_nodes: 1
discovery.zen.minimum_master_nodes: 1
discovery.zen.ping.multicast.enabled: false
cloud.node.auto_attributes: true
discovery.zen.ping.unicast.hosts: [ "elk001:9300" ]
indices.memory.index_buffer_size: 50%
marvel.agent.enabled: enabled

ES status :
root@elk01:/iscsi_disk1/etc/elasticsearch# curl -XGET '
http://localhost:9200/_cluster/health?pretty=true'
{
"cluster_name" : "elastic_test1",
"status" : "yellow",
"timed_out" : false,
"number_of_nodes" : 1,
"number_of_data_nodes" : 1,
"active_primary_shards" : 5,
"active_shards" : 5,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 5
}

On Mon, Jul 14, 2014 at 6:38 AM, Boaz Leskes b.leskes@gmail.com wrote:

Can you share a screen shot of what you see and also the logs of the
node? I'm looking for the adress Es bound it self to and any error from
marvel

On Mon, Jul 14, 2014 at 2:26 AM, ajay.bh111@gmail.com <
ajay.bh111@gmail.com> wrote:

Tried multiple times with setting it to true or false both but result
is same.
Thanks
Ajay

Sent from my BlackBerry 10 smartphone on the Rogers network.
*From: *Boaz Leskes
*Sent: *Sunday, July 13, 2014 02:09
*To: *elasticsearch@googlegroups.com
*Reply To: *elasticsearch@googlegroups.com
*Subject: *Re: Marvel does not display any contents with ES1.2.1.

Hi Ajay,

I'm not sure exactly what problem you have, but note that you have
disabled data shipping by setting "marvel.agent.enabled: false" . Was this
your intention? If not this why you don't have any data in marvel.

Cheers,
Boaz

PS you probably want to also remove "indices.memory.index_buffer_size:
50%", unless you plan on doing very heavy indexing and even then I'd wait
until I see problems

On Thursday, July 10, 2014 9:59:52 PM UTC+2, ajay....@gmail.com wrote:

Hi

I have new test setup for ES and added latest marvel from internet and
tried ipv6 workaround to mentioned in other thread too but display does not
show any contents from the marvel URL. Marvel plugin installed from
internet .

Here is the status (only one node up for debugging for 3 node cluster)

curl -XGET 'http://127.0.0.1:9200/_cluster/health?pretty=true'
{
"cluster_name" : "elastic_alpha",
"status" : "yellow",
"timed_out" : false,
"number_of_nodes" : 1,
"number_of_data_nodes" : 1,
"active_primary_shards" : 5,
"active_shards" : 5,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 5
}

root@elk01:/usr/local/elasticsearch# bin/plugin --list
Installed plugins:
- marvel
cluster.name: elastic_alpha

elasticsearch.yml file:

node.name: elk01
node.max_local_storage_nodes: 1
index.mapper.dynamic: true
action.auto_create_index: true
action.disable_delete_all_indices: true
path.conf: /iscsi_disk1/etc/elasticsearch
path.data: /iscsi_disk1/data/elasticsearch
path.work: /tmp/work/elasticsearch
path.logs: /iscsi_disk1/logs/elasticsearch
path.plugins: /usr/local/elasticsearch/bin/plugin
bootstrap.mlockall: true
http.port: 9200
gateway.expected_nodes: 1
discovery.zen.minimum_master_nodes: 1
discovery.zen.ping.multicast.enabled: false
cloud.node.auto_attributes: true
discovery.zen.ping.unicast.hosts: [
"elk01:9300","elk02:9300","elk03:9300" ]
indices.memory.index_buffer_size: 50%
marvel.agent.exporter.es.hosts: ["[::1]:9200"]
marvel.agent.enabled: false

Any thing wrong with the config ?

Thanks
Ajay

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/rdopCoFhrw8/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/3f66fd8d-211b-49df-bb68-96ee918c53fb%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/3f66fd8d-211b-49df-bb68-96ee918c53fb%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/rdopCoFhrw8/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/20140714002629.26468518.62786.275%40gmail.com
https://groups.google.com/d/msgid/elasticsearch/20140714002629.26468518.62786.275%40gmail.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/rdopCoFhrw8/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/1405334322396.4de81dad%40Nodemailer
https://groups.google.com/d/msgid/elasticsearch/1405334322396.4de81dad%40Nodemailer?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/rdopCoFhrw8/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAJrOVw17Bw%2BoqTeLraxSkVcW1M2a7PQjRpmUte%3DSJPy15sg-HA%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAJrOVw17Bw%2BoqTeLraxSkVcW1M2a7PQjRpmUte%3DSJPy15sg-HA%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKzwz0rVnc0uJe%3DNR99E85-TbdiukQ6saKAfNesU3wot1mmY6w%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(ajay.bh111) #8

Hi Boaz

After playing around with config only I managed to get it working but with
additional parameters set in the config, it does not work, not sure which
parameter breaks it at this time. It appears that once dummy node names are
assigned, it can take all the parameters.

Also with failed config, I see value in health check
"active_primary_shards" : 0, vs when working "active_primary_shards" : 1,.
When does the active primary shard gets created ?

See below the two configs.

Thanks
Ajay

Working config :

cluster.name: elastic_test1
indices.memory.index_buffer_size: 50%
path.conf: /iscsi_disk1/etc/elasticsearch
path.data: /iscsi_disk1/data/elasticsearch
path.work: /iscsi_disk1/work/elasticsearch
path.logs: /iscsi_disk1/logs/elasticsearch
path.plugins: /usr/local/elasticsearch/plugins
bootstrap.mlockall: true
discovery.zen.ping.multicast.enabled: false
discovery.zen.ping.unicast.hosts: [ "elk01.dbplat.altus.bblabs.rim.net:9300",
"elk02.dbplat.altus.bblabs.rim.net:9300", "
elk03.dbplat.altus.bblabs.rim.net:9300" ]

Failed Config:

action.auto_create_index: true action.disable_delete_all_indices:
true bootstrap.mlockall:
true cloud.node.auto_attributes: true cluster.name: elastic_test1
discovery.zen.minimum_master_nodes:
1 discovery.zen.ping.multicast.enabled: false
discovery.zen.ping.unicast.hosts:["elk01.dbplat.altus.bblabs.rim.net:9300","
elk02.dbplat.altus.bblabs.rim.net:9300","
elk03.dbplat.altus.bblabs.rim.net:9300"] gateway.expected_nodes: 1 http.port:
9200 index.mapper.dynamic: true indices.memory.index_buffer_size:
50% marvel.agent.enabled:
enabled marvel.agent.exporter.es.hosts: ["
elk01.dbplat.altus.bblabs.rim.net:9200"] marvel.agent.shard_stats.enabled:
true node.max_local_storage_nodes: 1 node.name:
elk01.dbplat.altus.bblabs.rim.net path.conf:
/iscsi_disk1/etc/elasticsearch path.data:
/iscsi_disk1/data/elasticsearch path.logs:
/iscsi_disk1/logs/elasticsearch path.plugins:
/usr/local/elasticsearch/bin/plugin path.work:
/iscsi_disk1/work/elasticsearch

On Tue, Jul 15, 2014 at 5:19 PM, Boaz Leskes b.leskes@gmail.com wrote:

Hi Ajay,

If look at the following line:

[2014-07-14 19:44:23,188][INFO ][plugins ] [elk01] loaded
[], sites []

You can see that the node doesn't find the marvel plugin. How did you
install ES? Did you install marvel with the same user? It may be that the
user running ES has no access to the files? Do you see the marvel files
at /usr/local/elasticsearch/bin/plugin ?

PS I'm not sure which version of internet explorer you are using, but
marvel is compatible with IE9 and up.

On Mon, Jul 14, 2014 at 10:46 PM, ajay b ajay.bh111@gmail.com wrote:

Attached are logs with one config error on hostname fixed (elk001 ->
elk01) and logs in DEBUG. Still no marvel display.
Thanks
Ajay

On Mon, Jul 14, 2014 at 2:12 PM, ajay b ajay.bh111@gmail.com wrote:

Hi Boaz

Attached are the logs, and screenshot. new config (vm recreated) with
fresh install config with marvel agent enabled . Using a single node setup
to find the issue with marvel.

Thanks
Ajay

Config:

cluster.name: elastic_test1
node.name: elk01
node.max_local_storage_nodes: 1
index.mapper.dynamic: true
action.auto_create_index: true
action.disable_delete_all_indices: true
path.conf: /iscsi_disk1/etc/elasticsearch
path.data: /iscsi_disk1/data/elasticsearch
path.work: /iscsi_disk1/work/elasticsearch
path.logs: /iscsi_disk1/logs/elasticsearch
path.plugins: /usr/local/elasticsearch/bin/plugin
bootstrap.mlockall: true
http.port: 9200
gateway.expected_nodes: 1
discovery.zen.minimum_master_nodes: 1
discovery.zen.ping.multicast.enabled: false
cloud.node.auto_attributes: true
discovery.zen.ping.unicast.hosts: [ "elk001:9300" ]
indices.memory.index_buffer_size: 50%
marvel.agent.enabled: enabled

ES status :
root@elk01:/iscsi_disk1/etc/elasticsearch# curl -XGET '
http://localhost:9200/_cluster/health?pretty=true'
{
"cluster_name" : "elastic_test1",
"status" : "yellow",
"timed_out" : false,
"number_of_nodes" : 1,
"number_of_data_nodes" : 1,
"active_primary_shards" : 5,
"active_shards" : 5,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 5
}

On Mon, Jul 14, 2014 at 6:38 AM, Boaz Leskes b.leskes@gmail.com wrote:

Can you share a screen shot of what you see and also the logs of the
node? I'm looking for the adress Es bound it self to and any error from
marvel

On Mon, Jul 14, 2014 at 2:26 AM, ajay.bh111@gmail.com <
ajay.bh111@gmail.com> wrote:

Tried multiple times with setting it to true or false both but result
is same.
Thanks
Ajay

Sent from my BlackBerry 10 smartphone on the Rogers network.
*From: *Boaz Leskes
*Sent: *Sunday, July 13, 2014 02:09
*To: *elasticsearch@googlegroups.com
*Reply To: *elasticsearch@googlegroups.com
*Subject: *Re: Marvel does not display any contents with ES1.2.1.

Hi Ajay,

I'm not sure exactly what problem you have, but note that you have
disabled data shipping by setting "marvel.agent.enabled: false" . Was this
your intention? If not this why you don't have any data in marvel.

Cheers,
Boaz

PS you probably want to also remove
"indices.memory.index_buffer_size: 50%", unless you plan on doing very
heavy indexing and even then I'd wait until I see problems

On Thursday, July 10, 2014 9:59:52 PM UTC+2, ajay....@gmail.com wrote:

Hi

I have new test setup for ES and added latest marvel from internet
and tried ipv6 workaround to mentioned in other thread too but display does
not show any contents from the marvel URL. Marvel plugin installed from
internet .

Here is the status (only one node up for debugging for 3 node
cluster)

curl -XGET 'http://127.0.0.1:9200/_cluster/health?pretty=true'
{
"cluster_name" : "elastic_alpha",
"status" : "yellow",
"timed_out" : false,
"number_of_nodes" : 1,
"number_of_data_nodes" : 1,
"active_primary_shards" : 5,
"active_shards" : 5,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 5
}

root@elk01:/usr/local/elasticsearch# bin/plugin --list
Installed plugins:
- marvel
cluster.name: elastic_alpha

elasticsearch.yml file:

node.name: elk01
node.max_local_storage_nodes: 1
index.mapper.dynamic: true
action.auto_create_index: true
action.disable_delete_all_indices: true
path.conf: /iscsi_disk1/etc/elasticsearch
path.data: /iscsi_disk1/data/elasticsearch
path.work: /tmp/work/elasticsearch
path.logs: /iscsi_disk1/logs/elasticsearch
path.plugins: /usr/local/elasticsearch/bin/plugin
bootstrap.mlockall: true
http.port: 9200
gateway.expected_nodes: 1
discovery.zen.minimum_master_nodes: 1
discovery.zen.ping.multicast.enabled: false
cloud.node.auto_attributes: true
discovery.zen.ping.unicast.hosts: [
"elk01:9300","elk02:9300","elk03:9300" ]
indices.memory.index_buffer_size: 50%
marvel.agent.exporter.es.hosts: ["[::1]:9200"]
marvel.agent.enabled: false

Any thing wrong with the config ?

Thanks
Ajay

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/rdopCoFhrw8/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/3f66fd8d-211b-49df-bb68-96ee918c53fb%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/3f66fd8d-211b-49df-bb68-96ee918c53fb%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/rdopCoFhrw8/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/20140714002629.26468518.62786.275%40gmail.com
https://groups.google.com/d/msgid/elasticsearch/20140714002629.26468518.62786.275%40gmail.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/rdopCoFhrw8/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/1405334322396.4de81dad%40Nodemailer
https://groups.google.com/d/msgid/elasticsearch/1405334322396.4de81dad%40Nodemailer?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/rdopCoFhrw8/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAJrOVw17Bw%2BoqTeLraxSkVcW1M2a7PQjRpmUte%3DSJPy15sg-HA%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAJrOVw17Bw%2BoqTeLraxSkVcW1M2a7PQjRpmUte%3DSJPy15sg-HA%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/rdopCoFhrw8/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAKzwz0rVnc0uJe%3DNR99E85-TbdiukQ6saKAfNesU3wot1mmY6w%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAKzwz0rVnc0uJe%3DNR99E85-TbdiukQ6saKAfNesU3wot1mmY6w%40mail.gmail.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAJrOVw0pVJea0EJGzT%2B_6coN%2BcDqQYMwANgZy90JKw%3D2aGoqyA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Boaz Leskes) #9

Hi Ajay,

Not sure exactly why the failed config doesn't work for you. Can you maybe
gist them? it will be easier to read..

Also with failed config, I see value in health check
"active_primary_shards" : 0, vs when working "active_primary_shards" : 1,.
When does the active primary shard gets created ?

The number is increased when an index is created and it's primary shards
become active.

Cheers,
Boaz

On Wednesday, July 16, 2014 11:28:37 PM UTC+3, ajay b wrote:

Hi Boaz

After playing around with config only I managed to get it working but with
additional parameters set in the config, it does not work, not sure which
parameter breaks it at this time. It appears that once dummy node names are
assigned, it can take all the parameters.

Also with failed config, I see value in health check
"active_primary_shards" : 0, vs when working "active_primary_shards" : 1,.
When does the active primary shard gets created ?

See below the two configs.

Thanks
Ajay

Working config :

cluster.name: elastic_test1
indices.memory.index_buffer_size: 50%
path.conf: /iscsi_disk1/etc/elasticsearch
path.data: /iscsi_disk1/data/elasticsearch
path.work: /iscsi_disk1/work/elasticsearch
path.logs: /iscsi_disk1/logs/elasticsearch
path.plugins: /usr/local/elasticsearch/plugins
bootstrap.mlockall: true
discovery.zen.ping.multicast.enabled: false
discovery.zen.ping.unicast.hosts: [ "
elk01.dbplat.altus.bblabs.rim.net:9300", "
elk02.dbplat.altus.bblabs.rim.net:9300", "
elk03.dbplat.altus.bblabs.rim.net:9300" ]

Failed Config:

action.auto_create_index: true action.disable_delete_all_indices: true bootstrap.mlockall:
true cloud.node.auto_attributes: true cluster.name: elastic_test1 discovery.zen.minimum_master_nodes:
1 discovery.zen.ping.multicast.enabled: false
discovery.zen.ping.unicast.hosts:["elk01.dbplat.altus.bblabs.rim.net:9300
","elk02.dbplat.altus.bblabs.rim.net:9300","
elk03.dbplat.altus.bblabs.rim.net:9300"] gateway.expected_nodes: 1 http.port:
9200 index.mapper.dynamic: true indices.memory.index_buffer_size: 50% marvel.agent.enabled:
enabled marvel.agent.exporter.es.hosts: ["
elk01.dbplat.altus.bblabs.rim.net:9200"] marvel.agent.shard_stats.enabled:
true node.max_local_storage_nodes: 1 node.name:
elk01.dbplat.altus.bblabs.rim.net path.conf:
/iscsi_disk1/etc/elasticsearch path.data: /iscsi_disk1/data/elasticsearch path.logs:
/iscsi_disk1/logs/elasticsearch path.plugins:
/usr/local/elasticsearch/bin/plugin path.work:
/iscsi_disk1/work/elasticsearch

On Tue, Jul 15, 2014 at 5:19 PM, Boaz Leskes b.leskes@gmail.com wrote:

Hi Ajay,

If look at the following line:

[2014-07-14 19:44:23,188][INFO ][plugins ] [elk01]
loaded [], sites []

You can see that the node doesn't find the marvel plugin. How did you
install ES? Did you install marvel with the same user? It may be that the
user running ES has no access to the files? Do you see the marvel files
at /usr/local/elasticsearch/bin/plugin ?

PS I'm not sure which version of internet explorer you are using, but
marvel is compatible with IE9 and up.

On Mon, Jul 14, 2014 at 10:46 PM, ajay b ajay.bh111@gmail.com wrote:

Attached are logs with one config error on hostname fixed (elk001 ->
elk01) and logs in DEBUG. Still no marvel display.
Thanks
Ajay

On Mon, Jul 14, 2014 at 2:12 PM, ajay b ajay.bh111@gmail.com wrote:

Hi Boaz

Attached are the logs, and screenshot. new config (vm recreated) with
fresh install config with marvel agent enabled . Using a single node setup
to find the issue with marvel.

Thanks
Ajay

Config:

cluster.name: elastic_test1
node.name: elk01
node.max_local_storage_nodes: 1
index.mapper.dynamic: true
action.auto_create_index: true
action.disable_delete_all_indices: true
path.conf: /iscsi_disk1/etc/elasticsearch
path.data: /iscsi_disk1/data/elasticsearch
path.work: /iscsi_disk1/work/elasticsearch
path.logs: /iscsi_disk1/logs/elasticsearch
path.plugins: /usr/local/elasticsearch/bin/plugin
bootstrap.mlockall: true
http.port: 9200
gateway.expected_nodes: 1
discovery.zen.minimum_master_nodes: 1
discovery.zen.ping.multicast.enabled: false
cloud.node.auto_attributes: true
discovery.zen.ping.unicast.hosts: [ "elk001:9300" ]
indices.memory.index_buffer_size: 50%
marvel.agent.enabled: enabled

ES status :
root@elk01:/iscsi_disk1/etc/elasticsearch# curl -XGET '
http://localhost:9200/_cluster/health?pretty=true'
{
"cluster_name" : "elastic_test1",
"status" : "yellow",
"timed_out" : false,
"number_of_nodes" : 1,
"number_of_data_nodes" : 1,
"active_primary_shards" : 5,
"active_shards" : 5,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 5
}

On Mon, Jul 14, 2014 at 6:38 AM, Boaz Leskes b.leskes@gmail.com
wrote:

Can you share a screen shot of what you see and also the logs of the
node? I'm looking for the adress Es bound it self to and any error from
marvel

On Mon, Jul 14, 2014 at 2:26 AM, ajay.bh111@gmail.com <
ajay.bh111@gmail.com> wrote:

Tried multiple times with setting it to true or false both but result
is same.
Thanks
Ajay

Sent from my BlackBerry 10 smartphone on the Rogers network.
*From: *Boaz Leskes
*Sent: *Sunday, July 13, 2014 02:09
*To: *elasticsearch@googlegroups.com
*Reply To: *elasticsearch@googlegroups.com
*Subject: *Re: Marvel does not display any contents with ES1.2.1.

Hi Ajay,

I'm not sure exactly what problem you have, but note that you have
disabled data shipping by setting "marvel.agent.enabled: false" . Was this
your intention? If not this why you don't have any data in marvel.

Cheers,
Boaz

PS you probably want to also remove
"indices.memory.index_buffer_size: 50%", unless you plan on doing very
heavy indexing and even then I'd wait until I see problems

On Thursday, July 10, 2014 9:59:52 PM UTC+2, ajay....@gmail.com
wrote:

Hi

I have new test setup for ES and added latest marvel from internet
and tried ipv6 workaround to mentioned in other thread too but display does
not show any contents from the marvel URL. Marvel plugin installed from
internet .

Here is the status (only one node up for debugging for 3 node
cluster)

curl -XGET 'http://127.0.0.1:9200/_cluster/health?pretty=true'
{
"cluster_name" : "elastic_alpha",
"status" : "yellow",
"timed_out" : false,
"number_of_nodes" : 1,
"number_of_data_nodes" : 1,
"active_primary_shards" : 5,
"active_shards" : 5,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 5
}

root@elk01:/usr/local/elasticsearch# bin/plugin --list
Installed plugins:
- marvel
cluster.name: elastic_alpha

elasticsearch.yml file:

node.name: elk01
node.max_local_storage_nodes: 1
index.mapper.dynamic: true
action.auto_create_index: true
action.disable_delete_all_indices: true
path.conf: /iscsi_disk1/etc/elasticsearch
path.data: /iscsi_disk1/data/elasticsearch
path.work: /tmp/work/elasticsearch
path.logs: /iscsi_disk1/logs/elasticsearch
path.plugins: /usr/local/elasticsearch/bin/plugin
bootstrap.mlockall: true
http.port: 9200
gateway.expected_nodes: 1
discovery.zen.minimum_master_nodes: 1
discovery.zen.ping.multicast.enabled: false
cloud.node.auto_attributes: true
discovery.zen.ping.unicast.hosts: [
"elk01:9300","elk02:9300","elk03:9300" ]
indices.memory.index_buffer_size: 50%
marvel.agent.exporter.es.hosts: ["[::1]:9200"]
marvel.agent.enabled: false

Any thing wrong with the config ?

Thanks
Ajay

--
You received this message because you are subscribed to a topic in
the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/rdopCoFhrw8/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/3f66fd8d-211b-49df-bb68-96ee918c53fb%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/3f66fd8d-211b-49df-bb68-96ee918c53fb%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in
the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/rdopCoFhrw8/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/20140714002629.26468518.62786.275%40gmail.com
https://groups.google.com/d/msgid/elasticsearch/20140714002629.26468518.62786.275%40gmail.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/rdopCoFhrw8/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/1405334322396.4de81dad%40Nodemailer
https://groups.google.com/d/msgid/elasticsearch/1405334322396.4de81dad%40Nodemailer?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/rdopCoFhrw8/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAJrOVw17Bw%2BoqTeLraxSkVcW1M2a7PQjRpmUte%3DSJPy15sg-HA%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAJrOVw17Bw%2BoqTeLraxSkVcW1M2a7PQjRpmUte%3DSJPy15sg-HA%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/rdopCoFhrw8/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAKzwz0rVnc0uJe%3DNR99E85-TbdiukQ6saKAfNesU3wot1mmY6w%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAKzwz0rVnc0uJe%3DNR99E85-TbdiukQ6saKAfNesU3wot1mmY6w%40mail.gmail.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

On Wednesday, July 16, 2014 11:28:37 PM UTC+3, ajay b wrote:

Hi Boaz

After playing around with config only I managed to get it working but with
additional parameters set in the config, it does not work, not sure which
parameter breaks it at this time. It appears that once dummy node names are
assigned, it can take all the parameters.

Also with failed config, I see value in health check
"active_primary_shards" : 0, vs when working "active_primary_shards" : 1,.
When does the active primary shard gets created ?

See below the two configs.

Thanks
Ajay

Working config :

cluster.name: elastic_test1
indices.memory.index_buffer_size: 50%
path.conf: /iscsi_disk1/etc/elasticsearch
path.data: /iscsi_disk1/data/elasticsearch
path.work: /iscsi_disk1/work/elasticsearch
path.logs: /iscsi_disk1/logs/elasticsearch
path.plugins: /usr/local/elasticsearch/plugins
bootstrap.mlockall: true
discovery.zen.ping.multicast.enabled: false
discovery.zen.ping.unicast.hosts: [ "
elk01.dbplat.altus.bblabs.rim.net:9300", "
elk02.dbplat.altus.bblabs.rim.net:9300", "
elk03.dbplat.altus.bblabs.rim.net:9300" ]

Failed Config:

action.auto_create_index: true action.disable_delete_all_indices: true bootstrap.mlockall:
true cloud.node.auto_attributes: true cluster.name: elastic_test1 discovery.zen.minimum_master_nodes:
1 discovery.zen.ping.multicast.enabled: false
discovery.zen.ping.unicast.hosts:["elk01.dbplat.altus.bblabs.rim.net:9300
","elk02.dbplat.altus.bblabs.rim.net:9300","
elk03.dbplat.altus.bblabs.rim.net:9300"] gateway.expected_nodes: 1 http.port:
9200 index.mapper.dynamic: true indices.memory.index_buffer_size: 50% marvel.agent.enabled:
enabled marvel.agent.exporter.es.hosts: ["
elk01.dbplat.altus.bblabs.rim.net:9200"] marvel.agent.shard_stats.enabled:
true node.max_local_storage_nodes: 1 node.name:
elk01.dbplat.altus.bblabs.rim.net path.conf:
/iscsi_disk1/etc/elasticsearch path.data: /iscsi_disk1/data/elasticsearch path.logs:
/iscsi_disk1/logs/elasticsearch path.plugins:
/usr/local/elasticsearch/bin/plugin path.work:
/iscsi_disk1/work/elasticsearch

On Tue, Jul 15, 2014 at 5:19 PM, Boaz Leskes b.leskes@gmail.com wrote:

Hi Ajay,

If look at the following line:

[2014-07-14 19:44:23,188][INFO ][plugins ] [elk01]
loaded [], sites []

You can see that the node doesn't find the marvel plugin. How did you
install ES? Did you install marvel with the same user? It may be that the
user running ES has no access to the files? Do you see the marvel files
at /usr/local/elasticsearch/bin/plugin ?

PS I'm not sure which version of internet explorer you are using, but
marvel is compatible with IE9 and up.

On Mon, Jul 14, 2014 at 10:46 PM, ajay b ajay.bh111@gmail.com wrote:

Attached are logs with one config error on hostname fixed (elk001 ->
elk01) and logs in DEBUG. Still no marvel display.
Thanks
Ajay

On Mon, Jul 14, 2014 at 2:12 PM, ajay b ajay.bh111@gmail.com wrote:

Hi Boaz

Attached are the logs, and screenshot. new config (vm recreated) with
fresh install config with marvel agent enabled . Using a single node setup
to find the issue with marvel.

Thanks
Ajay

Config:

cluster.name: elastic_test1
node.name: elk01
node.max_local_storage_nodes: 1
index.mapper.dynamic: true
action.auto_create_index: true
action.disable_delete_all_indices: true
path.conf: /iscsi_disk1/etc/elasticsearch
path.data: /iscsi_disk1/data/elasticsearch
path.work: /iscsi_disk1/work/elasticsearch
path.logs: /iscsi_disk1/logs/elasticsearch
path.plugins: /usr/local/elasticsearch/bin/plugin
bootstrap.mlockall: true
http.port: 9200
gateway.expected_nodes: 1
discovery.zen.minimum_master_nodes: 1
discovery.zen.ping.multicast.enabled: false
cloud.node.auto_attributes: true
discovery.zen.ping.unicast.hosts: [ "elk001:9300" ]
indices.memory.index_buffer_size: 50%
marvel.agent.enabled: enabled

ES status :
root@elk01:/iscsi_disk1/etc/elasticsearch# curl -XGET '
http://localhost:9200/_cluster/health?pretty=true'
{
"cluster_name" : "elastic_test1",
"status" : "yellow",
"timed_out" : false,
"number_of_nodes" : 1,
"number_of_data_nodes" : 1,
"active_primary_shards" : 5,
"active_shards" : 5,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 5
}

On Mon, Jul 14, 2014 at 6:38 AM, Boaz Leskes b.leskes@gmail.com
wrote:

Can you share a screen shot of what you see and also the logs of the
node? I'm looking for the adress Es bound it self to and any error from
marvel

On Mon, Jul 14, 2014 at 2:26 AM, ajay.bh111@gmail.com <
ajay.bh111@gmail.com> wrote:

Tried multiple times with setting it to true or false both but result
is same.
Thanks
Ajay

Sent from my BlackBerry 10 smartphone on the Rogers network.
*From: *Boaz Leskes
*Sent: *Sunday, July 13, 2014 02:09
*To: *elasticsearch@googlegroups.com
*Reply To: *elasticsearch@googlegroups.com
*Subject: *Re: Marvel does not display any contents with ES1.2.1.

Hi Ajay,

I'm not sure exactly what problem you have, but note that you have
disabled data shipping by setting "marvel.agent.enabled: false" . Was this
your intention? If not this why you don't have any data in marvel.

Cheers,
Boaz

PS you probably want to also remove
"indices.memory.index_buffer_size: 50%", unless you plan on doing very
heavy indexing and even then I'd wait until I see problems

On Thursday, July 10, 2014 9:59:52 PM UTC+2, ajay....@gmail.com
wrote:

Hi

I have new test setup for ES and added latest marvel from internet
and tried ipv6 workaround to mentioned in other thread too but display does
not show any contents from the marvel URL. Marvel plugin installed from
internet .

Here is the status (only one node up for debugging for 3 node
cluster)

curl -XGET 'http://127.0.0.1:9200/_cluster/health?pretty=true'
{
"cluster_name" : "elastic_alpha",
"status" : "yellow",
"timed_out" : false,
"number_of_nodes" : 1,
"number_of_data_nodes" : 1,
"active_primary_shards" : 5,
"active_shards" : 5,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 5
}

root@elk01:/usr/local/elasticsearch# bin/plugin --list
Installed plugins:
- marvel
cluster.name: elastic_alpha

elasticsearch.yml file:

node.name: elk01
node.max_local_storage_nodes: 1
index.mapper.dynamic: true
action.auto_create_index: true
action.disable_delete_all_indices: true
path.conf: /iscsi_disk1/etc/elasticsearch
path.data: /iscsi_disk1/data/elasticsearch
path.work: /tmp/work/elasticsearch
path.logs: /iscsi_disk1/logs/elasticsearch
path.plugins: /usr/local/elasticsearch/bin/plugin
bootstrap.mlockall: true
http.port: 9200
gateway.expected_nodes: 1
discovery.zen.minimum_master_nodes: 1
discovery.zen.ping.multicast.enabled: false
cloud.node.auto_attributes: true
discovery.zen.ping.unicast.hosts: [
"elk01:9300","elk02:9300","elk03:9300" ]
indices.memory.index_buffer_size: 50%
marvel.agent.exporter.es.hosts: ["[::1]:9200"]
marvel.agent.enabled: false

Any thing wrong with the config ?

Thanks
Ajay

--
You received this message because you are subscribed to a topic in
the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/rdopCoFhrw8/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/3f66fd8d-211b-49df-bb68-96ee918c53fb%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/3f66fd8d-211b-49df-bb68-96ee918c53fb%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in
the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/rdopCoFhrw8/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/20140714002629.26468518.62786.275%40gmail.com
https://groups.google.com/d/msgid/elasticsearch/20140714002629.26468518.62786.275%40gmail.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/rdopCoFhrw8/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/1405334322396.4de81dad%40Nodemailer
https://groups.google.com/d/msgid/elasticsearch/1405334322396.4de81dad%40Nodemailer?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/rdopCoFhrw8/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAJrOVw17Bw%2BoqTeLraxSkVcW1M2a7PQjRpmUte%3DSJPy15sg-HA%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAJrOVw17Bw%2BoqTeLraxSkVcW1M2a7PQjRpmUte%3DSJPy15sg-HA%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/rdopCoFhrw8/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAKzwz0rVnc0uJe%3DNR99E85-TbdiukQ6saKAfNesU3wot1mmY6w%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAKzwz0rVnc0uJe%3DNR99E85-TbdiukQ6saKAfNesU3wot1mmY6w%40mail.gmail.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/cf037947-5ab6-4d59-8636-327bcda7945c%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(ajay.bh111) #10

Thanks Boaz.

Sorted the problem out. plugin path refers to binary location for marvel
not the executable plugin.
It works now.
Ajay

On Thursday, July 10, 2014 3:59:52 PM UTC-4, ajay b wrote:

Hi

I have new test setup for ES and added latest marvel from internet and
tried ipv6 workaround to mentioned in other thread too but display does not
show any contents from the marvel URL. Marvel plugin installed from
internet .

Here is the status (only one node up for debugging for 3 node cluster)

curl -XGET 'http://127.0.0.1:9200/_cluster/health?pretty=true'
{
"cluster_name" : "elastic_alpha",
"status" : "yellow",
"timed_out" : false,
"number_of_nodes" : 1,
"number_of_data_nodes" : 1,
"active_primary_shards" : 5,
"active_shards" : 5,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 5
}

root@elk01:/usr/local/elasticsearch# bin/plugin --list
Installed plugins:
- marvel
cluster.name: elastic_alpha

elasticsearch.yml file:

node.name: elk01
node.max_local_storage_nodes: 1
index.mapper.dynamic: true
action.auto_create_index: true
action.disable_delete_all_indices: true
path.conf: /iscsi_disk1/etc/elasticsearch
path.data: /iscsi_disk1/data/elasticsearch
path.work: /tmp/work/elasticsearch
path.logs: /iscsi_disk1/logs/elasticsearch
path.plugins: /usr/local/elasticsearch/bin/plugin
bootstrap.mlockall: true
http.port: 9200
gateway.expected_nodes: 1
discovery.zen.minimum_master_nodes: 1
discovery.zen.ping.multicast.enabled: false
cloud.node.auto_attributes: true
discovery.zen.ping.unicast.hosts: [ "elk01:9300","elk02:9300","elk03:9300"
]
indices.memory.index_buffer_size: 50%
marvel.agent.exporter.es.hosts: ["[::1]:9200"]
marvel.agent.enabled: false

Any thing wrong with the config ?

Thanks
Ajay

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/e0d95052-ddd4-4de2-a8ed-b8eb230549f5%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #11