Cannot upgrade node because incompatible indices created with version [6.2.3] exist

I recently started using 8.5.3 version of Elasticsearch.I have some indices that were created in two earlier versions i.e. 7.17.0 and 6.2.3
Now when i while starting Elasticsearch for the version 8.5.3 i am getting the following error-

[2023-06-29T02:29:56,936][ERROR][o.e.b.Elasticsearch      ] [DESKTOP-PFQE75S] fatal exception while booting Elasticsearchjava.lang.IllegalStateException: cannot upgrade node because incompatible indices created with version [6.2.3] exist, while the minimum compatible index version is [7.0.0]. Upgrade your older indices by reindexing them in version [7.17.0] first.
        at org.elasticsearch.server@8.5.3/org.elasticsearch.env.NodeEnvironment.checkForIndexCompatibility(
        at org.elasticsearch.server@8.5.3/org.elasticsearch.env.NodeEnvironment.upgradeLegacyNodeFolders(
        at org.elasticsearch.server@8.5.3/org.elasticsearch.env.NodeEnvironment.<init>(
        at org.elasticsearch.server@8.5.3/org.elasticsearch.node.Node.<init>(
        at org.elasticsearch.server@8.5.3/org.elasticsearch.node.Node.<init>(

Can anyone please help me to resolve this?
Can we temporarily bypass this particular check?
If not what do i need to do?Do i need to reindex these 6.x version indices?If yes can you please share some relevant link mentioning steps for the same?

The 7.17 Upgrade Assistant should have picked up that you have old indices that need to be indexed. I believe you now need to go back to 7.17 and reindex the old indices there before upgrade to version 8. Make sure you also address any other issues identified by tbe assistant.

We improved the error message in More actionable error for ancient indices by DaveCTurner · Pull Request #91243 · elastic/elasticsearch · GitHub (8.6.0) to answer your questions about how to address this. If you were using a newer version you would get this message:

Revert this node to version [<PREVIOUS_VERSION>] and delete any indices with
versions earlier than [7.0.0] before upgrading to version [8.6.0]. If all such
indices have already been deleted, revert this node to version
[<PREVIOUS_VERSION>] and wait for it to join the cluster to clean up any older
indices from its metadata.

8.5.3 is already several versions old, why not use the latest?

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.