Cant Change Elastic Search Port On Kibana


(Gokhan ARTUK) #1

Hi

I am new to kibana and having a problem about changed default elasticsearch port on kibana. What I am trying to do is change default 9200 port to 9205 in elastichsearch. For the elasticsearch part I am able to do that by changing http.port: 9205 value in elastichsearch.yml

But even I change config\kibana.yml elasticsearch.url to #elasticsearch.url: "http://localhost:9205" kibana only trying to listen http://localhost.9200 and having problem about finding live connections.

I spent 2-3 days on it but couldnt find any solution.


(Brandon Kobel) #2

Hey @gokhankocak, the elasticsearch.url setting is what you should change, if you run the following from the Kibana server, what do you see?

curl http://localhost:9205

(Gokhan ARTUK) #3

Hi,

I made a big mistake. I didnt know that # means commented line in kibana.yml file. I removed that sign from the beginin and it is working now. Sorry for misunderstanding


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.