Can't connect to kibana on google cloud ubuntu vm


(Jonathan Talmi) #1

tl;dr I can start the kibana service but port 5601 doesn't open.

I'm having trouble setting up kibana on a brand new ubuntu instance on google cloud platform. I have elasticsearch up and running on localhost:9200, but when I installed kibana using the instructions [here](https://www.elastic.co/guide/en/kibana/current/deb.html), it doesn't work.

My elasticsearch.yml config:

network.host: 0.0.0.0
http.port: 9200-9300

curl localhost:9200 works fine.

My kibana config:

server.port: 5601
server.host: "0.0.0.0"
elasticsearch.url: "http://localhost:9200"
elasticsearch.preserveHost: true
logging.dest: /var/log/kibana/kibana.log

Note that I had to add the logging dest because otherwise i wasn't able to start the service using /bin/systemctl.

Now, sudo /bin/systemctl status kibana.service reveals that my kibana service is running, but kibana is absent from sudo netstat -ntpl, and curl localhost:5601 yields Failed to connect to localhost port 5601: Connection refused

I've tried different configurations of kibana.yml. I've tried setting server.host to localhost, or my google cloud node's internal IP, and it doesn't work.


(Pavel Bogdanov) #2

Since you turned on logging, could not you put log here from /var/log/kibana/kibana.log file?

I also checked my kibana installation and all fields except logging.dest are commented out. Nevertheless, I quietly see kibana on 127.0.0.1:5601


(Jonathan Talmi) #3

Hi Pavel, I should have followed up.

I turned on logging but nothing was being written to /var/log/kibana/kibana.log. I checked it several times.

I ended up installing a new kibana instance using curl straight into my user folder instead of using apt-get as I did initially. It worked. I'm not sure if the original problem was a permissions thing or my own incompetence. Thanks for the reply regardless, can you close this now?


(kulkarni) #4

Thanks for circling back with the solution which worked for you. Closing.

Cheers
Rashmi


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.