Can't load kibana on 5601


(Babeesh) #1

I have installed Elasticsearch, Logstash, Kibana and Nginx following this guide,

Elasticsearch is running on 9200
curl http://localhost:9200 gives the correct configuration.

But curl http://localhost:5601 gives

curl: (7) Failed to connect to localhost port 5601: Connection refused

In kibana.yml file I put

server.port: 5601
server.host: "127.0.0.1" Here I also checked with localhost and aws private ip address.

And while checking the port I am getting

netstat -anp | grep 5601

(No info could be read for "-p": geteuid()=1000 but you should be root.)

I can start kibana using sudo service kibana start

But while checking status using sudo service kibana status

kibana is not running

I haven't setup firewall . sudo ufw status

Status : Inactive

I am confused, why kibana port is not listening. Please help me to solve this.


(Mark Walkom) #2

What version of KB did you install?


(Babeesh) #3

Ubuntu 14.04
Elasticsearch 2.2.x, Logstash 2.2.x, and Kibana 4.4.x


(Christian Dahlqvist) #4

Based on the article it looks like it assumes Nginx is used as a proxy in front of Kibana, listening to port 80. Can you connect to port 80?


(Babeesh) #5

Yes I can connect to Port 80.


(Teewhey) #6

Do you mind to post the result of :

  1. ps -ef | grep kibana
  2. Content of your kibana.yml

(Babeesh) #7

1. ubuntu 2686 1415 0 07:40 pts/1 00:00:00 grep --color=auto kibana

2. server.host: "172.30.0.28:5601"


(Babeesh) #8

Its running now.
When I checked kibana log (vi /var/log/kibana/kibana.stderr)

Error: EACCES, permission denied '/opt/kibana/optimize/.babelcache.json'

So I changed permission of .babelcache.json
sudo chown -R kibana:root /opt/kibana/optimize/.babelcache.json

Then restarted kibana , Solved the issue.


(Richard Vencu) #9

Hi, I am in the same situation. Kibana worked for me, then after some time while playing with indexes it started to behave strangely, finally after a reboot it refuses connection to port 5601

I tried to uninstall, deleted all /opt/kibana files, reinstalled latest version, nothing is working

I even cannot access any log, I created a log file for kibana and set it into kibana.yml but it is always zero sized.

The service starts after an initial failure but connection to the port is denied.


(Duwayne Engelhardt) #10

I searched for an answer for 7 hours. I found that that in the kibana.yml file, if you change port: 5601 to server.port: 5601, I can connect to the server and port with curl. I have another error message and Kibana is not showing me Elasticsearch yet, but that is progress. And then after rebooting it would not start. However, changing it back to port: 5601 and restarting Kibana caused it to work again.


(system) #11