Can't Create Enrollment Token

When I try to open elasticsearch-create-enrollment-token, it crashes. I can't do anything with it; I click it, it pops up on my screen for half a second, and then closes.

Someone please help me. I have waited nearly a week for a response. I'm taking this course to get a job so I can pay for my university tuition, which starts in January. I need some assistance ASAP.

Hi @Bethanie_Tipton, Welcome to the community, sorry for the delayed response sooo many questions on the site right now! :slight_smile:

What OS are you on... Windows?

The executables are not GUI apps (i.e you cannot click on them): they are command line utilities you will need to use Powershell.

Are you following our documentation?

Yes, I am on Windows.

Oh, I did not realize. I was trying to use Command Prompt.

However, after much frustration, I still cannot get Elasticsearch to work. When I run ls it doesn't show up in my directory, nor does Kibana. When I try bin\elasticsearch.bat, PowerShell doesn't recognize it and says the module 'bin' could not be loaded. When I try cd elasticsearch/ it says it cannot find the path because it doesn't exist.

Hi @Bethanie_Tipton

Are you following official documentation?

Here is the installation for windows

If you want help you will need show us how you installed and the what commands you are running and the results

Do you have access to docker? That may be easier to get it all running?

I installed Elasticsearch first, then Kibana. I unzipped Elastic and Kibana and they are in Program Files. I opened config/kibana.yml and set elasticsearch.url to point at my Elasticsearch instance and uncommented.

If I run bin\elasticsearch.bat in PowerShell:

bin\elasticsearch.bat : The module 'bin' could not be loaded. For more information, run 'Import-Module bin'.
At line:1 char:1
+ bin\elasticsearch.bat
+ ~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : ObjectNotFound: (bin\elasticsearch.bat:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CouldNotAutoLoadModule

I don't know enough about Docker to get it to work unfortunately.

So you are following these directions?

notice the command is

.\bin\elasticsearch.bat with a .\

the .\ says relative to the directory I am in

And you need to be in the correct directory

Well you install docker-desktop and then we give you a docker-compose.yml and you run 1 command and it works :slight_smile:

but we can try that another time.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.