Cant create index after deleted them all

So, i have deleted all my indicies, using the endpoint:

DELETE <apiEndpoint>/*

after this, started to add data to elastic search again, which are arriving there successfully.

In kibana, when i create index, it seems its gets created but then going to "Discover" page, it says:

In order to viziualize and explore data in Kibana, you'll need to create an index pattern to retrieve data from Elasticsearch.

In the Dev Tools, executing the query:

GET _search
{
  "query": {
    "match_all": {}
  }
}

successfulkly returns my index, as well as the data.

How can I solve this problem? Been stuck here for days now, and finally i've decided to come here and ask, maybe someone could help me out.

Thank you,

One additial info:

If i go to advanced settings, and set the defaultIndex to the id of the index, and save it, it does not get saved. Refreshing kibana and the value I just set is gone.

What is happening here?

if you delete all your data, you also delete the kibana configuration data like index patterns. You need to recreate an index pattern in order to use kibana's discover/visualize tabs. You can go to 'Discover' and add an index pattern there.

In the future, you should probably not delete the .kibana index, unless you are really sure about that (this also deletes your visualizations and dashboards).

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.