Cant get Mapping to work

I always get "No cached Mapping..." for the context.request. and context.response. fields.

I tried changing the Mapping in APM-Server to enable the fields. But i cant get Kibana to recognize it. I also tried to refresh the index pattern.

Kibana version:

Elasticsearch version:
APM Server version:
APM Agent language and version:
Java 1.3.1-SNAPSHOT

Original install method (e.g. download page, yum, deb, from source, etc.) and version:
Fresh install or upgraded from other version?
Is there anything special in your setup? For example, are you using the Logstash or Kafka outputs? Are you using a load balancer in front of the APM Servers? Have you changed index pattern, generated custom templates, changed agent configuration etc.

Description of the problem including expected versus actual behavior. Please include screenshots (if relevant):

Use the Fields as intended, but without cached mapping i cant do anything with the fields.


Not all of the fields in context.request and context.response are indexed, which could explain the behaviour you are seeing. Which fields in particular are we talking about?

Fields that are unindexed are not searchable.

Btw. How did you create the index pattern? If you created it manually via the Management section, I'd suggest you delete it again, and instead import it via the APM Getting Started guide: https://<your domain>/app/kibana#/home/tutorial/apm


i've created it via the kibana setup guide.

The fields in question are:

  • ? context.request.body.catalogName
  • ? context.request.body.query
  • ? context.request.cookies.JSESSIONID
  • ? context.request.cookies.server-time
  • ? context.request.cookies.session-expiry
  • ? context.request.headers.accept-charset
  • ? context.request.headers.accept-encoding
  • ? context.request.headers.accept-language
  • ? context.request.headers.connection
  • ? context.request.headers.content-length
  • ? context.request.headers.content-type
  • ?
  • ? context.request.headers.user-agent
  • ? context.request.socket.encrypted
  • ? context.request.socket.remote_address
  • ? context.response.headers.Content-Type
  • ? context.response.headers.Date
  • ? context.response.headers.Set-Cookie
  • ? context.response.headers.Transfer-Encoding

i've edited the fields.yml of the apm-server by simply commented out the enabled: false

thx for the help

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.