No cached mapping for this field --> APM


(Umapati Singh) #1

I am using APM to monitor my node.js application. In Kibana, I see some fields with the error : " no cached mapping for this field". As a result, I cannot run any analytics or visualization on these fields.

example of fields that are being indexed:
context.request.http_version
context.request.method
context.request.url.full
context.request.url.hash

example of fields that are not being indexed:
context.request.body.app_id
context.request.body.Msg.MsgHdr.StatusCode
context.request.body.Msg.MsgHdr.StatusDesc

I have tried editing the fields.yml for apm-server. but i cant see those fields in the index management tab.

What am I missing?


(Ron Cohen) #2

Hi Umapati,

Have you created an index pattern that matches your APM indexes? If yes, could you try to go to Settings > Indices in Kibana and click the "Refresh field list" (yellow button) for that index pattern.

Let me know if that helps.

best,
Ron


(Umapati Singh) #3

Hi Ron,

I have update the fields.yml located @ /etc/apm-server with the missing parameters. However, I dont see them updated under kibana.


(Ron Cohen) #4

Thanks! The recommended way to get additional fields indexed at the moment is to add them to "tags": https://www.elastic.co/guide/en/apm/agent/nodejs/current/agent-api.html#apm-set-tag

For some fields that might be impossible or very inconvenient. It turns out that unfortunately 6.4 introduced a small bug which requires that you set setup.template.fields to fields.yml in order for apm-server to load the file. I've filed an issue https://github.com/elastic/beats/issues/8607.

Please also make sure you've set setup.template.overwrite: true and that it only works for newly created indices.

Let me know if that helps.

/Ron


Ability to add more exported fields in APM
(system) #5

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.