Can't open Kibana because it says I'm using Elasticsearch 6.2.4


#1

So I downloaded Elasticsearch and Kibana (both versions 6.4) but when I run bin/kibana (after having ran bin/elasticsearch) I get the error:

log [16:53:08.247] [error][status][plugin:security@6.4.0] Status changed from yellow to red - This version of Kibana requires Elasticsearch v6.4.0 on all nodes. I found the following incompatible nodes in your cluster: v6.2.4 @ 127.0.0.1:9200 (127.0.0.1)

And when I open localhost:5601 I get the error:

"It appears you're running the oss-only distribution of Elasticsearch.

To use the full set of free features in this distribution of Kibana, please update Elasticsearch to the default distribution."

I'm not sure why this is because I have downloaded version 6.4 of elasticsearch (the folder name from unzipping is called elasticsearch-6.4.0). Furthermore when I open localhost:9200 it says my cluster version number is 6.2.4 even though the folder is 6.4.0 so I have no idea what's going on.

Any help would be appreciated!


(Dawn Okem) #2

I had the same issue after running yum update to upgrade to version 6.4
I had to restart elasticsearch service. This solved the issue for me.

hope it helps .


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.