Can't search by custom response headers

Kibana version: 7.15.1

Elasticsearch version: 7.15.1

APM Server version:7.15.1

APM Agent language and version: 1.26.0 Java


I'm facing an issue that I can't make serachable transcations in APM UI. for http.response.headers that are in metadata

Specificly X-Transcation-ID

I have set up setup in APM server:

setup.template.overwrite: true


  • name: http.response.headers

    type: object

    dynamic: true

Seems that it doesn't work

@ufanautas welcome to the forum!

Did you make the config change before or after you started ingesting data? Existing indices won't be affected, so you would have to perform a manual rollover on your APM index aliases (apm-7.15.1-transaction, apm-7.15.1-span, ...). See Rollover API | Elasticsearch Guide [7.16] | Elastic for how to do that.

@axw As I use Docker, I just completely wipe out elastic volume's and built APM image (as i'm copying config inside of it in docker file) Seems nothing to change. only Elasticsearch has persistent volume configured. So a bit confused. Will try this. Will write if it work thanks!

It worked. But APM search bar seems to still use the old ones? The mappings updated, created a new index with it. But it still not searchable

IT worked had to target to create new index with _rollover/transcation001, but now it seems that the APM server doesn't get anything from its agent.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.