Change the default script language


(Or Weinberger) #1

Hi all,

Running ES 2.3.1 and latest Kibana version (pre 5)

I've set up the javascript language plugin and defined it in my elasticsearch.yml as the default language and enabled inline scripting.

However, when I attempt to set a scripted field via Kibana, I get an error and looking at the elasticsearch logs I can see it tries to parse the script via expression instead of javascript.

I verified that the javascript plugin is loaded and enabled on all cluster nodes. How can I tell Kibana to use javascript to parse scripted fields?

Thanks.


(Tyler Smalley) #2

Unfortunately this is not something which is currently supported.

There is a ticket open to provide this functionality: https://github.com/elastic/kibana/issues/6529


(Or Weinberger) #3

I found a hacky workaround which is to manually update the index-pattern in the .kibana index and change the lang to javascript which works great.


(system) #4