Changing node and cluster name Version: 1.1.1


(Francesco Audisio) #1

Hi all,

I am a beginner with Marvel, and I already meet a first difficulty =)

as I do to change and to assign with IP adress of the pc the name of the
node with this file:

elasticsearch.yml

because inside this file I have found this line

Node names are generated dynamically on startup, so you're relieved

from configuring them manually. You can tie this node to a specific name:

node.name:

but I don't understand as I do to write the name of the node, it produces
in automatic of the nodes names and I know this it is normal however as I
do to change him the name?

I repeat I am a beginner I want to learn =D

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/779a286a-96fe-4173-97f8-4a4bca017d50%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #2

Uncomment the line and put any nam you want:

node.name: My name

Is that what you are looking for?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 7 mai 2014 à 22:44:00, Francesco Audisio (cesco723@gmail.com) a écrit:

Hi all,

I am a beginner with Marvel, and I already meet a first difficulty =)

as I do to change and to assign with IP adress of the pc the name of the node with this file:

elasticsearch.yml

because inside this file I have found this line

Node names are generated dynamically on startup, so you're relieved

from configuring them manually. You can tie this node to a specific name:

node.name:

but I don't understand as I do to write the name of the node, it produces in automatic of the nodes names and I know this it is normal however as I do to change him the name?

I repeat I am a beginner I want to learn =D

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/779a286a-96fe-4173-97f8-4a4bca017d50%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.536a9b68.2ae8944a.944f%40MacBook-Air-de-David.local.
For more options, visit https://groups.google.com/d/optout.


(Francesco Audisio) #3

yes i have uncomment the line but now the Elasticsearch server not start
properly, i have this error:

sudo /etc/init.d/elasticsearch restart
[ ok ] Stopping Elasticsearch Server: Elasticsearch Server is not running
but pid file exists, cleaning up.
[ ok ] Starting Elasticsearch Server:.

but if i comment the line the server start properly with random node
name, I do not understand why, I have to compile the entire file?

Il giorno mercoledì 7 maggio 2014 22:45:28 UTC+2, David Pilato ha scritto:

Uncomment the line and put any nam you want:

node.name: My name

Is that what you are looking for?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 7 mai 2014 à 22:44:00, Francesco Audisio (cesc...@gmail.com<javascript:>)
a écrit:

Hi all,

I am a beginner with Marvel, and I already meet a first difficulty =)

as I do to change and to assign with IP adress of the pc the name of the
node with this file:

elasticsearch.yml

because inside this file I have found this line

Node names are generated dynamically on startup, so you're relieved

from configuring them manually. You can tie this node to a specific

name:

node.name:

but I don't understand as I do to write the name of the node, it produces
in automatic of the nodes names and I know this it is normal however as I
do to change him the name?

I repeat I am a beginner I want to learn =D

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/779a286a-96fe-4173-97f8-4a4bca017d50%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/779a286a-96fe-4173-97f8-4a4bca017d50%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/aed42466-db44-409b-b268-d04d2c5e4749%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #4

Can you see anything in elasticsearch logs or in system logs?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 7 mai 2014 à 23:13:01, Francesco Audisio (cesco723@gmail.com) a écrit:

yes i have uncomment the line but now the Elasticsearch server not start properly, i have this error:

sudo /etc/init.d/elasticsearch restart
[ ok ] Stopping Elasticsearch Server: Elasticsearch Server is not running but pid file exists, cleaning up.
[ ok ] Starting Elasticsearch Server:.

but if i comment the line the server start properly with random node name, I do not understand why, I have to compile the entire file?

Il giorno mercoledì 7 maggio 2014 22:45:28 UTC+2, David Pilato ha scritto:
Uncomment the line and put any nam you want:

node.name: My name

Is that what you are looking for?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 7 mai 2014 à 22:44:00, Francesco Audisio (cesc...@gmail.com) a écrit:

Hi all,

I am a beginner with Marvel, and I already meet a first difficulty =)

as I do to change and to assign with IP adress of the pc the name of the node with this file:

elasticsearch.yml

because inside this file I have found this line

Node names are generated dynamically on startup, so you're relieved

from configuring them manually. You can tie this node to a specific name:

node.name:

but I don't understand as I do to write the name of the node, it produces in automatic of the nodes names and I know this it is normal however as I do to change him the name?

I repeat I am a beginner I want to learn =D

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/779a286a-96fe-4173-97f8-4a4bca017d50%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/aed42466-db44-409b-b268-d04d2c5e4749%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.536b21f7.7fdcc233.944f%40MacBook-Air-de-David.local.
For more options, visit https://groups.google.com/d/optout.


(Francesco Audisio) #5

Today evening i check, thank you very much.

Il giorno giovedì 8 maggio 2014 08:19:35 UTC+2, David Pilato ha scritto:

Can you see anything in elasticsearch logs or in system logs?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 7 mai 2014 à 23:13:01, Francesco Audisio (cesc...@gmail.com<javascript:>)
a écrit:

yes i have uncomment the line but now the Elasticsearch server not start
properly, i have this error:

sudo /etc/init.d/elasticsearch restart
[ ok ] Stopping Elasticsearch Server: Elasticsearch Server is not running
but pid file exists, cleaning up.
[ ok ] Starting Elasticsearch Server:.

but if i comment the line the server start properly with random node
name, I do not understand why, I have to compile the entire file?

Il giorno mercoledì 7 maggio 2014 22:45:28 UTC+2, David Pilato ha scritto:

Uncomment the line and put any nam you want:

node.name: My name

Is that what you are looking for?

 -- 

David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 7 mai 2014 à 22:44:00, Francesco Audisio (cesc...@gmail.com) a écrit:

Hi all,

I am a beginner with Marvel, and I already meet a first difficulty =)

as I do to change and to assign with IP adress of the pc the name of the
node with this file:

elasticsearch.yml

because inside this file I have found this line

Node names are generated dynamically on startup, so you're relieved

from configuring them manually. You can tie this node to a specific

name:

node.name:

but I don't understand as I do to write the name of the node, it
produces in automatic of the nodes names and I know this it is normal
however as I do to change him the name?

I repeat I am a beginner I want to learn =D

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/779a286a-96fe-4173-97f8-4a4bca017d50%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/779a286a-96fe-4173-97f8-4a4bca017d50%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/aed42466-db44-409b-b268-d04d2c5e4749%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/aed42466-db44-409b-b268-d04d2c5e4749%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/82968833-3bfe-4a7a-9a1c-9574a06d3621%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Francesco Audisio) #6

i upload the file log, the problem start in the line 491

Il giorno giovedì 8 maggio 2014 08:19:35 UTC+2, David Pilato ha scritto:

Can you see anything in elasticsearch logs or in system logs?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 7 mai 2014 à 23:13:01, Francesco Audisio (cesc...@gmail.com<javascript:>)
a écrit:

yes i have uncomment the line but now the Elasticsearch server not start
properly, i have this error:

sudo /etc/init.d/elasticsearch restart
[ ok ] Stopping Elasticsearch Server: Elasticsearch Server is not running
but pid file exists, cleaning up.
[ ok ] Starting Elasticsearch Server:.

but if i comment the line the server start properly with random node
name, I do not understand why, I have to compile the entire file?

Il giorno mercoledì 7 maggio 2014 22:45:28 UTC+2, David Pilato ha scritto:

Uncomment the line and put any nam you want:

node.name: My name

Is that what you are looking for?

 -- 

David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 7 mai 2014 à 22:44:00, Francesco Audisio (cesc...@gmail.com) a écrit:

Hi all,

I am a beginner with Marvel, and I already meet a first difficulty =)

as I do to change and to assign with IP adress of the pc the name of the
node with this file:

elasticsearch.yml

because inside this file I have found this line

Node names are generated dynamically on startup, so you're relieved

from configuring them manually. You can tie this node to a specific

name:

node.name:

but I don't understand as I do to write the name of the node, it
produces in automatic of the nodes names and I know this it is normal
however as I do to change him the name?

I repeat I am a beginner I want to learn =D

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/779a286a-96fe-4173-97f8-4a4bca017d50%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/779a286a-96fe-4173-97f8-4a4bca017d50%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/aed42466-db44-409b-b268-d04d2c5e4749%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/aed42466-db44-409b-b268-d04d2c5e4749%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/36c4e9e1-c5f9-4c9f-b5b2-7024a2512b3e%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #7

Please use GIST instead of attaching files.

Did you set name to be "Blind Faith"?

Could you gist your elasticsearch.yml file?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 8 mai 2014 à 08:44:49, Francesco Audisio (cesco723@gmail.com) a écrit:

i upload the file log, the problem start in the line 491

Il giorno giovedì 8 maggio 2014 08:19:35 UTC+2, David Pilato ha scritto:
Can you see anything in elasticsearch logs or in system logs?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 7 mai 2014 à 23:13:01, Francesco Audisio (cesc...@gmail.com) a écrit:

yes i have uncomment the line but now the Elasticsearch server not start properly, i have this error:

sudo /etc/init.d/elasticsearch restart
[ ok ] Stopping Elasticsearch Server: Elasticsearch Server is not running but pid file exists, cleaning up.
[ ok ] Starting Elasticsearch Server:.

but if i comment the line the server start properly with random node name, I do not understand why, I have to compile the entire file?

Il giorno mercoledì 7 maggio 2014 22:45:28 UTC+2, David Pilato ha scritto:
Uncomment the line and put any nam you want:

node.name: My name

Is that what you are looking for?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 7 mai 2014 à 22:44:00, Francesco Audisio (cesc...@gmail.com) a écrit:

Hi all,

I am a beginner with Marvel, and I already meet a first difficulty =)

as I do to change and to assign with IP adress of the pc the name of the node with this file:

elasticsearch.yml

because inside this file I have found this line

Node names are generated dynamically on startup, so you're relieved

from configuring them manually. You can tie this node to a specific name:

node.name:

but I don't understand as I do to write the name of the node, it produces in automatic of the nodes names and I know this it is normal however as I do to change him the name?

I repeat I am a beginner I want to learn =D

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/779a286a-96fe-4173-97f8-4a4bca017d50%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/aed42466-db44-409b-b268-d04d2c5e4749%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/36c4e9e1-c5f9-4c9f-b5b2-7024a2512b3e%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.536b2df9.431bd7b7.944f%40MacBook-Air-de-David.local.
For more options, visit https://groups.google.com/d/optout.


(Francesco Audisio) #8

No i haven't set "Blind Faith",what is it?

this is my elasticsearch-yml:

Il giorno giovedì 8 maggio 2014 09:10:49 UTC+2, David Pilato ha scritto:

Please use GIST instead of attaching files.

Did you set name to be "Blind Faith"?

Could you gist your elasticsearch.yml file?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 8 mai 2014 à 08:44:49, Francesco Audisio (cesc...@gmail.com<javascript:>)
a écrit:

i upload the file log, the problem start in the line 491

Il giorno giovedì 8 maggio 2014 08:19:35 UTC+2, David Pilato ha scritto:

Can you see anything in elasticsearch logs or in system logs?

 -- 

David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 7 mai 2014 à 23:13:01, Francesco Audisio (cesc...@gmail.com) a écrit:

yes i have uncomment the line but now the Elasticsearch server not
start properly, i have this error:

sudo /etc/init.d/elasticsearch restart
[ ok ] Stopping Elasticsearch Server: Elasticsearch Server is not running
but pid file exists, cleaning up.
[ ok ] Starting Elasticsearch Server:.

but if i comment the line the server start properly with random node
name, I do not understand why, I have to compile the entire file?

Il giorno mercoledì 7 maggio 2014 22:45:28 UTC+2, David Pilato ha scritto:

Uncomment the line and put any nam you want:

node.name: My name

Is that what you are looking for?

 -- 

David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 7 mai 2014 à 22:44:00, Francesco Audisio (cesc...@gmail.com) a écrit:

Hi all,

I am a beginner with Marvel, and I already meet a first difficulty =)

as I do to change and to assign with IP adress of the pc the name of the
node with this file:

elasticsearch.yml

because inside this file I have found this line

Node names are generated dynamically on startup, so you're relieved

from configuring them manually. You can tie this node to a specific

name:

node.name:

but I don't understand as I do to write the name of the node, it
produces in automatic of the nodes names and I know this it is normal
however as I do to change him the name?

I repeat I am a beginner I want to learn =D

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/779a286a-96fe-4173-97f8-4a4bca017d50%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/779a286a-96fe-4173-97f8-4a4bca017d50%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/aed42466-db44-409b-b268-d04d2c5e4749%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/aed42466-db44-409b-b268-d04d2c5e4749%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/36c4e9e1-c5f9-4c9f-b5b2-7024a2512b3e%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/36c4e9e1-c5f9-4c9f-b5b2-7024a2512b3e%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.


--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/3b88084e-b42d-4fd1-80d0-339b6567d00a%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #9

You should write something like:

node.name: 192.168.0.12.raspi1

Does it work?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 8 mai 2014 à 09:22:06, Francesco Audisio (cesco723@gmail.com) a écrit:

No i haven't set "Blind Faith",what is it?

this is my elasticsearch-yml:

Il giorno giovedì 8 maggio 2014 09:10:49 UTC+2, David Pilato ha scritto:
Please use GIST instead of attaching files.

Did you set name to be "Blind Faith"?

Could you gist your elasticsearch.yml file?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 8 mai 2014 à 08:44:49, Francesco Audisio (cesc...@gmail.com) a écrit:

i upload the file log, the problem start in the line 491

Il giorno giovedì 8 maggio 2014 08:19:35 UTC+2, David Pilato ha scritto:
Can you see anything in elasticsearch logs or in system logs?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 7 mai 2014 à 23:13:01, Francesco Audisio (cesc...@gmail.com) a écrit:

yes i have uncomment the line but now the Elasticsearch server not start properly, i have this error:

sudo /etc/init.d/elasticsearch restart
[ ok ] Stopping Elasticsearch Server: Elasticsearch Server is not running but pid file exists, cleaning up.
[ ok ] Starting Elasticsearch Server:.

but if i comment the line the server start properly with random node name, I do not understand why, I have to compile the entire file?

Il giorno mercoledì 7 maggio 2014 22:45:28 UTC+2, David Pilato ha scritto:
Uncomment the line and put any nam you want:

node.name: My name

Is that what you are looking for?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 7 mai 2014 à 22:44:00, Francesco Audisio (cesc...@gmail.com) a écrit:

Hi all,

I am a beginner with Marvel, and I already meet a first difficulty =)

as I do to change and to assign with IP adress of the pc the name of the node with this file:

elasticsearch.yml

because inside this file I have found this line

Node names are generated dynamically on startup, so you're relieved

from configuring them manually. You can tie this node to a specific name:

node.name:

but I don't understand as I do to write the name of the node, it produces in automatic of the nodes names and I know this it is normal however as I do to change him the name?

I repeat I am a beginner I want to learn =D

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/779a286a-96fe-4173-97f8-4a4bca017d50%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/aed42466-db44-409b-b268-d04d2c5e4749%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/36c4e9e1-c5f9-4c9f-b5b2-7024a2512b3e%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/3b88084e-b42d-4fd1-80d0-339b6567d00a%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.536b5fb1.6b8b4567.9e48%40air-de-david.esprit.tn.
For more options, visit https://groups.google.com/d/optout.


(Francesco Audisio) #10

thanks you very much!!!! now Work!!! =)

Il giorno giovedì 8 maggio 2014 12:42:57 UTC+2, David Pilato ha scritto:

You should write something like:

node.name: 192.168.0.12.raspi1

Does it work?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 8 mai 2014 à 09:22:06, Francesco Audisio (cesc...@gmail.com<javascript:>)
a écrit:

No i haven't set "Blind Faith",what is it?

this is my elasticsearch-yml:

https://gist.github.com/Fraaud/89114d2ad6b70daa3437#file-elasticsearch-yml

Il giorno giovedì 8 maggio 2014 09:10:49 UTC+2, David Pilato ha scritto:

Please use GIST instead of attaching files.

Did you set name to be "Blind Faith"?

Could you gist your elasticsearch.yml file?

 -- 

David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 8 mai 2014 à 08:44:49, Francesco Audisio (cesc...@gmail.com) a écrit:

i upload the file log, the problem start in the line 491

Il giorno giovedì 8 maggio 2014 08:19:35 UTC+2, David Pilato ha scritto:

Can you see anything in elasticsearch logs or in system logs?

 -- 

David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 7 mai 2014 à 23:13:01, Francesco Audisio (cesc...@gmail.com) a écrit:

yes i have uncomment the line but now the Elasticsearch server not
start properly, i have this error:

sudo /etc/init.d/elasticsearch restart
[ ok ] Stopping Elasticsearch Server: Elasticsearch Server is not
running but pid file exists, cleaning up.
[ ok ] Starting Elasticsearch Server:.

but if i comment the line the server start properly with random node
name, I do not understand why, I have to compile the entire file?

Il giorno mercoledì 7 maggio 2014 22:45:28 UTC+2, David Pilato ha
scritto:

Uncomment the line and put any nam you want:

node.name: My name

Is that what you are looking for?

 -- 

David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 7 mai 2014 à 22:44:00, Francesco Audisio (cesc...@gmail.com) a
écrit:

Hi all,

I am a beginner with Marvel, and I already meet a first difficulty =)

as I do to change and to assign with IP adress of the pc the name of
the node with this file:

elasticsearch.yml

because inside this file I have found this line

Node names are generated dynamically on startup, so you're relieved

from configuring them manually. You can tie this node to a specific

name:

node.name:

but I don't understand as I do to write the name of the node, it
produces in automatic of the nodes names and I know this it is normal
however as I do to change him the name?

I repeat I am a beginner I want to learn =D

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/779a286a-96fe-4173-97f8-4a4bca017d50%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/779a286a-96fe-4173-97f8-4a4bca017d50%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/aed42466-db44-409b-b268-d04d2c5e4749%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/aed42466-db44-409b-b268-d04d2c5e4749%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/36c4e9e1-c5f9-4c9f-b5b2-7024a2512b3e%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/36c4e9e1-c5f9-4c9f-b5b2-7024a2512b3e%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.


--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/3b88084e-b42d-4fd1-80d0-339b6567d00a%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/3b88084e-b42d-4fd1-80d0-339b6567d00a%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/bec9853b-e273-47d8-9989-fd83e74a5726%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #11