Changing the 1d interval in Visual Builder


(Addison) #1

I love the new visual builder tool and it has been very helpful but when i set the interval to "1d" it buckets the data in 24 hour periods from 7:00pm - 7:00pm. Its still great for comparing the data to itself but when I compare it to other visualizations that we use for BI it makes it hard to compare. Is there any functionality to change how visual builder designates that 1d interval?


(Lee Drengenberg) #2

Hi Addison,

Can you post a screenshot of what you're seeing?

Are you looking at it around 7PM by any chance and it's using the current time as the end of each 24 hour period?

Can you check your Management > Advanced Settings > dateFormat:tz and tell us if you have the default setting of browser?

What timezone are you in? If you happen to be in Central time zone like me (UTC-5), then I think 7PM is midnight UTC? Could that be the issue? If so, that could be a bug and we can get it filed.

WARNING: You could try changing that dateFormat:tz to see if it helps, but be aware that it is a global setting that affects all Kibana users.

Thanks,
Lee


(Addison) #3

The dateFormat:tz was set to America/Chicago


(Addison) #4

You can see how the last bucket is incomplete even though we are looking at the time interval through 23:59:59.999


(Lee Drengenberg) #5

Hi Addison,

Yes, I think it's a bug. I compared a daily time interval on other Kibana charts and it looks like those use your local time offset when it requests the data from Elasticsearch and then shows it to you in your local time and the Visual Build doesn't seem to do that.

Thanks for reporting this!


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.