Chrome Sense Beta plugin flagged as malware


(Bryce Etheridge) #1

Hey,

Starting with Chrome 61, the old browser extension version of sense (https://github.com/elastic/sense) was marked by Google as containing malware. It's been removed from the chrome webstore, and the browser forcibly disables the extension.

I'm fine with the extension going away (it's been deprecated for more than a year in favor of kibana). What i'd like to know is why it was flagged as malware and if I need to worry about my system being compromised for having used it for so long.

Thanks,
--Bryce


(Bryce Etheridge) #2

To be clear, I'm asking here because the chrome plugin was developed by the elastic team back in the day. So someone here should have been the one to upload it to the Chrome web store and presumably would have more info from Google about whats up.


(kulkarni) #3

I have raised this question internally, once I get an answer will pass it on. Thanks for your patience.

Rashmi


(Zachary Toliver) #4

+1 on this. Has been a bummer for my team. Had to start using Elasticsearch Head and Postman but they aren't as friendly.


(Sivakanth Sattiraju) #5

Just noticed this... crap!!! It is a roadblock to me as well! Appreciate any help in resolving this.


(javier) #6

I noticed this today as well, I couldn't find a work around to enable the extension on chrome :frowning:

I tried

  • elasticsearch-head chrome extension
  • elasticsearch tools chrome application
    I did not like any of those.

So I installed kibana + elastic sense kibana plugin and additionally I had to launch a dummy localhost elasticseach in order to be able to access elastic sense application http://localhost:5601/app/sense

Anyone know if I can have kibana apps without having to launch a elasticsearch instance ?


(kulkarni) #7

Sense plugin was removed from the Chrome store quite awhile ago. We believe, version that was being published in the Chrome web store was a fork we didn’t control.


Sense chrome extension disabled
(apaksha) #8

hi

we had installed kibana but it seems to be not compatible with our version..Any recommendations


(apaksha) #9

any recommendation


#10

While having it integrated into Kabana is nice, if one loads the ELK stack and Kabana is having issues (say Elasticsearch does not come up or is lagging too much ) one's view into the system is limited. My PC box is Windows (no curl/cannot add software)...

Its like Chicken and the Egg trying to solve issues.


(javier) #11

@apakshabhat
I did it with kibana 4.5.0 and elasticsearch 2.3.1
You can download those versions here: https://www.elastic.co/downloads/past-releases


(Sivakanth Sattiraju) #13

Any plans to restore it?


(Mark Walkom) #14

There are currently no plans to make Console a separate plugin.


(Tirthankar Bhowmick) #15

Many of you are having issues with useful chrome sense plugin marked as malware.

Please download this zip file from my dropbox and follow the instructions to install it. Please run the file through some anti-virus to protect yourself. Thanks to this link to help me export chrome extension.

  1. Download and unzip attachment
  2. Go to chrome://extensions
  3. Delete the current Sense plugin installed
    4.. Check developer mode and click on "Load unpacked extension..." and select the unzipped folder.
  4. Most important: Enjoy!


(Taras Kohut) #16

After several minutes chrome disables this plugin as well :frowning:


(Tirthankar Bhowmick) #17

Me or my colleagues did not face this issue. Can you share a screenshot?


(Ismael Alaoui) #18

Tirthankar's solution worked for me. After a couple of days, my plugin is still active.


(Taras Kohut) #19

I'm using chrome on several PC's, and it does plugins sync. I removed old plugin and reinstalled it only on one PC, so I believe after some time synchronization replaced your version by this old one from other PC.
I replaced the plugin on all PC's, and for now everything is ok, so I suspect that was the problem. If the issue will appear again I will send a screenshot.


(Tirthankar Bhowmick) #20

Thanks. I never thought of this. This will help my colleagues having the same issue.


(Teddy Santos) #21

Hi

I also tried Tirthankar's solution, and it does disables after a few minutes.

Would like to ask on how to fix this issue.

Thanks.