Co-ordinate map not working

Unable to use co-ordinate map function in kibana. It doesn't shows any error. Even in my elasticsearch indices all the fields are available but still still it doesn't plot..I am attaching the scrrenchot of indices and mapping of my logstash.

mapping is as follows:
PUT _template/logstash_template
"index_patterns": ["logstash_squidlogs"],
"settings": {
"number_of_shards": 5
"mappings": {
"doc": {
"properties": {
"location": {
"type": "geo_point"

You don't have that field in your data, only geoip.location.

Thanks for fast reply..So what should I do???shall I change

How are you sending the data to Elasticsearch?

via logstash

I am using elk version 6.7.2

Well unless you are changing the index name, the default settings should all work.

Whenever I am using the default setting it says no compatible fields in geo-point

@warkolm can I also get help on this topic too...I am seriously stuck here..previously it was plotted easily I didn't have to change the default mapping for plotting

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.