Configuration of SMTP in elastic cloud

Hi ,

We are using this configuration in elastic cloud for smtp :

xpack.notification.email.account:
exchange_account:
profile: outlook
email_defaults:
from:
smtp:
auth: true
starttls.enable: true
host: smtp.office365.com
port: 587
user:

While saving I get the error below:

'xpack.notification.email.account.exchange_account.profile': is not allowed

Please let us know what is missing.

Hello @spinscale

I am also facing this same issue . I saw a similar discussion in the link below:

Could you please help.

See https://www.elastic.co/guide/en/cloud/current/ec-watcher.html#ec-watcher-whitelist

We had added the email id in the whitelist from the metioned contact settings, but do we any thing like below to be mentioned in user overrides settings in ES in elastic cloud.:

xpack.notification.email.html.sanitization