Could not load plugin descriptor for existing plugin [repository-hdfs]. Was the plugin built before 2.0?


(Jesus) #1

Hi,
I installed the repository-hdfs plugin but I have an error when I run Elasticsearch. This is the error:

./elasticsearch
[2016-09-29 09:37:33,169][WARN ][bootstrap ] unable to install syscall filter: seccomp unavailable: requires kernel 3.5+ with CONFIG_SECCOMP and CONFIG_SECCOMP_FILTER compiled in
[2016-09-29 09:37:33,295][INFO ][node ] [Hammer Harrison] version[2.4.0], pid[8381], build[ce9f0c7/2016-08-29T09:14:17Z]
[2016-09-29 09:37:33,299][INFO ][node ] [Hammer Harrison] initializing ...
Exception in thread "main" java.lang.IllegalStateException: Could not load plugin descriptor for existing plugin [repository-hdfs]. Was the plugin built before 2.0?
Likely root cause: java.nio.file.AccessDeniedException: /home/weblogic/elasticsearch-2.4.0/plugins/repository-hdfs/plugin-descriptor.properties
at sun.nio.fs.UnixException.translateToIOException(UnixException.java:84)
at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:102)
at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:107)
at sun.nio.fs.UnixFileSystemProvider.newByteChannel(UnixFileSystemProvider.java:214)
at java.nio.file.Files.newByteChannel(Files.java:361)
at java.nio.file.Files.newByteChannel(Files.java:407)
at java.nio.file.spi.FileSystemProvider.newInputStream(FileSystemProvider.java:384)
at java.nio.file.Files.newInputStream(Files.java:152)
at org.elasticsearch.plugins.PluginInfo.readFromProperties(PluginInfo.java:87)
at org.elasticsearch.plugins.PluginsService.getPluginBundles(PluginsService.java:378)
at org.elasticsearch.plugins.PluginsService.(PluginsService.java:128)
at org.elasticsearch.node.Node.(Node.java:158)
at org.elasticsearch.node.Node.(Node.java:140)
at org.elasticsearch.node.NodeBuilder.build(NodeBuilder.java:143)
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:194)
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:286)
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:35)
Refer to the log for complete error details.

I do not understand why it is happening.
Can anybody help me, please?


(David Pilato) #2

I think you installed a wrong version.

How did you install your plugin?


(Jesus) #3

I use this command to install my plugin:

bin/plugin install file:///home/weblogic/elasticsearch-2.4.0/elasticsearch-repository-hdfs-2.4.0-hadoop2.zip

I downloaded my plugin then I installed with "bin/plugin install"
I installed elasticsearch 2.4.0. How can I see more plugin version of repository-hdfs?


(David Pilato) #4

Where did you download this file from?


(Jesus) #5

I downloaded it from here:

https://oss.sonatype.org/content/repositories/releases/org/elasticsearch/elasticsearch-repository-hdfs/2.4.0/


(David Pilato) #6

Strange. This file ( https://oss.sonatype.org/content/repositories/releases/org/elasticsearch/elasticsearch-repository-hdfs/2.4.0/elasticsearch-repository-hdfs-2.4.0-hadoop2.zip ) has the plugin-descriptor.properties file in it.

I think you are doing something bad on your side but can't really tell with the details you provided so far.

Can you reproduce the error you have seen with:

  • a fresh clean install of elasticsearch 2.4.0
  • the zip file I linked here downloaded to /tmp
  • bin/plugin install file:///tmp/elasticsearch-repository-hdfs-2.4.0-hadoop2.zip executed with no failure
  • bin/elasticsearch

And report again?

BTW why are you downloading manually the ZIP file?


(Jesus) #7

Finally,
I install Elasticsearch 2.3.1 with this hdfs:

https://oss.sonatype.org/content/repositories/snapshots/org/elasticsearch/elasticsearch-repository-hdfs/2.4.0.BUILD-SNAPSHOT/elasticsearch-repository-hdfs-2.4.0.BUILD-20160418.041409-10-hadoop2.zip

And it worked perfectly.
THANKS!!!


(system) #8