Count Metric goes to 0


#1

Hi,

I am very new to Kibana and Elasticsearch, I am trying to understand the visualizations and their options.

I have some example data in elastisearch, which I can see via the Dev Tools when running the default query. There, I have 46 entries, a couple of them are from the .kibana index, and the rest from my example data .example_data index.

I simply want to create a visual metric showing the entries for the .example_data index, which I thought might just be the easiest thing to start with. So I create a new Metric, choose "Count" and at first, the count actually is correct. However, after the dashboard refreshes again and again, it goes down 1 every time, until it is at 0. The data however is obviously still there. When I put in new data, the count goes up 1 immediately, but then goes down to 0 again.

I have also tried using "Unique Count" and setting the field to "_id". It just stays at 0. I have tried every field I have which is unique, nothing will bring up the actual count of the documents in the index.

I appreciate any help with this.


(Sumit Sontakke) #2

Try selecting different time range on top right corner of kibana dashboard.
What is there?
You must get all the data with time range as


#3

:man_facepalming:

Thanks a lot. I thought the Dashboard had a global state regarding the date. Didn't see that setting.


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.