Curator no output


I am having a weird issue with curator. I did some tests previously running curator manually to take a few snapshots, and it worked.

Now I am running it again and I see nothing happening and nothing in the logs.

Here is my curator config and my action file:

    - SERVER-01
  port: 9200
  use_ssl: True
  certificate: '/CA/CA.cer'
  ssl_no_validate: False
  http_auth: xxxxx:xxxx
  timeout: 30
  master_only: False

  loglevel: DEBUG
  logfile: "/var/log/curator/curator.log"
  logformat: default
  blacklist: []

action file:

    action: snapshot
    description: >-
      Snapshot xxxxx
      repository: backup
      name: curator-%Y%m%d%H%M%S
      ignore_unavailable: False
      include_global_state: True
      partial: False
      wait_for_completion: True
      skip_repo_fs_check: False
      disable_action: False
      continue_if_exception: False
    - filtertype: pattern
      kind: prefix
      value: log-
    - filtertype: age
      source: creation_date
      direction: older
      unit: days
      unit_count: 1
    - filtertype: opened
      exclude: False

When I run curator /path/actionfile.yml, it justs ends and nothing happens. I'm not sure if anything changed since the time it worked before..

Any help is appreciated.


When Curator fails to even log anything (or do you have any logs, and it just terminates after something happens, but not the action?), it's almost always due to badly formatted YAML.

Are there potentially tabs in your action file? YAML will depend on uniform spacing to work properly.

I will check if there are any tabs.

Thanks :slightly_smiling_face:

There does not seem to be any tab spaces.
I also used an action file that works on another server, and I got the same behavior

I don't have any logs at all in curator.log (since the last time it worked)
I am still investigating if there are any other problems.


Do you get any logging at all? If not, it could be the ~/.curator.yml file having strange spacing. It should show something or nothing.


Thanks for your reply. I found out the issue. The certificate file location was changed :crazy_face:
After I fix that, curator runs fine now.

And no there was no logs at all, which would have helped in this case.

Thanks again

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.