[solved] Curator not giving any output


(Sean) #1

I just download the curator prebuild windows executable. I can run it enough for it to tell me it can't find a certain file, but when I give it the correct files it does not produce any logging at all when set to default log level or to debug log level. I've tried configuring it to write to a file and stdout, neither working.
the command I'm giving it to run is

.\curator --config .\curator.yml --dry-run .\action.yml

my config file is

 client:
  hosts:
      - 127.0.0.1
          port: 9200
          url_prefix:
          use_ssl: False
          certificate:
          client_cert:
          client_key:
          ssl_no_validate: False
          http_auth:
          timeout: 30
          master_only: False

          logging:
            loglevel: DEBUG
            logfile:
            logformat: default
            blacklist: ['elasticsearch', 'urllib3']

my action file is

actions:
  1:
    action: delete_indices
    description: >-
      Delete indices older than 6 weeks (based on index name), for logstash-
      prefixed indices. Ignore the error if the filter does not result in an
      actionable list of indices (ignore_empty_list) and exit cleanly.
    options:
      ignore_empty_list: True
      disable_action: True
    filters:
    - filtertype: pattern
      kind: prefix
      value: log_index-
    - filtertype: age
      source: name
      direction: older
      timestring: '%Y.%m.%d'
      unit: weeks
      unit_count: 6

(Sean) #2

Solved!
I had copied the example config file to create mine. I reformatted the host portion and it worked!
final config:

client:
  hosts: [127.0.0.1]
  port: 9200
  url_prefix:
  use_ssl: False
  certificate:
  client_cert:
  client_key:
  ssl_no_validate: False
  http_auth:
  timeout: 30
  master_only: False

logging:
  loglevel: DEBUG
  logfile: 
  logformat: default
  blacklist: ['elasticsearch', 'urllib3']


(Aaron Mildenstein) #3

Yes, YAML is very particular about proper indentation. Way to go solving it yourself!


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.