Currency Format

Hi all,
My data in Elasticsearch index are numbers (integer, long, float) and amounts in euros € currency whitout affecting those are just a number.
I would like to display all amounts with euro € signe.
Unfortunately, any formating in Kibana -> advanced settings -> Currency format does not help.
If I do this formating in Kibana -> advanced settings -> Number format, it would apply changes on all other numbers that are not currency.
Do you have any solution please ?
Best regards

Under Management > Index Patterns you can specify a field formatter per field. The number formatter uses numeraljs for formattering numbers. Checkout out their docs.

Hi ylasri.
Thank you for replaying.

Indeed, there is this option in Advanced Setting as I mentioned in my post.
The problème is that, I have both numbers (which are notre currency money) and numbers which are currency. As ex : 5 plane tickets each 500 € and the sum would be 2500 €
If I format in the advanced setting the Currency format as (0,0.[00]€), it does not affect the currency because all my currency fields are numbers.
And at the same time if change my Number format from 0,0.[000] into (0,0.[00]€) all my numbers will be displayed as currency.
So the Advanced Setting could not solve my problème !
Any Idea ?
Best Regards

The Advanced Setting will be applied to any field with type number
I suggested to define the number format on each index patten/field, so there you will able to apply the formmatting to the specific field you want.

Thank you so much.
I just found it this solution.
It's to much work but better then nothing

Yes, you need to do that for each field :slight_smile:
You are limited by possibilities offered by numeraljs

Is there any template mapping that could do the job ?

Not sure if this is possible from the mapping perspective in elasticsearch
It's more related to Kibana API to define the index pattern and its properties

I mean as a type of field like currency.
I know there isn't one, but it might be helpful if Elastic introduced it.

This is for those who have encountered the same problem.
In Kibana, you have to go to Index Patterns then choose the index in which you want to apply the currency format then edit the selected field and modify its display format as in the image.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.