Custom bundle does not appear in ElasticSearch deployment edit page

Hi there !

I am trying to setup Kiban SSO with Google Suite SAML.
I am following the official doc + using some existing posts out there:

I am blocked at the step to upload a custum bundle with the SAML provider metada.

I have

  • created a custom plugin,
  • uploaded a Zip archive with the required files and directory tree layout as mentionned
  • BUT when trying to add this new bundle to an existing deployment, the bundle / plugin does not show up under the Elasticsearch plugins and settings section .... (Step 8.b)

Then, when trying to apply my changes to the elasticsearch.yml I face a file does not exist ...

Does someone have a clear how-to guide to follow to setup Kibana SSO with SAML provided by Google Gsuite ?


I don;t think that a Google suite specific guide would help you further here. It would mention the same steps as above since Google does not host the metadata for the account's IDP somewhere and you would need to upload a custom bundle.

Your best bet at this stage is to open a support ticket and the support engineer that deals with your case will be able to help you figure out why the bundle doesn't show and what to do to get it uploaded correctly.

Thanks @ikakavas, I have contacted the ElasticCloud support and they explained me why I was not able to see the bundle (I am not using in the right subscription plan)... UX Issue :sweat:

Thank you again for your time and answer !

Nevertheless, I am still interested by a nice and full tutorial on how to setup KIbana SSO with Google (SAML or OIDC) since I am facing an other issue and I am browsing deep in all topics and messages posted on this forum.

@m1kel just wrote one for saml : Step by step guide to enable SAML with G Suite Idp (elastic cloud)

I haven't gone through it so I can't endorse it at this point, but maybe you can take a look and you could also let @m1kel know if you find anything that requires adjustments.

Other than that, feel free to ask any additional questions here regarding anything that is not obvious/clear in our docs ( that you referenced above ) - we do take feedback seriously and we will make necessary adjustments if something is brought up to our attention.

1 Like

Thanks @ikakavas this is exactly what I was looking for and I can confirm you that it works perfectly !

Thank you again for your help and your time !

I can't take any credit for this, thanks @m1kel :smiley:

glad it helps already.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.