Custom URL not directing to correct ML job in Anomaly Explorer from email alert


I generated a few rules to alert on a severity threshold for different Anomaly Detection jobs. Whenever I click the url to open the job in anomaly explorer, it takes me to the same unrelated ML job. I'm using ({{{kibanaBaseUrl}}}{{{context.anomalyExplorerUrl}}}) in my email configuration. What might the reason be that all of my alerts are getting directed to the same ML job?



Were your ml jobs created in custom spaces other than default?

If yes, you might hit this known issue, which was fixed in 8.9 version. If upgrade is not an option, the workaround is to add a URL path component that contains space info between the kibanaBaseUrl and context.anomalyExplorerUrl, e.g.

[Open in Anomaly Explorer]({{{kibanaBaseUrl}}}/s/my-custom-space{{{context.anomalyExplorerUrl}}})


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.