Data Table and large fields


(Maksym Rybnytskyi) #1

Hello,

I have search logs that contains query to database. Sometimes this query can contain more than 300 words(and symbols). I tried to build data table visualization and everything looks ok, but all records with query fiels bigger then approximately 220 symbols do not show up in visualization table. I tried to increase size option - but no luck.
Any advise?

Thanks,
Max.


(Jon Budzenski) #2

Which version of Kibana are you on? Does the table scroll horizontally or cut off?

In newer versions the words should be wrapping, we had https://github.com/elastic/kibana/issues/2025 for tracking it.


(Maksym Rybnytskyi) #3

Hello,
Kibana has version 5.1.2. And the actual problem is missing logs. On dashboard I see all logs. But via data table I do not see all logs. I noticed that there are missing logs with large filed "query". Probably some other logs are missing as well.

Here is my table:

    {
  "title": "Usage Logs with Query",
  "type": "table",
  "params": {
    "perPage": 10,
    "showMeticsAtAllLevels": false,
    "showPartialRows": false,
    "showTotal": false,
    "sort": {
      "columnIndex": null,
      "direction": null
    },
    "totalFunc": "sum"
  },
  "aggs": [
    {
      "id": "1",
      "enabled": true,
      "type": "count",
      "schema": "metric",
      "params": {}
    },
    {
      "id": "2",
      "enabled": true,
      "type": "terms",
      "schema": "bucket",
      "params": {
        "field": "Department.keyword",
        "size": 5,
        "order": "desc",
        "orderBy": "1"
      }
    },
    {
      "id": "4",
      "enabled": true,
      "type": "terms",
      "schema": "bucket",
      "params": {
        "field": "Web_User_Id.keyword",
        "size": 5,
        "order": "desc",
        "orderBy": "1"
      }
    },
    {
      "id": "5",
      "enabled": true,
      "type": "terms",
      "schema": "bucket",
      "params": {
        "field": "User_Full_Name.keyword",
        "size": 5,
        "order": "desc",
        "orderBy": "1"
      }
    },
    {
      "id": "6",
      "enabled": true,
      "type": "terms",
      "schema": "bucket",
      "params": {
        "field": "User_Query.keyword",
        "size": 5,
        "order": "desc",
        "orderBy": "1"
      }
    }
  ],
  "listeners": {}
}

(Maksym Rybnytskyi) #4

I would like to add, that if I enable option "Show partial rows". I see all logs records. But filed with "query" is empty for logs with large "query" filed. Looks like kibana doesn't get correct responce from elasticsearch.


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.