Kibana datatable visualization not displaying all data rows


(Sarra ) #1

Hello,

So I'm working with Kibana 5.5.2 and elasticsearch 5.5.2 to create visualizations and dashboards for our log data.
I've created a new data table visualization but I can't get all the data of last week to be shown at the same time.

Without any sub-buckets, I'm getting the number of finished trips equal to 29. (using count aggregation) but when I split rows based on rider_profile.full_name (A searchable and aggregatable field which is present in all my 29 records), I get a total of only 14 finished trips displayed for the same date range. Actually, I thought I might have a total of 29 finished trips distributed on multiple rows..

But well, I have noticed that the number of rows doesn't exeed 5. It's like I'm getting the top 5 rows of this datatable. (This is the case for all my other data tables).

Is there something I'm missing here? Should I change something in Kibana configuration to display all my datatable rows?

Thanks in advance for your help.


(Sarra ) #2

I have solved this issue, by changing the field size : 5 to another value in my saved objects.

{
  "id": "7",
  "enabled": true,
  "type": "terms",
  "schema": "bucket",
  "params": {
    "field": "full_name",
    "size": 100,
    "order": "desc",
    "orderBy": "1",
    "customLabel": "Rider name"
  }

My question now is, couldn't there be a way to set the size to all ? I want to get all the values of full_name !


(kulkarni) #3

Hi,
Have you tried to increase the size to a greater number like say ~10000 to get all the values ?

https://www.elastic.co/guide/en/elasticsearch/reference/master/search-aggregations-bucket-terms-aggregation.html#_size

Thanks
Rashmi


(Sarra ) #4

Hello rashmi, this is exactly what I'm doing now! Thanks.


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.