Data Visualizer - Import button grayed out for CSV import

I'm unable to import a CSV file to Elasticsearch using the Data Visualizer. I get to upload the file and see the file stats but after that when I type the name of the index the import button remains gray and can't import the data.

Does test.index already exist?

Just tested that and in 7.3.1 it gives you an error below if it does. Have you tried other index names?

Thanks for the quick reply. So, I was working with version 7.9.0 and after seeing your answer I tried with version 7.3.1. It actually works, I can click on import but then I get the following error

I also tried many other index names but same error.

It did work when I unchecked the option create index pattern. Thank you

However, I still need to create the index in order to access the Dashboard but I keep getting the error : Error creating index pattern Forbidden

When you click advanced you can create and edit the index pattern. Or you can create one after you make the index in Management -> Index Patterns.

But I don't understand why this isn't working for you as is.

See this

1 Like

Yes that's what I tried but I keep getting the same error when creating the index using the index Patterns Management.

I also tested with all time filter field names but not working.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.