Import Button Grayed Out for a JSON File Import

I have recently installed and configured ElasticSearch 7.9 along with Kibana 7.9.

When loading a josn file for testing purposes, I manage to arrive to thee data visualization step but cannot finalize this process due to the fact that the "Import" button is greyed out.
Greyed Out

I have tried fiddling around with the index name, index pattern, the settings, but to no avail. And previous topics on this very subject have not been of use to me.

Is there something that I am missing?

Does the user whom you have logged in as have the required privileges to perform the action ?

Thanks
Rashmi

The user that I am logged in as has the "superuser" credentials.

The 7.9.1 update to both elasticsearch and kibana have resolved this issue.