Defining an index pattern in Kibana timing out


(Hirad Khakipour) #1

I have this json log file with only 307 records, but 1416 fields for each record. I loaded them into Elasticsearch, and now I'm trying to visualize them with Kibana, just like what I did with my other log files. I also like to note the other log files all contain tens of thousands of records, but with a fewer number of fields (100~200.)

But when I try to define an index pattern using a wildcard that would contain all 307 records, I get a fatal error saying the request timed out after 30 seconds.

I assumed this problem is due to the large number of fields, but I'm pretty new to Elasticsearch and Kibana, so I need help to see if there's a workaround for this. Maybe adding more nodes? I'm currently just using one node.

Any help would be appreciated.


(Marius Dragomir) #2

Hello,,
On the Kibana end, you can increase the timeout for elasticsearch requests by changing the elasticsearch.requestTimeout setting in your kibana.yml.


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.