Disable Replicate Data on Elasticsearch Cluster

Hello Elastic Team,

I've create Elasticsearch with 3 node, when i send the data, Elasticsearch replicate my original data and consume more storage. How to disable replicated data on Elasticsearch Cluster?



Set index.number_of_replicas to 0 on existing indices. If you want to change the setting by default, use index template function.

1 Like

Thankyou So Much @Tomo_M

1 Like

Hi @Tomo_M , what the impact if set replication to 0 ?

The doc says:

WARNING: Configuring it to 0 may lead to temporary availability loss
during node restarts or permanent data loss in case of data corruption.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.