Documents are not displayed in a space other than the default space

Good afternoon!
I am trying to find out why it happened and how to solve it, but I can not find the key.
Let me tell you: I have created an additional space in kibana with the intention of creating a dashboard that could be displayed by some users. When I copy the necessary objects for the visualization of this dashboard (Goal type visualizations, patterns for the indexes, etc) from the space where I have created and tested it to the new space, no information is loaded, when I access using the Discover menu to the index in question (the pattern is correctly created) I get a message indicating the following:

Search Error

Could not locate that index-pattern-field (id: @timestamp)

Thinking that due to the life cycles configured in the different indexes used, the documents would have been deleted, I have made the same query in Discover from the Default space where I created the dashboard, and from this space the data is displayed.

I have tried to delete and recreate the space, user, patterns and role but it is still the same, I even deleted all the stored objects related to the dashboard with the intention of creating it again by hand, but the problem persists, not finding any document in the index (although it exists) it does not show any information.

Here is my question: how can I find out why, despite having the index pattern, it does not display the documents although from the index manager it appears in the Docs count : 10 column?

Thanks in advance!

Sorry, I just saw why it happened, a query I was making about the index in the role configuration had a typo.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.