ECE ccs.default instance not found


(Rockybean) #1

It looks like a bug in ECE 2.2.0 like below when try to setup a ccs deployment.


(Rockybean) #2

In addition,I upgrade from 2.1.0 to 2.2.0.


(Osykora) #3

I ran into the very same issue. Upgraded from ECE 2.1 to 2.2, attempted to create a new ccs cluster using Cross cluster search template, customized the deployment and the error above showed up.

The root cause is that the deployment template requires an instance template called "ccs.default" which doesn't exist. I fixed that by updating the template and using "data.default" instance template instead.

You can update the template easily by api call https://www.elastic.co/guide/en/cloud-enterprise/current/Templates_-_Deployments.html#set-deployment-template or simply creating an instance template called "ccs.default" might work as well, but I haven't tried.


(Rockybean) #4

Thanks!

I've tried to create on through UI but it doesn't works.

It should work through api. Let me test.


(Yuri Tceretian) #5

Yes, there is missing instance configuration that is used by the template. It will be fixed in 2.2.1 which will be released soon.
I will post the correct instance configuration that you can apply via API. I would not recommend you to create your own "ccs.default" configuration.


(Yuri Tceretian) #6
curl -XPUT 'http://$HOST:12300/api/v1/platform/configuration/instances/ccs.default' \
  -u "admin:$PASSWORD" \
  -H 'Content-Type: application/json' \
  -d '
    {
      "name": "ccs.default",
      "description": "The instance configuration that is used to search data across one or more remote deployments",
      "system_owned": true,
      "instance_type": "elasticsearch",
      "node_types": ["data","master"],
      "discrete_sizes": {
        "sizes": [1024,2048,4096,8192,16384,32768,65536],
        "default_size": 1024,
        "resource": "memory"
      },
      "storage_multiplier": 4
    }'