Elastic 6 Upgrade issues on Elastic Cloud


(Adam Reynolds) #1

When running the Cluster Checkup from ES 5.6.5 I get a message saying "Deprecated script security settings changes" followed by a long list of script security settings.

This Cluster was originally a 2.4.4 cluster, upgraded to 5.2.2 and then up to 5.6.5 in preparation for upgrading to 6.

I can't see any way in Elastic Cloud to reconfigure the script settings (I'm not currently using any scripts so I've tried just disabling them) that will enable me to upgrade the cluster to either 6.0 or 6.1

Has anyone managed it yet?


(Mark Walkom) #2

For support on Elastic Cloud clusters, please see https://www.elastic.co/cloud/as-a-service/support.


(Adam Reynolds) #3

The last time I asked a general question there rather than an 'X is broken' type of request I was told that our support contract doesn't cover consultancy. I'm therefore asking here if anyone else has similar issues. If they haven't I'll raise a support ticket...but it might just be me missing something?


(Mark Walkom) #4

Ok :slight_smile:

Are you sure there aren't any script in use?


(Adam Reynolds) #5

Not as far as I'm aware. I've even tried disabling the 3 types of scripts in the configuration screen. I'm wondering if the upgrade checker, and process, are complaining that the variables still exist in the config rather than the scripts actually being in use.

The documentation linked to says "All of the existing scripting security settings have been removed. Instead they are replaced with script.allowed_types and script.allowed_contexts" whereas the checker says "Details: [node[instance-0000000003] used these script-security settings:[script.inline, script.stored, script.file, script..."

I can't access the config directly in Elastic Cloud afaik??


(Adam Reynolds) #6

To eliminate issues caused by the prior upgrades I've just created a small 5.6.5 (with all the scripting disabled) cluster and without doing anything else to it I ran the upgrade check. I still see the same scripting error
"Deprecated script security settings changes
This issue must be resolved to upgrade. Read Documentation
Details: [node[instance-0000000000] used these script-security settings:[script.inline, script.stored, script.file, script.engine.mustache.inline]]"

I'm going to raise this with Elastic Support and see what they say


(Mark Walkom) #7

Yeh, I would link them to this thread as well.


(dan) #8

I'm hitting the same issue. did you get a result from support?


(Adam Reynolds) #10

ah yes...after digging about it seems that to allow the upgrade to take place you need to Disable the Index & File scripts, and Enable All Inline Scripts.

I assume you can change these settings back after the upgrade is complete. Let me know if that works for you or if I just got lucky! :wink:


(dan) #11

Nope, no change... but thanks for getting back to me! I contacted support for guidance.


(Adam Reynolds) #12

What errors are you seeing in the Upgrade Checker in Kibana?


(Martin Skovvang Petersen) #13

I'm having the same issue. Perhaps he's having the similar error:

Deprecated script security settings changes
This issue must be resolved to upgrade. Read Documentation
Details: [node[instance-0000000018] used these script-security settings:[script.inline, script.stored, script.file, script.engine.mustache.inline]]

I've tried both disabling and enabled all script settings.

My "solution" was to create a new cluster and reindex all old documents by an application script.


(dan) #14

Yeah.. same thing:

Deprecated script security settings changes
This issue must be resolved to upgrade. Read Documentation
Details: [node[instance-0000000002] used these script-security settings:[script.inline, script.stored, script.file, script.engine.mustache.inline]]

Reindexing everything seems painful.. It sounds like this is literally a yml change that we just don't have access to in the UI.. seems like support should be able to assist.


(Adam Reynolds) #15

I did have to reindex where it said I did...and yeah, that's quite a pain, but as long as I had the Index & File scripts disabled and the Inline scripts ALL enabled I was able to upgrade even though the checker gave the 'deprecated script security' error


(system) #16

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.