Elastic Agent 7.10 - Setup - Invalid URL - NULL

Hi, I'm seeing an error "Invalid URL: null" when trying to view any pages related to fleet.

I was testing 7.9.3 in Docker and was able to add a few agents, then upgraded to 7.10.0. Now none of the fleet pages will load. Everything else seems to work though. I can add agents by using the old config scripts in "standalone" mode, but managing any of the Elastic Agents through fleet is not working.

docker-compose logs Stack Trace:

kib01    | 
"tags ["error","plugins","ingestManager"],
"message":"{ TypeError [ERR_INVALID_URL]: Invalid URL: null
   at onParseError (internal/url.js:241:17)
   at new URL (internal/url.js:319:5)
   at getFullAgentPolicyKibanaConfig (/usr/share/kibana/x-pack/plugins/ingest_manager/common/services/full_agent_policy_kibana_config.js:15:26)
   at AgentPolicyService.getFullAgentPolicy (/usr/share/kibana/x-pack/plugins/ingest_manager/server/services/agent_policy.js:505:85)
   at process._tickCallback (internal/process/next_tick.js:68:7) input: 'null' }"}

Any thoughts on what might be happening?

I'm hoping it's possible to fix this in place and retain the current data for a bit even though it's a test environment since I actually found some interesting indicators of compromise.


Hi Chris

Thanks for testing Elastic Agent :slight_smile:

Looks like the Fleet settings are invalid, not sure how it happened, but you can probably try to fix it by removing the settings with the following (and reconfiguring them after)

You can run this as a superuser to delete the settings, they will be recreated after you visit the settings tab in Fleet

POST .kibana/_delete_by_query
  "query": {
    "bool": {
      "must": [
          "terms": {
            "type": [

Let me know if it fix your problem

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.