Elastic Endpoint Security Fundamentals - Lab 1 cannot install Sensor


in the first lab of Elastic Endpoint Security Fundamentals, I run the following command as requested, from an admin prompt:

SensorWindowsInstaller-windows.exe -c SensorWindowsInstaller-windows.cfg -k myAPIKey -d false -l install.log

And I got the following log:

And no sensor is visible in the Sensor tab in the next step.

Can you help me ?

thanks in advance !


Hi Ben,

Sorry you are having issues with the setup. Usually when we see these types of errors it is related to DNS (like most things). Can you do the following:

  1. Confirm the transceiver address in the sensor profile is the same as the server instance
  2. Confirm the API key is correct
  3. Build a new sensor profile and use the IP address instead of the DNS name and see if this works.

If these are unsuccessful, can you post a screenshot of the errors, the sensor profile tab with transceiver address and a picture of the server networking information.

Thanks for your time.


as my training expires in one hour, I won't have the occasion to test it again, I choose to do the course without the lab.

Thanks for your help anyway,




I am stuck on the same stage, and I have tried using the IP address instead of the DNS but the installer times out when trying to connect. Is there something else that could be done?

Thanks for your help!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.