Elastic nodes and kibana on different VM


(Sj Tom) #1

I have deployed elastic nodes, logstash through azure template. i have installed kibana on a separate VM. Kibana is not communicating with elasticsearch.

elasticsearch.yml

cluster.name: "rsxxxxxx"
node.name: "DvELKdata-0"
path.logs: /var/log/elasticsearch
path.data: /datadisks/disk1/elasticsearch/data
discovery.zen.ping.unicast.hosts: ["DvELKmaster-0:9300","DvELKmaster-1:9300","DvELKmaster-2:9300"]
node.master: false
node.data: true
discovery.zen.minimum_master_nodes: 2
network.host: [site, local]
node.max_local_storage_nodes: 1
node.attr.fault_domain: 0
node.attr.update_domain: 0
cluster.routing.allocation.awareness.attributes: fault_domain,update_domain
xpack.license.self_generated.type: trial
xpack.security.enabled: false
bootstrap.memory_lock: true

kibana.yml

Kibana is served by a back end server. This setting specifies the port to use.

#server.port: 5601
#To allow connections from remote users, set this parameter to a non-loopback address.
server.host: "10.2**.1**.11" // [site] of elastic IP

The maximum payload size in bytes for incoming server requests.

#server.maxPayloadBytes: 1048576

The Kibana server's name. This is used for display purposes.![22%20PM|690x435]

#server.name: "your-hostname"

The URL of the Elasticsearch instance to use for all your queries.

elasticsearch.url: "http:/127.0.0.1:9200"


(Mark Walkom) #2

That needs to be the IP of the Elasticsearch host.


(Sj Tom) #3

Thanks for the attention Mark..
I updated the elasticsearch url to http://10.2**.1**.11"

When i visited http://10.2**.1**.11" :5601 - it still says connection refused

kibana.yml
#server.port: 5601
server.host: "10.2**.1**.11"
#server.maxPayloadBytes: 1048576
#server.name: "http://10.2**.1**.11" ::5601"
elasticsearch.url: "http://10.2**.1**.11" ::9200"
#elasticsearch.preserveHost: true

NOTE : Kibana runs on 10.2**.1**.14


(Sj Tom) #4

stderror file:

FATAL { [Error: listen EADDRNOTAVAIL . . . :5601]
cause:
{ [Error: listen EADDRNOTAVAIL . . . :5601]
code: 'EADDRNOTAVAIL',
errno: 'EADDRNOTAVAIL',
syscall: 'listen',
address: ' . . *.11 ',
port: 5601 },
isOperational: true,
code: 'EADDRNOTAVAIL',
errno: 'EADDRNOTAVAIL',
syscall: 'listen',
address: ' . . *.11 ',
port: 5601 }


(Mark Walkom) #5

You also updated server.host. See https://www.elastic.co/guide/en/kibana/current/settings.html for what that means.